Dell Unity: Software upgrade fails with Health Check Error:check_replication

Summary: A Dell Unity Software upgrade fails with 'Health Check Error:check_replication_health_2, check_replication_health_5'. The software update could also fail with 'Warning: check_replication_health_4'. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Upgrade Health Check messages and Events Alert:

Errors
The health check has failed. One or more remote system problems were detected on the system and causes the upgrade to fail. Record the error code and search the Dell Online Support website for available support options.
[Error Code: platform::check_replication_health_2]

-------------------------------------Errors-------------------------------------
Platform: Check replication health
Sync is in progress for the following replication sessions:
         * VRT_xxxx_xx
Action : Cannot perform upgrade while a sync is in progress for a
         replication session. Please wait until the sync completes or pause the
         sessions and retry the upgrade.
ERROR_CODE=platform::check_replication_health_5|Error|VRT_xxxx_xx

Events > Alerts > Information: 
The remote system connection is out of date. Update the connection with the latest interface changes.

Warnings
One or more replication sessions are configured to be auto-synchronized. This could cause a problem during an upgrade. Pause the replication sessions prior to starting the upgrade and resume them after completing the upgrade. 
[Warning Code=platform::check_replication_health_4]

/nas/log/check_health.161031-152020.log
------------------------------------Warnings------------------------------------
Platform: Check replication health
The following replication sessions should be paused prior to starting the upgrade:
         * rep_sess_res_84_res_1_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx
         * rep_sess_res_85_res_2_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx
Action : Since these are auto-synchronized sessions, they could get  into critical state if replication attempts a sync during the upgrade.  To avoid this issue, please pause these sessions before starting the upgrade and resume them after the upgrade.

ERROR_CODE=platform::check_replication_health_4|Warning|rep_sess_nas_44_nas_1_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx
* rep_sess_res_84_res_1_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx
* rep_sess_res_85_res_2_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx
-------------------------------------Errors-------------------------------------
Platform: Check replication health
The following remote systems have health problems:
         * FNMxxxxxxxxxxx
Action : Escalate this issue through your support organization and provide this output in your escalation.
ERROR_CODE=platform::check_replication_health_2|Error|FNMxxxxxxxxxxx
--------------------------------------------------------------------------------
UPGRADE CANNOT PROCEED.
Check Result: Error

spb:~$ uemcli /remote/sys -id RS_1 show -detail |grep Health
      Health state                 = Minor failure (15)
      Health details               = "Update the remote system connection to pick up the latest interface changes on the local and remote systems."

Unisphere > Replication > Connections
Hovering by the Warning triangle shows:
"Update the remote system connection to pick up the latest interface changes on the local and remote systems." 

Cause

  1. For the health check error failure, the underlying cause is that the connection between the two (2) Replication systems must be updated. The Replication Connections require manual updating anytime the Storage Processors (SPs) are rebooted, or the system Management Service has been restarted.
  2. For the Health Check Warning, the Replication Sessions must be paused on the Source system NAS Server and each individual file system.
    NOTE:  Pausing the Source side changes the Destination side replication state to paused.

Resolution

For the Warning message, pause all replication sessions from the Source system, which pauses all respective Destination sessions:
Resolution: Pause all Source Replication sessions
Unisphere > Replication > Sessions > More Actions > Pause


For the Error message failure, update your Replication > Connections:
Resolution:  Update Remote connection from Source system
Unisphere > Replication > Connections > Verify and Update

NOTE:  The Connection should update and show a green check status.

Additional Information


Affected Products

Dell EMC Unity, Dell Unity 450F DC, Dell Unity 300, Dell Unity 300 DC, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell Unity 350F DC, Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity 400, Dell Unity 400 DC, Dell EMC Unity 400F , Dell EMC Unity 450F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Hybrid ...
Article Properties
Article Number: 000058805
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  5
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