Dell Unity:軟體升級失敗,並出現執行狀況檢查錯誤:check_replication
Summary: Dell Unity 軟體升級失敗,並顯示「Health Check Error:check_replication_health_2, check_replication_health_5」。軟體更新也可能失敗,並顯示「警告:check_replication_health_4」。
Symptoms
升級執行狀況檢查訊息和事件警示:
錯誤The health check has failed. One or more remote system problems were detected on the system and causes the upgrade to fail. Record the error code and search the Dell Online Support website for available support options.[Error Code: platform::check_replication_health_2]-------------------------------------Errors-------------------------------------Platform: Check replication healthSync is in progress for the following replication sessions: * VRT_xxxx_xxAction : Cannot perform upgrade while a sync is in progress for a replication session. Please wait until the sync completes or pause the sessions and retry the upgrade.ERROR_CODE=platform::check_replication_health_5|Error|VRT_xxxx_xxEvents > Alerts > Information: The remote system connection is out of date. Update the connection with the latest interface changes.WarningsOne or more replication sessions are configured to be auto-synchronized. This could cause a problem during an upgrade. Pause the replication sessions prior to starting the upgrade and resume them after completing the upgrade. [Warning Code=platform::check_replication_health_4]/nas/log/check_health.161031-152020.log------------------------------------Warnings------------------------------------Platform: Check replication healthThe following replication sessions should be paused prior to starting the upgrade: * rep_sess_res_84_res_1_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx * rep_sess_res_85_res_2_FNMxxxxxxxxxxx_FNMxxxxxxxxxxxAction : Since these are auto-synchronized sessions, they could get into critical state if replication attempts a sync during the upgrade. To avoid this issue, please pause these sessions before starting the upgrade and resume them after the upgrade.ERROR_CODE=platform::check_replication_health_4|Warning|rep_sess_nas_44_nas_1_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx* rep_sess_res_84_res_1_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx* rep_sess_res_85_res_2_FNMxxxxxxxxxxx_FNMxxxxxxxxxxx-------------------------------------Errors-------------------------------------Platform: Check replication healthThe following remote systems have health problems: * FNMxxxxxxxxxxxAction : Escalate this issue through your support organization and provide this output in your escalation.ERROR_CODE=platform::check_replication_health_2|Error|FNMxxxxxxxxxxx--------------------------------------------------------------------------------UPGRADE CANNOT PROCEED.Check Result: Errorspb:~$ uemcli /remote/sys -id RS_1 show -detail |grep Health Health state = Minor failure (15) Health details = "Update the remote system connection to pick up the latest interface changes on the local and remote systems."
Unisphere > 複寫 > 連線
懸停在警告三角形旁會顯示:"Update the remote system connection to pick up the latest interface changes on the local and remote systems."
Cause
- 若執行狀況檢查錯誤失敗,根本原因是必須更新兩 (2) 個複寫系統之間的連線。每次將儲存處理器 (SP) 重新開機,或系統管理服務已重新啟動時,都需要手動更新複寫連線。
- 對於執行狀況檢查警告,必須在來源系統 NAS 伺服器和每個個別檔案系統上 暫停 複製工作階段。
注意: 暫停源端會將目標端複製狀態更改為已暫停。
Resolution
針對警告訊息,請暫停來源系統的所有複寫工作階段,這會暫停所有個別的目的地工作階段:
解決方案:暫停所有來源複寫工作階段
Unisphere > 複寫>工作階段 > 更多動作暫停 >
在錯誤訊息失敗時,請更新您的 複寫>連線:
解決方案: 從來源系統
更新遠端連線Unisphere > 複寫>連線 > 驗證並更新
注意: 連線應會更新,並顯示綠色勾號狀態。