Avamar Client für Windows: Das Avamar-Backup wird nicht mit dem Fehler "avtar Error <18866> abgeschlossen: Nicht genügend Arbeitsspeicher für Cache-Datei" auf Windows-Clients

Summary: Das Ziel dieses KB-Artikels ist es, eine bestimmte Situation zu behandeln, in der der Client für diese Art von Cache-Problem nicht in der Lage ist, mehr Arbeitsspeicher für das Wachstum der Cache-Datei zuzulassen, und welche KB-Artikel-495969 nicht zutrifft. ...

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Symptoms



In diesem Szenario wird das gleiche Problem wie in der Wissensdatenbank dargestellt 495969 die Lösung gilt jedoch aufgrund eines Umgebungsproblems auf einem Windows-Client nicht. Das Problem kann jedes Plug-in betreffen, wie in diesem Fall, wobei der Fehler auf folgende Weise angezeigt wird:   
  • Für FS-Backups:   
avtar Info <8650>: Opening hash cache file 'C:\Program Files\avs\var\p_cache.dat'
avtar Error <18866>: Out of memory for cache file 'C:\Program Files\avs\var\p_cache.dat' size 805306912
avtar FATAL <5351>: MAIN: Unhandled internal exception Unix exception Not enough space

  • Für VSS-Backups:   
avtar Info <8650>: Opening hash cache file 'C:\Program Files\avs\var\p_cache.dat'
avtar Error <18866>: Out of memory for cache file 'C:\Program Files\avs\var\p_cache.dat' size 1610613280
avtar FATAL <5351>: MAIN: Unhandled internal exception Unix exception Not enough space

  • Für Oracle-Backup:   
avtar Info <8650>: Opening hash cache file 'C:\Program Files\avs\var\clientlogs\oracle-prefix-1_cache.dat'
avtar Error <18866>: Out of memory for cache file 'C:\Program Files\avs\var\clientlogs\oracle-prefix-1_cache.dat' size 100663840
avtar FATAL <5351>: MAIN: Unhandled internal exception Unix exception Not enough space

or this variant:   

avtar Info <8650>: Opening hash cache file 'C:\Program Files\avs\var\clientlogs\oracle-prefix-1_cache.dat'
avtar Error <18864>: Out of restricted memory for cache file 'C:\Program Files\avs\var\clientlogs\oracle-prefix-1_cache.dat' size 100663840
avtar FATAL <5351>: MAIN: Unhandled internal exception Unix exception Not enough space 
avoracle Error <7934>: Snapup of <oracle-db> aborted due to rman terminated abnormally - check the logs


  • Das RMAN-Protokoll meldet Folgendes:   
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of backup plus archivelog command at 06/14/2018 22:17:40
RMAN-03009: failure of backup command on c0 channel at 06/14/2018 22:17:15
ORA-04030: out of process memory when trying to allocate 1049112 bytes (KSFQ heap,KSFQ Buffers)
Recovery Manager complete.


Ursprünglich dachte man, die Cache-Datei könne aufgrund eines falschen "hashcachemax"-Werts nicht größer werden.

Der Client hatte viel freien RAM (48 GB Gesamt-RAM), also haben wir den Wert des Flags von -16 (max. 3 GB Dateigröße) auf -8 (max. 6 GB Dateigröße) erhöht.

Aber das Problem blieb bestehen, und auch der Speicherplatz war kein Problem, es gab viele GB freien Speicherplatz.

Cause

Weitere Untersuchungen mit einer Testbinärdatei des Engineering-Teams führten dazu, dass das MS OS nicht genügend ungenutzten und zusammenhängenden Speicher freigab, der erforderlich war, um die gesamte Hash-Cache-Datei für den Backup-Vorgang zuzuweisen/in den Speicher zu laden.

Es wurde mit einer Testbinärdatei versucht, die den Speicher in kleinere Stücke aufteilt, um zu sehen, ob wir den Punkt erreichen können, an dem das Betriebssystem es zulässt, dass die vollständige Datei p_cache.dat in den Speicher geladen wird, aber auch das hat nicht geholfen. Das Betriebssystem ließ aus irgendeinem Grund immer noch nicht zu, dass die Datei in den Arbeitsspeicher geladen wurde.

Die Ursache ist irgendwo im Betriebssystem verborgen, aber in diesem Fall haben wir das MS-Team nicht für weitere Untersuchungen hinzugezogen.

Stattdessen haben wir einen Weg gefunden, das Problem zu umgehen, indem wir die Cache-Datei kleiner eingestellt haben. Details finden Sie im Abschnitt "Lösung" unten.

Resolution

Um dieses Problem zu umgehen, haben wir die Hash-Cache-Datei auf eine kleinere Größe festgelegt, damit das Betriebssystem keine Probleme bei der Zuweisung in den Arbeitsspeicher hat.

In diesem Fall wurde festgestellt, dass das Betriebssystem auch Probleme bei der Zuweisung kleinerer Größen wie 200+ MB hatte, so dass wir beschlossen, die Größe der p_cache.dat mit der Verwendung des folgenden Flags auf nur 100 MB umzustellen:   

--hashcachemax=100

Auf diese Weise würde die Hash-Cache-Datei nie über 100 MB wachsen und die alten Einträge würden überschrieben.

Nach dem Hinzufügen dieses Flags empfiehlt es sich, die Cachedatei zu recyceln, indem Sie die p_cache.dat umbenennen oder löschen (Umbenennen ist die bevorzugte Option).

Nach dem ersten Backup, das wie erwartet länger als gewöhnlich dauern würde (um die Cachedatei neu zu erstellen), sollte das Problem behoben sein.

Additional Information

  • Der bedarfsorientierte Auslagerungscache wird in diesem Szenario nicht empfohlen, da die Backups an den GSAN-Speicher geleitet werden, sodass der monolithische Auslagerungscache verwendet wurde.
  • Demand-Paging wurde entwickelt, um Vorteile für Backups zu erzielen, die an den DataDomain-Storage gesendet werden.

Affected Products

Avamar

Products

Avamar, Avamar Client for Windows, Avamar Plug-in for Oracle
Article Properties
Article Number: 000060137
Article Type: Solution
Last Modified: 17 Jun 2025
Version:  3
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