Klient Avamar dla systemu Windows: Kopia zapasowa Avamar nie kończy się z błędem "avtar Error <18866>: Brak pamięci dla pliku pamięci podręcznej" na klientach z systemem Windows

Summary: Celem tego artykułu bazy wiedzy jest rozwiązanie konkretnej sytuacji, w której w przypadku tego typu problemu z pamięcią podręczną klient nie jest w stanie dopuścić do zwiększenia ilości pamięci dla pliku pamięci podręcznej i który artykuł bazy wiedzy 495969 nie ma zastosowania. ...

:-brak-pamięci-dla-pliku-pamięci-podręcznej"-na-klientach-z-systemem-windows" />
This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



W tym scenariuszu mamy ten sam problem przedstawiony co w 495969 bazy wiedzy, jednak rozwiązanie nie ma zastosowania ze względu na problem ze środowiskiem na kliencie Windows. Problem może dotyczyć dowolnej wtyczki, tak jak w tym przypadku, z błędem przedstawionym w następujący sposób:   
  • W przypadku kopii zapasowych systemu plików FS:   
avtar Info <8650>: Opening hash cache file 'C:\Program Files\avs\var\p_cache.dat'
avtar Error <18866>: Out of memory for cache file 'C:\Program Files\avs\var\p_cache.dat' size 805306912
avtar FATAL <5351>: MAIN: Unhandled internal exception Unix exception Not enough space

  • W przypadku kopii zapasowych VSS:   
avtar Info <8650>: Opening hash cache file 'C:\Program Files\avs\var\p_cache.dat'
avtar Error <18866>: Out of memory for cache file 'C:\Program Files\avs\var\p_cache.dat' size 1610613280
avtar FATAL <5351>: MAIN: Unhandled internal exception Unix exception Not enough space

  • W przypadku kopii zapasowej Oracle:   
avtar Info <8650>: Opening hash cache file 'C:\Program Files\avs\var\clientlogs\oracle-prefix-1_cache.dat'
avtar Error <18866>: Out of memory for cache file 'C:\Program Files\avs\var\clientlogs\oracle-prefix-1_cache.dat' size 100663840
avtar FATAL <5351>: MAIN: Unhandled internal exception Unix exception Not enough space

or this variant:   

avtar Info <8650>: Opening hash cache file 'C:\Program Files\avs\var\clientlogs\oracle-prefix-1_cache.dat'
avtar Error <18864>: Out of restricted memory for cache file 'C:\Program Files\avs\var\clientlogs\oracle-prefix-1_cache.dat' size 100663840
avtar FATAL <5351>: MAIN: Unhandled internal exception Unix exception Not enough space 
avoracle Error <7934>: Snapup of <oracle-db> aborted due to rman terminated abnormally - check the logs


  • Dziennik RMAN zgłasza to:   
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of backup plus archivelog command at 06/14/2018 22:17:40
RMAN-03009: failure of backup command on c0 channel at 06/14/2018 22:17:15
ORA-04030: out of process memory when trying to allocate 1049112 bytes (KSFQ heap,KSFQ Buffers)
Recovery Manager complete.


Początkowo sądzono, że plik pamięci podręcznej nie może się powiększyć z powodu nieprawidłowej wartości "hashcachemax".

Klient miał dużo wolnej pamięci RAM (łącznie 48 GB pamięci RAM), więc zwiększyliśmy wartość flagi z -16 (maksymalny rozmiar pliku 3 GB) do -8 (maksymalny rozmiar pliku 6 GB).

Ale problem nadal występował, a miejsce na dysku również nie było problemem, było dużo GB wolnego miejsca.

Cause

Dalsze badania z testowym plikiem binarnym zespołu inżynierów doprowadziły do faktu, że system operacyjny MS nie zwalniał wystarczającej ilości nieużywanej i ciągłej pamięci wymaganej do przydzielenia/załadowania do pamięci całego pliku pamięci podręcznej skrótu dla operacji tworzenia kopii zapasowej.

Próbowano tego z testowym plikiem binarnym, który przydzielał pamięć w mniejszych częściach, aby sprawdzić, czy możemy osiągnąć punkt, w którym system operacyjny pozwoli na załadowanie pełnego pliku p_cache.dat do pamięci, ale to również nie pomogło. System operacyjny z jakiegoś powodu nadal nie pozwalał na załadowanie pliku do pamięci.

Główna przyczyna jest ukryta gdzieś w systemie operacyjnym, jednak w tym przypadku nie zaangażowaliśmy zespołu MS w dalsze badania po jego stronie.

Zamiast tego znaleźliśmy sposób na obejście problemu, ustawiając plik pamięci podręcznej na mniejszy. Zobacz szczegóły w sekcji rozwiązań poniżej.

Resolution

Aby obejść ten problem, ustawiliśmy mniejszy rozmiar pliku pamięci podręcznej skrótu, aby system operacyjny nie miał problemów z przydzieleniem go do pamięci.

W tym przypadku zauważono, że system operacyjny miał również problemy z przydzielaniem mniejszych rozmiarów, takich jak 200+ MB, więc zdecydowaliśmy się zmienić rozmiar p_cache.dat na zaledwie 100 MB za pomocą następującej flagi:   

--hashcachemax=100

W ten sposób plik pamięci podręcznej skrótu nigdy nie przekroczy 100 MB i zastąpi stare wpisy.

Po dodaniu tej flagi należy ponownie wykorzystać plik pamięci podręcznej poprzez zmianę nazwy lub usunięcie p_cache.dat (zmiana nazwy jest preferowaną opcją).

Po wykonaniu pierwszej kopii zapasowej, która zgodnie z oczekiwaniami potrwa dłużej niż zwykle (odbudowa pliku pamięci podręcznej), problem powinien zostać rozwiązany.

Additional Information

  • Pamięć podręczna stronicowania na żądanie nie jest zalecana w tym scenariuszu, ponieważ kopie zapasowe są kierowane do magazynu GSAN, więc użyto monolitycznej pamięci podręcznej stronicowania.
  • Stronicowanie na żądanie zaprojektowano w celu uzyskania korzyści z wysyłania kopii zapasowych do pamięci masowej DataDomain.

Affected Products

Avamar

Products

Avamar, Avamar Client for Windows, Avamar Plug-in for Oracle
Article Properties
Article Number: 000060137
Article Type: Solution
Last Modified: 17 Jun 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.