Avamar Client для Windows. Резервное копирование Avamar не завершается с ошибкой «avtar Error <18866>: «Out memory for cache file» на клиентах Windows

Summary: Целью данной статьи базы знаний является рассмотрение конкретной ситуации, в которой для решения проблемы с кэшем данного типа клиент не может разрешить увеличение объема памяти для файла кэша, и эта статья базы знаний, 495969 которой не применяется. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



В этом сценарии мы сталкиваемся с той же проблемой, что и в 495969 базы знаний, однако решение не применяется из-за проблемы со средой на клиенте Windows. Проблема может затронуть любой плагин, как в этом случае, с ошибкой, представленной следующим образом:   
  • Для резервных копий файловой системы:   
avtar Info <8650>: Opening hash cache file 'C:\Program Files\avs\var\p_cache.dat'
avtar Error <18866>: Out of memory for cache file 'C:\Program Files\avs\var\p_cache.dat' size 805306912
avtar FATAL <5351>: MAIN: Unhandled internal exception Unix exception Not enough space

  • Для резервных копий VSS:   
avtar Info <8650>: Opening hash cache file 'C:\Program Files\avs\var\p_cache.dat'
avtar Error <18866>: Out of memory for cache file 'C:\Program Files\avs\var\p_cache.dat' size 1610613280
avtar FATAL <5351>: MAIN: Unhandled internal exception Unix exception Not enough space

  • Для резервного копирования Oracle:   
avtar Info <8650>: Opening hash cache file 'C:\Program Files\avs\var\clientlogs\oracle-prefix-1_cache.dat'
avtar Error <18866>: Out of memory for cache file 'C:\Program Files\avs\var\clientlogs\oracle-prefix-1_cache.dat' size 100663840
avtar FATAL <5351>: MAIN: Unhandled internal exception Unix exception Not enough space

or this variant:   

avtar Info <8650>: Opening hash cache file 'C:\Program Files\avs\var\clientlogs\oracle-prefix-1_cache.dat'
avtar Error <18864>: Out of restricted memory for cache file 'C:\Program Files\avs\var\clientlogs\oracle-prefix-1_cache.dat' size 100663840
avtar FATAL <5351>: MAIN: Unhandled internal exception Unix exception Not enough space 
avoracle Error <7934>: Snapup of <oracle-db> aborted due to rman terminated abnormally - check the logs


  • Журнал RMAN сообщает следующее:   
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of backup plus archivelog command at 06/14/2018 22:17:40
RMAN-03009: failure of backup command on c0 channel at 06/14/2018 22:17:15
ORA-04030: out of process memory when trying to allocate 1049112 bytes (KSFQ heap,KSFQ Buffers)
Recovery Manager complete.


Изначально считалось, что файл кэша не может увеличиваться в размерах из-за неверного значения «hashcachemax».

У клиента было много свободной оперативной памяти (всего 48 ГБ ОЗУ), поэтому мы увеличили значение флага с -16 (макс. размер файла 3 ГБ) до -8 (макс. размер файла 6 ГБ).

Но проблема оставалась, и дисковое пространство также не было проблемой, было много гигабайт свободного места.

Cause

Дальнейшие исследования с тестовым двоичным файлом, проведенные группой инженеров, привели к тому, что ОС MS не освобождала достаточно неиспользуемой и непрерывной памяти, необходимой для выделения/загрузки в память всего хеш-файла кэш-памяти для операции резервного копирования.

Он был опробован с тестовым двоичным файлом, который распределял память на более мелкие части, чтобы посмотреть, сможем ли мы достичь точки, когда ОС позволит загружать в память весь файловый p_cache.dat, но это также не помогло. Операционная система по-прежнему не позволяла загрузить файл в память по какой-то причине.

Первопричина скрыта где-то в ОС, однако в данном случае мы не привлекали команду MS для дальнейших расследований на их стороне.

Вместо этого мы нашли способ обойти эту проблему, установив меньший размер файла кэша. Подробнее см. в разделе о решении ниже.

Resolution

Чтобы обойти эту проблему, мы установили для хеш-файла кэша меньший размер, чтобы у ОС не возникало проблем с его выделением в память.

В этом случае было замечено, что ОС также испытывает проблемы с выделением меньших размеров, таких как 200+ МБ, поэтому мы решили изменить размер p_cache.dat до 100 МБ с помощью следующего флага:   

--hashcachemax=100

Таким образом, размер файла хеш-кэша никогда не превысит 100 МБ и перезапишет старые записи.

После добавления этого флага необходимо переработать файл кэша, переименовав или удалив p_cache.dat (переименование является предпочтительным вариантом).

После первого резервного копирования, которое обычно занимает больше времени, чем ожидалось (для восстановления файла кэша), проблема должна исчезнуть.

Additional Information

  • В этом сценарии не рекомендуется использовать кэш подкачки по требованию, так как резервные копии направляются в хранилище GSAN, поэтому использовался монолитный кэш подкачки.
  • Подкачка по требованию была разработана для получения преимуществ от отправки резервных копий в хранилище DataDomain.

Affected Products

Avamar

Products

Avamar, Avamar Client for Windows, Avamar Plug-in for Oracle
Article Properties
Article Number: 000060137
Article Type: Solution
Last Modified: 17 Jun 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.