VxRail: Falla durante la actualización previa a 4.0 y versiones posteriores
Summary: VxRail puede tener una falla durante una actualización previa a 4.0 o superior. A continuación, se presentan varias situaciones para una resolución.
Symptoms
Hay varios escenarios que dan lugar a este problema. Consulte la sección Resolución para conocer los posibles problemas y las correcciones correspondientes.
Cause
Los errores de servicio interno para la falla de la operación de carga offline pueden deberse a uno de los siguientes escenarios en la sección Resolución.
Resolution
Problema #1: No hay suficiente espacio para el paquete compuesto desempaquetado (se requieren 2,35 * compositeBundleSize).
Posible solución: Intente limpiar el sistema de archivos (elimine los archivos temporales y cualquier otro archivo no utilizado) en la máquina virtual de VxRail Manager para obtener el espacio necesario 2,35 * compositeBundleSize.
NOTA: Si la actualización comienza desde ciertos niveles de código, es necesario un proceso manual para expandir la partición de disco en VxRail Manager antes de la actualización. Comuníquese con el soporte de Dell para obtener más ayuda.
Problema #2: La plataforma de hardware de ESXi no es compatible con el paquete de actualización de ESXi que se encuentra en el paquete compuesto.
Posible solución: La plataforma de hardware existente no es compatible con el paquete de actualización usado. Esto se debe a que la información del proveedor de hardware de ESXi no coincide con el paquete de actualización de ESXi en el paquete compuesto. Para resolver este problema, asegúrese de obtener el paquete de descarga que coincida con la información del proveedor de hardware ESXi desde el sitio de descarga de Dell o la categoría ACG.
Problema #3: la versión de vCenter no es compatible con el paquete de actualización de ESXi que se encuentra en el paquete compuesto.
Posible solución: La versión de ESXi objetivo debe ser compatible con la versión de vCenter instalada. Por lo general, esto sucede en el contexto de VC externo. Esto significa que la versión VC queda rezagada. Para resolver esto, actualice el VC externo con la versión que coincida con la versión de ESXi incluida.
Problema #4: La plataforma de hardware ESXi no es compatible con el paquete de actualización de VIB que se encuentra en el paquete compuesto.
Posible solución: La versión de VIB objetivo debe ser compatible con la versión instalada de la plataforma ESXi. Esto se debe a que el paquete VIB incluido no coincide con la información del proveedor de hardware de ESXi. Para resolver este problema, asegúrese de obtener el paquete de descarga que coincida con la información del proveedor de hardware ESXi desde el sitio de descarga de Dell o la categoría ACG.
Problema #5: Se produce un error al leer el paquete de actualización cargado desde el almacenamiento temporal de Tomcat.
Posible solución: Intente limpiar el sistema de archivos (elimine los archivos temporales y cualquier otro archivo no utilizado) en la máquina virtual de VxRail Manager y reinicie el servicio. Póngase en contacto con el servicio al cliente si el problema no se resuelve después.
Problema #6: No se pudo obtener la versión actual de ESXi del host.
Posible solución: Por lo general, se debe a la pérdida de conexión del host con VC. Verifique que la conexión del host sea correcta entre VC y el host.
Problema #7: No se pudo obtener la versión actual del VIB de VxRail del host
Posible solución: Por lo general, se debe a la pérdida de conexión del host con VC o a la ausencia del VIB de VxRail en el host. Verifique que la conexión del host esté bien entre VC y el host o que se instale el VIB de VxRail.
Problema #8: El servicio de plataforma aún no está instalado o listo
Posible solución: Puede haber muchas causas que provoquen un error en el servicio de plataforma. Comuníquese con el servicio al cliente cuando se produzca este problema.
Problema #9: La plataforma Quanta no se soporta para actualizar a 7.x.
Posible solución: Ninguno
Problema #10: La verificación de integridad del paquete de actualización falló.
Posible solución 1: Cuando el mensaje de error contiene "Falla de comprobación previa: No se pudo verificar la cadena de certificados". O "Falla de comprobación previa: No se pudo verificar la firma del archivo de manifiesto", descargue un nuevo paquete de actualización y vuelva a intentar la actualización.
Posible solución 2: Cuando el mensaje de error contiene "Falla de comprobación previa: No se pudo verificar el archivo de manifiesto", si utiliza la API pública v5 para actualizar y el paquete de actualización está personalizado (VxRail solo admite la eliminación de componentes de actualización innecesarios del paquete de actualización, no admite la adición ni la modificación de componentes de actualización), consulte la Guía del usuario de la API de VxRail más reciente para comprobar el nuevo uso de parámetros para la API v5. De lo contrario, descargue un nuevo paquete de actualización y vuelva a intentar la actualización.
Problema #11: TPM1.2 está habilitado en el clúster de VxRail 14G (versión 4.7.x o 7.0.x), por lo que la actualización a VxRail 8.0.000 se bloqueará.
Posible solución: Consulte el artículo 000204703 para conocer las opciones.
Problema #12: El paquete de actualización es para las plataformas Dell VxRail 14G y posteriores. No puede instalarlo en plataformas 13G.
Posible solución: VxRail 7.0.411 es la última versión de VxRail 7.0.x recomendada para que estos sistemas Dell VxRail 13G se actualicen. No podrá actualizar a una versión posterior si tiene un nodo 13G en el clúster.
Problema #13: La carga del paquete fallaba cuando la LCM de 4.7.212 o versiones anteriores pasaba directamente a 7.0.480.
Posible solución: Si la versión actual del clúster es inferior a 4.7.300, no se soporta la actualización directa a 7.0.480. Compruebe las notas de la versión 7.0.480 para conocer la ruta de actualización directa compatible, actualice el clúster a cualquiera de las versiones compatibles primero (p. ej., 4.7.300) y, a continuación, continúe con la actualización a 7.0.480.
Problema #14: No se pudo cargar el paquete. El mensaje de error mostraba "No se pudo actualizar la utilidad VxRail Radar porque /mystic/radar owership no es tcserver".
Posible solución: Inicie sesión en VxRail Manager mediante SSH y ejecute el comando: su chown -R tcserver:pivotal /mystic/radar
Problema #15: No se pudo cargar el paquete debido a que la actualización es de un modelo, una versión o un modo LCM no compatibles.
Posible solución: Consulte las notas de la versión para comprobar si se soporta la actualización actual.