VxRail: Errore durante il pre-aggiornamento alla versione 4.0 e successive
Summary: VxRail potrebbe riscontrare un errore durante un pre-aggiornamento alla versione 4.0 o successiva. Di seguito sono riportati diversi scenari per una risoluzione.
Symptoms
Esistono diversi scenari che causano questo problema. Consultare la sezione Risoluzione per informazioni sui possibili problemi e sulle relative correzioni.
Cause
Gli errori interni del servizio per l'errore dell'operazione di caricamento offline possono essere dovuti a uno dei seguenti scenari nella sezione Risoluzione.
Resolution
Problema 1: Non c'è spazio sufficiente per il pacchetto composito decompresso (richiesto 2,35 * compositeBundleSize).
Possibile soluzione: Provare a ripulire il file system (eliminare i file temporanei e qualsiasi altro file inutilizzato) sulla macchina virtuale VxRail Manager per ottenere lo spazio richiesto 2,35 * compositeBundleSize.
NOTA: Se l'aggiornamento viene avviato da determinati livelli di codice, prima dell'aggiornamento viene richiesto un processo manuale per espandere la partizione del disco su VxRail Manager. Contattare il Supporto Dell per ulteriore assistenza.
Problema 2: La piattaforma hardware ESXi non è compatibile con il pacchetto di aggiornamento ESXi incluso nel pacchetto composito.
Possibile soluzione: La piattaforma hardware esistente non è compatibile con il pacchetto di aggiornamento utilizzato. Ciò è dovuto al fatto che le informazioni del fornitore dell hardware ESXi non corrispondono al pacchetto di aggiornamento ESXi nel pacchetto composito. Per risolvere questo problema, assicurarsi di ottenere il pacchetto di download corrispondente alle informazioni del fornitore dell hardware ESXi dal sito di download Dell o dalla categoria ACG.
Problema #3: la versione di vCenter non è compatibile con il pacchetto di aggiornamento ESXi che nel pacchetto composito.
Possibile soluzione: La versione ESXi di destinazione deve essere compatibile con la versione di vCenter installata. Ciò si verifica in genere in un contesto VC esterno. Significa che la versione VC rimane indietro. Per risolvere questo problema, aggiornare il VC esterno alla versione corrispondente alla versione ESXi inclusa.
Problema #4: La piattaforma hardware ESXi non è compatibile con il pacchetto di aggiornamento VIB incluso nel pacchetto composito.
Possibile soluzione: La versione VIB di destinazione deve essere compatibile con la versione della piattaforma ESXi installata. Ciò è dovuto al fatto che il pacchetto VIB incluso non corrisponde alle informazioni del fornitore dell hardware ESXi. Per risolvere questo problema, assicurarsi di ottenere il pacchetto di download corrispondente alle informazioni del fornitore dell hardware ESXi dal sito di download Dell o dalla categoria ACG.
Problema #5: Si verifica un errore durante la lettura del pacchetto di aggiornamento caricato dallo storage temporaneo Tomcat.
Possibile soluzione: Provare a ripulire il file system (eliminare i file temporanei e qualsiasi altro file inutilizzato) sulla macchina virtuale VxRail Manager e riavviare il servizio. Contattare il servizio clienti se il problema non viene risolto.
Problema #6: Impossibile ottenere la versione ESXi corrente dell host.
Possibile soluzione: In genere è causato dalla perdita della connessione host con VC. Verificare che la connessione host tra VC e l'host sia corretta.
Problema #7: Impossibile ottenere la versione VIB VxRail corrente dell host
Possibile soluzione: In genere è causato dalla perdita della connessione host con VC oppure dalla mancanza di VIB VxRail dall host. Verificare che la connessione host tra VC e l'host o VxRail VIB venga installato.
Problema #8: Platform Service non è ancora installato o pronto
Possibile soluzione: Ci possono essere molte cause che provocano l'errore del servizio della piattaforma. Contattare l'assistenza clienti quando si verifica questo problema.
Problema #9: La piattaforma Quanta non è supportata per l'aggiornamento alla versione 7.x.
Possibile soluzione: None
Problema #10: La verifica dell'integrità del pacchetto di aggiornamento non è riuscita.
Possibile soluzione 1: Quando il messaggio di errore contiene "Errore di controllo preliminare: Impossibile verificare la catena di certificati." O "Errore di controllo preliminare: Impossibile verificare la firma del file manifesto.", scaricare un nuovo pacchetto di aggiornamento e riprovare l'aggiornamento.
Possibile soluzione 2: Quando il messaggio di errore contiene "Errore di controllo preliminare: Impossibile verificare il file manifesto.", se utilizza l'API pubblica v5 per l'aggiornamento e il pacchetto di aggiornamento è personalizzato (VxRail supporta solo la rimozione di componenti di aggiornamento non necessari dal pacchetto di aggiornamento, non supporta l'aggiunta o la modifica di componenti di aggiornamento), consultare la Guida utente dell'API VxRail più recente per verificare l'utilizzo dei nuovi parametri per l'API v5. In caso contrario, scaricare un nuovo pacchetto di aggiornamento e riprovare a eseguire l'aggiornamento.
Problema #11: TPM1.2 è abilitato sul cluster VxRail 14G (versione 4.7.x o 7.0.x), pertanto l'aggiornamento a VxRail 8.0.000 verrà bloccato.
Possibile soluzione: Vedere l'articolo 000204703 per le opzioni.
Problema #12: Il pacchetto di aggiornamento è per le piattaforme Dell VxRail 14G e successive. Non è possibile installarlo su piattaforme 13G.
Possibile soluzione: VxRail 7.0.411 è l'ultima versione VxRail 7.0.x consigliata per l'upgrade di questi sistemi Dell VxRail 13G. Non sarà possibile eseguire l'aggiornamento a una versione successiva se si dispone di un nodo 13G nel cluster.
Problema #13: Il caricamento del pacchetto non riusciva quando LCM dalla versione 4.7.212 o precedente direttamente alla 7.0.480.
Possibile soluzione: Se la versione corrente del cluster è inferiore a 4.7.300, non è supportato l'aggiornamento diretto alla versione 7.0.480. Controllare le note di rilascio della versione 7.0.480 per il percorso di aggiornamento diretto supportato e aggiornare prima il cluster a una delle versioni supportate (ad esempio 4.7.300), quindi procedere con l'aggiornamento alla versione 7.0.480.
Problema #14: Impossibile caricare il pacchetto. Il messaggio di errore mostrava "Impossibile aggiornare l'utilità VxRail Radar because /mystic/radar owership is not tcserver".
Possibile soluzione: Accedere a VxRail Manager tramite ssh ed eseguire il comando: su chown -R tcserver:pivotal /mystic/radar
Problema #15: Impossibile caricare il pacchetto poiché l'aggiornamento proviene da un modello, una versione o una modalità LCM non supportati.
Possibile soluzione: Fare riferimento alle note di rilascio per verificare se l'aggiornamento corrente è supportato.