Data Domain: przesyłanie pliku rpm DDOS za pomocą GUI (Data Domain System Manager) może wypełnić partycję /ddr

Summary: Przesłanie pliku RPM DDOS za pomocą graficznego interfejsu użytkownika (Data Domain System Manager) może wypełnić partycję /ddr

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Plik DDOS RPM jest najpierw zapisywany w katalogu /ddr/gui/temp podczas przesyłania za pomocą graficznego interfejsu użytkownika (DDSM). Po przesłaniu plik RPM jest przenoszony do katalogu /ddr/var/releases.

Jeśli w /ddr zabraknie miejsca podczas przesyłania, może to wpłynąć na aktualizacje rejestru i spowodować PANIC / ponowne uruchomienie systemu plików.  Może to mieć również wpływ na inne usługi (dd_procmon, dd_hd_rdb_tool, netmon, scm, sms itp.), które zapisują dane do /ddr.

Poniżej przedstawiono przykłady błędów, które można zobaczyć w messages.engineering, gdy /ddr jest pełny (uwaga: błędy nie wskazują, że /ddr/ został zapełniony z powodu nieudanego przesyłania RPM):

 
Jan 22 12:17:15 dd6300 dd_hd_rdb_tool: ERROR: Błąd 13 kroku SQL rejestru /ddr/registry/p0/alerts_local.db3 SQL step 'step insert value' 13 (baza danych lub dysk są pełne) (ponawia=0)


Jan 22 12:17:23 dd6300 ddfs[30031]: ERROR: Błąd 13 kroku SQL "step insert value" rejestru /ddr/registry/m0/system.db3 (baza danych lub dysk są pełne) (liczba prób = 0)
Jan 22 12:17:23 dd6300 ddfs[30031]: ERROR: Rejestr /ddr/registry/m0/system.db3 Błąd SQL 13 (baza danych lub dysk są pełne): zresetuj wstaw wartość

sty 22 12:17:19 dd6300 netmon: ERROR: Błąd \ddr/registry/p0/config.db3 SQL step 'step insert value' 13 (baza danych lub dysk jest pełny) (liczba prób = 0)
sty 22 12:17:19 dd6300 netmon: ERROR: Rejestr /ddr/registry/p0/config.db3 Błąd SQL 13 (baza danych lub dysk jest pełny): Zresetuj wstaw wartośćW innych przypadkach, nawet jeśli w katalogu /ddr nie zabraknie całkowicie miejsca, wykorzystanie miejsca może stać się na tyle duże, że uniemożliwi uaktualnienie.  
Poniżej przedstawiono przykład niepowodzenia sprawdzania wstępnego uaktualnienia: 

# wstępne sprawdzanie aktualizacji systemu 7.1.0.5-643969.rpmTrwa sprawdzanie wstępne aktualizacji:
Istotność problemu z węzłem Rozwiązanie---- -------- ------------------------------ --------0 KRYTYCZNE wykorzystanie /ddr wynosi 93% wolnego miejsca w /ddr---- -------- ------------------------------ --------Węzeł 0: faza 1/1 (wstępne sprawdzenie 100%)**** Wstępne sprawdzenie uaktualnienia wykryło 1 problem(y) blokujący. 

Cause

Partycja /ddr ma ograniczoną przestrzeń w kilku modelach DDR.  Ponadto rozmiar RPM DDOS w nowszych wersjach (takich jak DDOS 7.x) jest większy, więc istnieje prawdopodobieństwo, że większy rozmiar RPM DDOS w połączeniu z mniejszą (i w połowie pełną) partycją /ddr w niektórych modelach DD może spowodować brak miejsca na dysku w katalogu /ddr podczas przesyłania RPM za pośrednictwem graficznego interfejsu użytkownika.

Ponadto zachęcamy do zapoznania się z następującym artykułem bazy wiedzy, ponieważ opisano w nim podobny błąd, który może być powiązany:
Od czasu uaktualnienia do DDMC 6.1 lub 6.2 próba przesłania plików RPM z graficznego interfejsu użytkownika kończy się niepowodzeniem. Może się to również zdarzyć w przypadku DDOS podczas korzystania z graficznego interfejsu użytkownika (DDSM)

Resolution

Jeśli partycja /ddr zostanie zapełniona, do czyszczenia partycji /ddr potrzebny jest dostęp bash. Aby uzyskać natychmiastową pomoc, skontaktuj się ze swoim dostawcą usług pomocy technicznej.

Aby uniknąć ryzyka trafienia tej wady, nie należy używać interfejsu użytkownika do przesyłania plików RPM.  Niektóre opcje obejmują:
  • Użyj polecenia "scp", aby przesłać plik RPM do systemu Data Domain w katalogu /ddr/var/releases/.
  • Zamapuj folder /ddvar na klienta CIFS i skopiuj plik RPM do folderu /ddvar/releases.

Additional Information

Informacje te przetłumaczono na 17 języków: 
https://downloads.dell.com/TranslatedPDF/CS_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/DA_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/DE_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/FI_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/FR_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/IT_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/JA_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/KO_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/NL_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/NO-NO_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/PL_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/RU_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/SV_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/TR_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_KB541095.pdf

Affected Products

Data Domain

Products

Data Domain, DD OS 6.1, DD OS 7.0, DD OS 7.1
Article Properties
Article Number: 000063425
Article Type: Solution
Last Modified: 09 Oct 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.