Data Domain : upload of DDOS rpm file via using GUI (Data Domain System Manager) can fill up /ddr partition
Summary: Upload of DDOS RPM file via using GUI (Data Domain System Manager) can fill up /ddr partition
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Symptoms
The DDOS RPM file is first stored under /ddr/gui/temp while being uploaded using the GUI (DDSM). After upload, the RPM is moved to /ddr/var/releases.
If /ddr runs out of space during upload, this can affect registry updates and cause the file system to PANIC / restart. This can also affect other services (dd_procmon, dd_hd_rdb_tool, netmon, scm, sms etc) that write to /ddr.
Below are examples of errors that can be seen in messages.engineering when /ddr is full (note the errors are not indicative /ddr/ became full due to a failed RPM upload):
Jan 22 12:17:15 dd6300 dd_hd_rdb_tool: ERROR: Registry /ddr/registry/p0/alerts_local.db3 SQL step 'step insert value' error 13 (database or disk is full) (retries=0)
Jan 22 12:17:23 dd6300 ddfs[30031]: ERROR: Registry /ddr/registry/m0/system.db3 SQL step 'step insert value' error 13 (database or disk is full) (retries=0)
Jan 22 12:17:23 dd6300 ddfs[30031]: ERROR: Registry /ddr/registry/m0/system.db3 SQL error 13 (database or disk is full): reset insert value
Jan 22 12:17:19 dd6300 netmon: ERROR: Registry /ddr/registry/p0/config.db3 SQL step 'step insert value' error 13 (database or disk is full) (retries=0) Jan 22 12:17:19 dd6300 netmon: ERROR: Registry /ddr/registry/p0/config.db3 SQL error 13 (database or disk is full): reset insert value In other cases, even if /ddr does not run out of space completely, the space usage could become high enough to prevent an upgrade. Below is an example of a upgrade pre-check failure: # system upgrade precheck 7.1.0.5-643969.rpm Upgrade precheck in progress: Node Severity Issue Solution ---- -------- ------------------------------ -------- 0 CRITICAL Utilization on /ddr is 93% Free space on /ddr ---- -------- ------------------------------ -------- Node 0: phase 1/1 (Precheck 100%) **** Upgrade precheck found 1 blocking issue(s).
Cause
/ddr partition has limited space on several DDR models. Also, the DDOS RPM size in the later releases (such as DDOS 7.x) is larger, so chances are the larger DDOS RPM size combined with a smaller (and half full) /ddr partition in some DD models can add up to causing the lack of disk space under /ddr while uploading the RPM through the GUI.
Additionally, you are encouraged to check the following KB article as well, as a similar error is described which may be related:
Since upgrading to DDMC 6.1 or 6.2, trying to upload RPM files from the GUI fails. This could also occur for DDOS when using the GUI (DDSM)
Additionally, you are encouraged to check the following KB article as well, as a similar error is described which may be related:
Since upgrading to DDMC 6.1 or 6.2, trying to upload RPM files from the GUI fails. This could also occur for DDOS when using the GUI (DDSM)
Resolution
If /ddr partition becomes full, bash access is needed to clean up /ddr. Please contact your contracted support provider for immediate assistance.
To avoid the risk of hitting this defect, avoid using the UI to upload the RPM. Some options include:
To avoid the risk of hitting this defect, avoid using the UI to upload the RPM. Some options include:
- Use "scp" to upload the RPM file to the Data Domain under the /ddr/var/releases/ directory.
- Map the /ddvar folder to a CIFS client and copy the RPM to the /ddvar/releases folder.
Additional Information
This content is translated in 17 languages:
| https://downloads.dell.com/TranslatedPDF/CS_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/DA_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/DE_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/ES-XL_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/FI_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/FR_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/IT_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/JA_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/KO_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/NL_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/NO-NO_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/PL_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/PT-BR_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/RU_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/SV_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/TR_KB541095.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-CN_KB541095.pdf |
Affected Products
Data DomainProducts
Data Domain, DD OS 6.1, DD OS 7.0, DD OS 7.1Article Properties
Article Number: 000063425
Article Type: Solution
Last Modified: 09 Oct 2024
Version: 4
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