VxRack: storcli commands not effective

Summary: VxRack Node: storcli commands not effective

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Using storcli commands to set VD attributes. This can happen after a disk failure, or replacing a disk.

Symptoms

Some storcli commands to set VD attributes would return successfully, but upon checking, the VD attributes are not updated.

Sometimes when there is a failed disk, the attributes of other VDs might change and storcli commands cannot set them.

 

Impact

Reduced performance

Cause

This problem can occur in two situations:

  • RAID controller firmware has been upgraded, but the host has not been rebooted yet
  • There is preservedcache for the failed disk, which prevents the storcli commands to be effective

Resolution

Use "storcli /c0 show all" to check what is the version of currently running firmware - if it is not, reboot the host in order to load the correct firmware.

If the firmware is already running at its expected version, use the following command to check preservedcache:

storcli /c0 show preservedcache

If there is preservedcache, this command shows it, for example:

Controller = 0
Status = Success
Description = None
-----------
VD State
-----------
4 Missing

 

And the VD number in the output will most likely not be present in "storcli /c0/vall show," as it is usually a failed disk.

Use the following command to delete preservedcache (Replace '#' with the number in "VD" column in above command's output. Based on the above example, use number '4').

storcli /c0/v# delete preservedcache [force]

After that use storcli commands to set VD attributes again.

 

 

Impacted versions

This is not a ScaleIO software issue and can affect all servers with LSI raid controllers and all versions of ScaleIO.

Fixed in version

N/A This is not a ScaleIO issue.

Article Properties
Article Number: 000065897
Article Type: Solution
Last Modified: 10 Nov 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.