NetWorker: Fejlfinding af "timeout for inaktivitet"-fejl

Summary: Sikkerhedskopieringer mislykkes med timeoutfejl uden inaktivitet.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Symptomer

  • Fejl: Inactivity timeout
  • Sikkerhedskopieringer mislykkes på grund af timeoutfejl uden aktivitet
  • Sikkerhedskopieringer afbrudt på grund af timeoutfejl uden aktivitet
  • Fejl: (client):(save set) has been inactive for (number) minutes
  • Fejl: SYSTEM STATE:\ aborted due to inactivity
  • Fejl: nsrexec: clientname has been abandoned by nsrexec
  • Fejl: nsrexecd: Recvd signal to kill process group - aborted due to inactivity
  • Fejl: nsrexec: Attempting a kill on remote save
  • Sikkerhedskopieringer mislykkes med timeoutfejl uden aktivitet
  • Fejl: inactivity timeout Under trinvis sikkerhedskopiering
  • Fejl: No full backups of this save set were found in the media database; performing a full backup
  • Trinvise sikkerhedskopieringer mislykkes
  • Gemmer holder op med at reagere

Cause

NetWorker angiver attributterne "Timeout for inaktivitet" flere steder:

  • Timeout for NetWorker-serverjobinaktivitet:
    Timeout for jobinaktivitet 
BEMÆRK: Timeout for jobinaktivitet angiver, hvor længe NetWorker venter på et jobsvar. Hvis der ikke kommer noget svar i tide, afslutter serveren jobbet. Timeout for jobinaktivitet gælder for alle handlinger, der er defineret i alle arbejdsprocesser i en politik. Standardindstillingen er nul (ingen timeout).
 
  • Timeout for handlingsinaktivitet:
    Timeout for handling uden aktivitet 
BEMÆRK: Dette angiver det maksimale antal minutter, som et job, der køres af en handling, kan forsøge at svare på serveren. Hvis et job ikke reagerer i tide, markerer serveren det som mislykket. NetWorker forsøger straks igen for at undgå at miste tid på grund af fejlen. Der kan forekomme inaktivitet i forbindelse med sikkerhedskopier af store gemte sæt, sikkerhedskopier af gemte sæt med store sparsomme filer og trinvise sikkerhedskopier af mange små statiske filer. Indstillingen Timeout for inaktivitet gælder for sondehandlinger og sikkerhedskopieringshandlinger for handlingstyperne Traditionel og Snapshot. Hvis du angiver en værdi for denne indstilling i andre handlinger, ignorerer NetWorker værdien.


NetWorker-administrationsvejledningen indeholder yderligere oplysninger om indstillingerne for "Timeout for inaktivitet": NetWorker-dokumentation

Resolution

Generelt kan der være mange årsager til, at en timeout for inaktivitet udløses.

Timeoutfejl for inaktivitet opstår ofte, når klienten scanner et stort filsystem. Hvis kun få filer ændres, kan den næste lagringsstream blive forsinket betydeligt. Denne betingelse kan løses ved at øge værdien af attributten "Timeout for inaktivitet" for den NetWorker-sikkerhedskopieringshandling, der rapporterer fejlen. Indstil værdien til 0 for at deaktivere timeout. Hold derefter øje med den gemte indstillingsvarighed, og indstil timeout for inaktivitet til det antal minutter eller mere.

Hvis timeout ikke skyldes ovenstående årsag, skal du bekræfte følgende punkter:

  1. Kontroller, at NetWorker-klienten ikke er slukket, og at netværkskablet er tilsluttet.
  2. Sikkerhedskopieringsforsøg mislykkes altid.
  3. Alle navnefortolkninger mellem NetWorker-klienten og sikkerhedskopieringsserveren er gennemført: NetWorker: Fejlfinding af navnefortolkning Bedste praksis
  4. Kontrollér, at alle kendte aliasser for NetWorker-klienten er angivet i aliasattributten for NetWorker-klientressourcen.
  5. Alle netværkskort og switche har de samme indstillinger for Dupleks, Hastighed, MTU og andre indstillinger.
  6. Parallelitetsindstillinger er korrekt defineret. Se NetWorker-vejledningen til optimering og planlægning af ydeevne: NetWorker-dokumentation
  7. Kontroller den justerbare TCP/IP-parameter. Se NetWorker-vejledningen til optimering og planlægning af ydeevne: NetWorker-dokumentation
Hvis alle ovenstående udsagn er sande, skal du kontrollere følgende også kendte bidragende faktorer, der kan generere dette problem.

Firewalls:
Hvis en firewall adskiller NetWorker-serveren og klienten, skal du åbne tilstrækkeligt mange porte inden for NetWorker-forbindelsesområdet til at muliggøre korrekt kommunikation. NetWorker-serveren kan nå klienten, men klienten kan muligvis ikke åbne nye porte for at svare. NetWorker-processer og -porte

BEMÆRK: Kontakt dit netværk eller sikkerhedsteam for at overvåge firewalltrafik under handlingen, der mislykkes med timeout-fejl, og overvåg for eventuelle kommunikationsproblemer.

NetWorker-konfiguration:
 
Det er blevet set, hvor en forkert konfigureret 'Execution Path'-attribut for NetWorker-klientens ressource har forårsaget disse timeoutfejl uden aktivitet. Konfigurer attributten "Execution Path" korrekt, eller lad feltet stå tomt.
 
Korruption:
  1. Dette problem blev oplevet på grund af korruption af filer på disken. Kontroller kontrolsummen eller datoen for filerne for at sikre deres integritet. Fjern, flyt eller reparer den beskadigede fil, eller brug NetWorker-direktivet til at springe den over.
  2. Beskadigelse af NetWorker-ressourcefilen, især sikkerhedskopierings- eller klonhandlingsressourcen, forårsager lejlighedsvis timeoutfejl for inaktivitet. Prøv at slette ressourcen for den mislykkede sikkerhedskopiering eller klonhandling og oprette den igen. Du kan også prøve at gendanne NetWorker-ressourcefilen fra et tidspunkt, før fejlene startede. Dette kræver typisk engagement af NetWorker-support for at udføre NetWorker Server Disaster Recovery (NSRDR)
  3. Det er kendt, at beskadigelse af NetWorker-klientfilindekser eller mediedatabase resulterer i timeoutfejl uden aktivitet. Kør nsrck -L6 for at forsøge at reparere indekser eller køre nsrck -L7 for at gendanne indekser. For mediedatabasen kan korruption muligvis løses ved at gendanne en ældre mediedatabase. Dette kræver typisk engagement af NetWorker-support for at udføre NetWorker Server Disaster Recovery (NSRDR).
Når alle ovenstående anbefalinger er udtømt, og inden du går til anden fejlfinding, anbefales det stærkt at:
  • Genstart NetWorker-dæmoner for at rydde cachelagre, der kan være forældede.
Linux: 
nsr_shutdown
systemctl start networker

OR

/etc/init.d/networker start
Windows:
net stop nsrexecd /y

For NetWorker servers:
net start nsrd

For NetWorker Management Console Servers:
net start nsrexecd
net start gstd

For NetWorker client systems:
net start nsrexecd
  • Genstart serveren og klienten, som rydder hukommelsen fra fragmenter af død kode, og geninitialiser alle programmer og operativsystemet.

Additional Information

   For yderligere referencer til konfiguration og ydeevneanalyse af NetWorker, henvises til:

Generel NetWorker:
Tilpasning af NetWorker-serveren til optimal ydeevne  KB-205851
Sådan konfigurerer du NetWorker-sikkerhedskopieringer af flere netværk  KB-204258
Sådan kører du en BIGASM-test  KB-205896
Parallelitet og målsessioner KB-202942

DNS-netværk
Fejlfinding af problemer med DNS og navneopløsning  KB-125514
Sådan konfigureres DNS Forward & Reverse Lookup Zones  KB-198676
DNS – Vilkår og værktøjer for diagnosticeringssupport  KB-197647
DNS – Indstillinger for netværksforbindelse  KB-198751

Netværksporte og firewalls:
Beregning og konfiguration af NetWorker-portintervaller KB-173639
Brug af NetWorker-kommandoen 'nsrrpcinfo'  KB-199703
Indstillinger for NetWorker-firewallport KB-203593

Affected Products

NetWorker

Products

NetWorker Series
Article Properties
Article Number: 000068580
Article Type: Solution
Last Modified: 23 Sep 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.