NetWorker: Fejlfinding af "timeout for inaktivitet"-fejl
Summary: Sikkerhedskopieringer mislykkes med timeoutfejl uden inaktivitet.
Symptoms
Symptomer
- Fejl:
Inactivity timeout - Sikkerhedskopieringer mislykkes på grund af timeoutfejl uden aktivitet
- Sikkerhedskopieringer afbrudt på grund af timeoutfejl uden aktivitet
- Fejl:
(client):(save set) has been inactive for (number) minutes - Fejl:
SYSTEM STATE:\ aborted due to inactivity - Fejl:
nsrexec: clientname has been abandoned by nsrexec - Fejl:
nsrexecd: Recvd signal to kill process group - aborted due to inactivity - Fejl:
nsrexec: Attempting a kill on remote save - Sikkerhedskopieringer mislykkes med timeoutfejl uden aktivitet
- Fejl:
inactivity timeoutUnder trinvis sikkerhedskopiering - Fejl:
No full backups of this save set were found in the media database; performing a full backup - Trinvise sikkerhedskopieringer mislykkes
- Gemmer holder op med at reagere
Cause
NetWorker angiver attributterne "Timeout for inaktivitet" flere steder:
- Timeout for NetWorker-serverjobinaktivitet:
- Timeout for handlingsinaktivitet:
NetWorker-administrationsvejledningen indeholder yderligere oplysninger om indstillingerne for "Timeout for inaktivitet": NetWorker-dokumentation
Resolution
Generelt kan der være mange årsager til, at en timeout for inaktivitet udløses.
Timeoutfejl for inaktivitet opstår ofte, når klienten scanner et stort filsystem. Hvis kun få filer ændres, kan den næste lagringsstream blive forsinket betydeligt. Denne betingelse kan løses ved at øge værdien af attributten "Timeout for inaktivitet" for den NetWorker-sikkerhedskopieringshandling, der rapporterer fejlen. Indstil værdien til 0 for at deaktivere timeout. Hold derefter øje med den gemte indstillingsvarighed, og indstil timeout for inaktivitet til det antal minutter eller mere.
Hvis timeout ikke skyldes ovenstående årsag, skal du bekræfte følgende punkter:
- Kontroller, at NetWorker-klienten ikke er slukket, og at netværkskablet er tilsluttet.
- Sikkerhedskopieringsforsøg mislykkes altid.
- Alle navnefortolkninger mellem NetWorker-klienten og sikkerhedskopieringsserveren er gennemført: NetWorker: Fejlfinding af navnefortolkning Bedste praksis
- Kontrollér, at alle kendte aliasser for NetWorker-klienten er angivet i aliasattributten for NetWorker-klientressourcen.
- Alle netværkskort og switche har de samme indstillinger for Dupleks, Hastighed, MTU og andre indstillinger.
- Parallelitetsindstillinger er korrekt defineret. Se NetWorker-vejledningen til optimering og planlægning af ydeevne: NetWorker-dokumentation
- Kontroller den justerbare TCP/IP-parameter. Se NetWorker-vejledningen til optimering og planlægning af ydeevne: NetWorker-dokumentation
Firewalls:
Hvis en firewall adskiller NetWorker-serveren og klienten, skal du åbne tilstrækkeligt mange porte inden for NetWorker-forbindelsesområdet til at muliggøre korrekt kommunikation. NetWorker-serveren kan nå klienten, men klienten kan muligvis ikke åbne nye porte for at svare. NetWorker-processer og -porte
BEMÆRK: Kontakt dit netværk eller sikkerhedsteam for at overvåge firewalltrafik under handlingen, der mislykkes med timeout-fejl, og overvåg for eventuelle kommunikationsproblemer.
NetWorker-konfiguration:
- Dette problem blev oplevet på grund af korruption af filer på disken. Kontroller kontrolsummen eller datoen for filerne for at sikre deres integritet. Fjern, flyt eller reparer den beskadigede fil, eller brug NetWorker-direktivet til at springe den over.
- Beskadigelse af NetWorker-ressourcefilen, især sikkerhedskopierings- eller klonhandlingsressourcen, forårsager lejlighedsvis timeoutfejl for inaktivitet. Prøv at slette ressourcen for den mislykkede sikkerhedskopiering eller klonhandling og oprette den igen. Du kan også prøve at gendanne NetWorker-ressourcefilen fra et tidspunkt, før fejlene startede. Dette kræver typisk engagement af NetWorker-support for at udføre NetWorker Server Disaster Recovery (NSRDR)
- Det er kendt, at beskadigelse af NetWorker-klientfilindekser eller mediedatabase resulterer i timeoutfejl uden aktivitet. Kør
nsrck -L6for at forsøge at reparere indekser eller kørensrck -L7for at gendanne indekser. For mediedatabasen kan korruption muligvis løses ved at gendanne en ældre mediedatabase. Dette kræver typisk engagement af NetWorker-support for at udføre NetWorker Server Disaster Recovery (NSRDR).
- Genstart NetWorker-dæmoner for at rydde cachelagre, der kan være forældede.
nsr_shutdown systemctl start networker OR /etc/init.d/networker start
net stop nsrexecd /y For NetWorker servers: net start nsrd For NetWorker Management Console Servers: net start nsrexecd net start gstd For NetWorker client systems: net start nsrexecd
- Genstart serveren og klienten, som rydder hukommelsen fra fragmenter af død kode, og geninitialiser alle programmer og operativsystemet.
Additional Information
| For yderligere referencer til konfiguration og ydeevneanalyse af NetWorker, henvises til: Generel NetWorker: Tilpasning af NetWorker-serveren til optimal ydeevne KB-205851 Sådan konfigurerer du NetWorker-sikkerhedskopieringer af flere netværk KB-204258 Sådan kører du en BIGASM-test KB-205896 Parallelitet og målsessioner KB-202942 DNS-netværk Fejlfinding af problemer med DNS og navneopløsning KB-125514 Sådan konfigureres DNS Forward & Reverse Lookup Zones KB-198676 DNS – Vilkår og værktøjer for diagnosticeringssupport KB-197647 DNS – Indstillinger for netværksforbindelse KB-198751 Netværksporte og firewalls: Beregning og konfiguration af NetWorker-portintervaller KB-173639 Brug af NetWorker-kommandoen 'nsrrpcinfo' KB-199703 Indstillinger for NetWorker-firewallport KB-203593 |