Для Dell Encryption Enterprise потрібна System32 . EXE будуть виключені
Summary: Виключення Dell Encryption Enterprise (раніше Dell Data Protection Enterprise Edition) можна додати для System32 . EXE, дотримуючись цих інструкцій.
Symptoms
Продукти, на які впливають:
- Dell Encryption Enterprise
- Захист даних Dell | Корпоративне видання
Впливає на такі версії:
- v7.0.x і пізніші версії
Корпорація Майкрософт нещодавно змінила процес оновлення Windows, щоб змінити файли в каталозі \Windows\System32 перед завантаженням драйверів Dell Encryption Enterprise. Це може призвести до того, що зашифровані SDE виконувані файли (.exe) у папці System32 будуть замінені відкритим текстом (незашифрованим) файлом без повідомлення Dell Encryption Enterprise про зміну.
Cause
Це змушує Dell Encryption Enterprise намагатися розшифрувати незашифрований файл, що призводить до появи синього екрана.
Resolution
Як дізнатися, чи це стосується мене?
Ця проблема стосується лише користувачів, які використовують Dell Encryption Enterprise із шифруванням системних даних (SDE). Клацніть версію сервера керування безпекою Dell, щоб визначити, чи присутня проблема у вашому середовищі.
- Увійдіть у консоль віддаленого керування Dell Data Protection (RMC).
- В області меню ліворуч виберіть пункт Населення.

Малюнок 1: (Лише англійською мовою) Населення
- Виберіть пункт Підприємство, Групи кінцевих точок або Кінцеві точки. Цей параметр залежить від того, де в організації змінюються політики SDE.

Малюнок 2: (Лише англійською мовою) Виберіть «Підприємство», «Група кінцевих точок» або «Кінцеві точки»
- Натисніть Шифрування файлів/папок (FFE).

Малюнок 3: (Лише англійською мовою) Шифрування файлів/папок (FFE)
- Переконайтеся, що SDE Encrypted увімкнено .

Малюнок 4: (Лише англійською мовою) Переконайтеся, що SDE зашифровано ввімкнено
- У розділі «Правила шифрування SDE» знайдіть
%ENV:SYSTEMROOT%\SYSTEM32\;exeабоC:\Windows\System32\;exeбез-символ.
Приклад поліса з питанням:
C:\Windows\System32\;exe @C:\Windows\System32\;exe %ENV:SYSTEMROOT%\System32\;exe @%ENV:SYSTEMROOT%\System32\;exe
^, ^2 або ^3 символ.
Якщо ви не можете знайти синтаксис, подібний до наведених вище прикладів, ця проблема вас не стосується. Якщо ви знайшли синтаксис, подібний до наведеного вище прикладу, перейдіть до: Як вирішити проблему?
- Увійдіть у консоль віддаленого керування Dell Data Protection (RMC).
- В області меню ліворуч виберіть «Підприємство», «Групи кінцевих точок» або «Кінцеві точки». Цей параметр залежить від того, де в організації змінюються політики SDE.

Малюнок 5: (Лише англійською мовою) Виберіть «Підприємство», «Групи кінцевих точок», «Кінцеві точки»
Приклад поліса з питанням:
^, ^2 або ^3 символ.
Якщо ви не можете знайти синтаксис, схожий на наведені вище приклади, то у вас це питання вас не стосується. Якщо ви знайшли синтаксис, подібний до наведеного вище прикладу, перейдіть до: Як вирішити проблему?
- Виберіть вкладку Політики безпеки .

Малюнок 6: (Лише англійською мовою) Політики безпеки
- Якщо з'явиться меню шаблону, натисніть кнопку Замінити , а потім перейдіть до кроку 5.

Малюнок 7: (Лише англійською мовою) Перевизначити
- У розкривному списку Категорія політики виберіть пункт Шифрування Windows.

Малюнок 8: (Лише англійською мовою) Виберіть пункт Шифрування Windows
- Розгорнути фіксоване сховище.

Малюнок 9: (Лише англійською мовою) Фіксоване сховище
- Переконайтеся, що для параметра SDE Encryption Enabled встановлено значення true. Якщо параметр SDE Encryption Enabled має значення False, ця проблема вас не стосується.
- У розділі «Правила шифрування SDE» знайдіть
%ENV:SYSTEMROOT%\SYSTEM32\;exeабоC:\Windows\System32\;exeбез-символ.
C:\Windows\System32\;exe @C:\Windows\System32\;exe %ENV:SYSTEMROOT%\System32\;exe @%ENV:SYSTEMROOT%\System32\;exe
Як вирішити проблему?
Виберіть версію вашого сервера безпеки даних Dell / сервера захисту даних Dell, щоб знайти рішення.
- Знову увійдіть у RMC і перейдіть до розділу «Правила шифрування SDE» (описано в розділі «Як дізнатися, чи це стосується мене?»).
- Додайте символ «-» (мінус) до відповідного синтаксису.
Приклад зміни:

Малюнок 10: (Лише англійською мовою) Перед

Малюнок 11: (Лише англійською мовою) Після
- У верхньому правому меню натисніть Зберегти.

Малюнок 12: (Лише англійською мовою) Рятувати
- В області меню ліворуч виберіть пункт Керування.

Малюнок 13: (Лише англійською мовою) Управління
- Натисніть Commit.

Малюнок 14: (Лише англійською мовою) Зробити
- У меню Commit за бажанням введіть коментарі щодо зміни правил, а потім натисніть Commit Policy.
- Кінцеві точки, які використовують Dell Encryption Enterprise, помітять нову зміну політики під час наступного опитування політики та почнуть розшифровувати .exe у папці System32.
Це може призвести до появи синього екрана, якщо .exe розширення зашифровано за допомогою System Data Encryption (SDE), Common або User.
- Знову увійдіть у RMC і перейдіть до розділу «Правила шифрування SDE» (описано в розділі «Як дізнатися, чи це стосується мене?»).
- Додайте об'єкт
-(мінус) до відповідного синтаксису.
Приклад зміни:

Малюнок 15: (Лише англійською мовою) Перед

Малюнок 16: (Лише англійською мовою) Після
- У нижньому правому куті натисніть Зберегти.

Малюнок 17: (Лише англійською мовою) Рятувати
- На панелі меню ліворуч виберіть пункт Commit Policies (у розділі Дії).

Малюнок 18: (Лише англійською мовою) Правила комітів
- За потреби введіть коментар щодо зміни політики, а потім натисніть кнопку Застосувати зміни.
- Кінцеві точки, що використовують Dell Data Protection | Enterprise Edition сприйме нову зміну політики під час наступного опитування та почне розшифровувати .exe у папці System32.
Щоб зв'язатися зі службою підтримки, зверніться за номерами телефонів міжнародної служби підтримки Dell Data Security.
Перейдіть до TechDirect , щоб згенерувати запит на технічну підтримку онлайн.
Щоб отримати додаткову інформацію та ресурси, приєднуйтесь до форуму спільноти Dell Security Community.