Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell Endpoint Security Suite Enterprise System Requirements

Summary: System requirements must be met when installing Dell Endpoint Security Suite Enterprise.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

Note:

This article covers the computer requirements for installing Dell Endpoint Security Suite Enterprise.


Affected Products:

Dell Endpoint Security Suite Enterprise

Affected Operating Systems:

Windows
Mac
Linux


Cause

Not applicable.

Resolution

Dell Endpoint Security Suite Enterprise has specific Network, Hardware, and Software requirements. Click the appropriate tab for more information.

Network requirements vary based on the version of the Dell Data Security Server (formerly Dell Data Protection Server) being used with Dell Endpoint Security Suite Enterprise. Click the appropriate version for more information.

Note: For assistance on locating the server version, reference How to Identify the Dell Data Security / Dell Data Protection Server Version.

External Destinations for Dell Security Management Server Virtual also vary based on tenant region that is selected during provisioning. Click the appropriate region for more information.

Function Port Source Destination
On-the-Box Entitlement Validation 443 BE Product Server cloud.dell.com
Product Server Updates 443 BE Product Server sha2act.credant.com1
Product Server Updates 443 BE Product Source dist.ddsproduction.com1
iFrame Reporting 443 BE Product Server login.cylance.com
iFrame Reporting 443 BE Product Server protect.cylance.com
iFrame Reporting 443 Managed Endpoint data.cylance.com
Client Updating 443 Managed Endpoint update.cylance.com
Server Provisioning 443 BE Product Server api.cylance.com
Server Provisioning 443 BE Product Server protect-api.cylance.com
Product Download 443 Managed Endpoint download.cylance.com

1Required only for Dell Security Management Server Virtual (formerly Dell Data Protection | Virtual Edition)

Note:
  • Amazon Web Services hosts destinations through dynamic IPs. The IPs are not static and are subject to change without notice.
  • Alternatively *.cylance.com, *.dell.com, *.ddsproduction.com, & *.credant.com may be used.
  • An existing HTTP/HTTPS proxy server may be used in place of direct connectivity through the firewall.
Function Port Source Destination
On-the-Box Entitlement Validation 443 BE Product Server cloud.dell.com
Product Server Updates 443 BE Product Server sha2act.credant.com1
Product Server Updates 443 BE Product Source dist.ddsproduction.com1
iFrame Reporting 443 BE Product Server login-euc1.cylance.com
iFrame Reporting 443 BE Product Server protect-euc1.cylance.com
iFrame Reporting 443 Managed Endpoint data-euc1.cylance.com
Client Updating 443 Managed Endpoint update-euc1.cylance.com
Server Provisioning 443 BE Product Server api.cylance.com
Server Provisioning 443 BE Product Server protect-api-euc1.cylance.com
Product Download 443 Managed Endpoint download.cylance.com

1Required only for Dell Security Management Server Virtual (formerly Dell Data Protection | Virtual Edition)

Note:
  • Amazon Web Services hosts destinations through dynamic IPs. The IPs are not static and are subject to change without notice.
  • Alternatively *.cylance.com, *.dell.com, *.ddsproduction.com, & *.credant.com may be used.
  • An existing HTTP or HTTPS proxy server may be used in place of direct connectivity through the firewall.
Function Port Source Destination
On-the-Box Entitlement Validation 443 BE Product Server cloud.dell.com
Product Server Updates 443 BE Product Server sha2act.credant.com1
Product Server Updates 443 BE Product Source dist.ddsproduction.com1
iFrame Reporting 443 BE Product Server login-apne1.cylance.com
iFrame Reporting 443 BE Product Server protect-apne1.cylance.com
iFrame Reporting 443 Managed Endpoint data-apne1.cylance.com
Client Updating 443 Managed Endpoint update-apne1.cylance.com
Server Provisioning 443 BE Product Server api.cylance.com
Server Provisioning 443 BE Product Server protect-api-apne1.cylance.com
Product Download 443 Managed Endpoint download.cylance.com

1Required only for Dell Security Management Server Virtual (formerly Dell Data Protection | Virtual Edition)

Note:
  • Amazon Web Services hosts destinations through dynamic IPs. The IPs are not static and are subject to change without notice.
  • Alternatively *.cylance.com, *.dell.com, *.ddsproduction.com, & *.credant.com may be used.
  • An existing HTTP or HTTPS proxy server may be used in place of direct connectivity through the firewall.
Function Port Source Destination
On-the-Box Entitlement Validation 443 BE Product Server cloud.dell.com
Product Server Updates 443 BE Product Server sha2act.credant.com1
Product Server Updates 443 BE Product Source dist.ddsproduction.com1
iFrame Reporting 443 BE Product Server login-au.cylance.com
iFrame Reporting 443 BE Product Server protect-au.cylance.com
iFrame Reporting 443 Managed Endpoint data-au.cylance.com
Client Updating 443 Managed Endpoint update-au.cylance.com
Server Provisioning 443 BE Product Server api.cylance.com
Server Provisioning 443 BE Product Server protect-api-au.cylance.com
Product Download 443 Managed Endpoint download.cylance.com

1Required only for Dell Security Management Server Virtual (formerly Dell Data Protection | Virtual Edition)

Note:
  • Amazon Web Services hosts destinations through dynamic IPs. The IPs are not static and are subject to change without notice.
  • Alternatively *.cylance.com, *.dell.com, *.ddsproduction.com, & *.credant.com may be used.
  • An existing HTTP or HTTPS proxy server may be used in place of direct connectivity through the firewall.
Function Port Source Destination
On-the-Box Entitlement Validation 443 BE Product Server cloud.dell.com
Product Server Updates 443 BE Product Server sha2act.credant.com1
Product Server Updates 443 BE Product Source dist.ddsproduction.com1
iFrame Reporting 443 BE Product Server login-sae1.cylance.com
iFrame Reporting 443 BE Product Server protect-sae1.cylance.com
iFrame Reporting 443 Managed Endpoint data-sae1.cylance.com
Client Updating 443 Managed Endpoint update-sae1.cylance.com
Server Provisioning 443 BE Product Server api.cylance.com
Server Provisioning 443 BE Product Server protect-api-sae1.cylance.com
Product Download 443 Managed Endpoint download.cylance.com

1Required only for Dell Security Management Server Virtual (formerly Dell Data Protection | Virtual Edition)

Note:
  • Amazon Web Services hosts destinations through dynamic IPs. The IPs are not static and are subject to change without notice.
  • Alternatively *.cylance.com, *.dell.com, *.ddsproduction.com, & *.credant.com may be used.
  • An existing HTTP or HTTPS proxy server may be used in place of direct connectivity through the firewall.

External Destinations for Dell Security Management Server Virtual also vary based on tenant region that is selected during provisioning. Click the appropriate region for more information.

Function Port Source Destination
On-the-Box Entitlement Validation 443 BE Product Server cloud.dell.com
Product Server Updates 443 BE Product Server sha2act.credant.com1
iFrame Reporting 443 BE Product Server login.cylance.com
iFrame Reporting 443 BE Product Server protect.cylance.com
iFrame Reporting 443 Managed Endpoint data.cylance.com
Client Updating 443 Managed Endpoint update.cylance.com
Server Provisioning 443 BE Product Server api.cylance.com
Server Provisioning 443 BE Product Server protect-api.cylance.com
Product Download 443 Managed Endpoint download.cylance.com

1Required only for Dell Security Management Server Virtual (formerly Dell Data Protection | Virtual Edition)

Note:
  • Amazon Web Services hosts destinations through dynamic IPs. The IPs are not static and are subject to change without notice.
  • Alternatively *.cylance.com, *.dell.com, & *.credant.com may be used.
  • An existing HTTP or HTTPS proxy server may be used in place of direct connectivity through the firewall.
Function Port Source Destination
On-the-Box Entitlement Validation 443 BE Product Server cloud.dell.com
Product Server Updates 443 BE Product Server sha2act.credant.com1
iFrame Reporting 443 BE Product Server login-euc1.cylance.com
iFrame Reporting 443 BE Product Server protect-euc1.cylance.com
iFrame Reporting 443 Managed Endpoint data-euc1.cylance.com
Client Updating 443 Managed Endpoint update-euc1.cylance.com
Server Provisioning 443 BE Product Server api.cylance.com
Server Provisioning 443 BE Product Server protect-api-euc1.cylance.com
Product Download 443 Managed Endpoint download.cylance.com

1Required only for Dell Security Management Server Virtual (formerly Dell Data Protection | Virtual Edition)

Note:
  • Amazon Web Services hosts destinations through dynamic IPs. The IPs are not static and are subject to change without notice.
  • Alternatively *.cylance.com, *.dell.com, & *.credant.com may be used.
  • An existing HTTP or HTTPS proxy server may be used in place of direct connectivity through the firewall.
Function Port Source Destination
On-the-Box Entitlement Validation 443 BE Product Server cloud.dell.com
Product Server Updates 443 BE Product Server sha2act.credant.com1
iFrame Reporting 443 BE Product Server login-au.cylance.com
iFrame Reporting 443 BE Product Server protect-au.cylance.com
iFrame Reporting 443 Managed Endpoint data-au.cylance.com
Client Updating 443 Managed Endpoint update-au.cylance.com
Server Provisioning 443 BE Product Server api.cylance.com
Server Provisioning 443 BE Product Server protect-api-au.cylance.com
Product Download 443 Managed Endpoint download.cylance.com

1Required only for Dell Security Management Server Virtual (formerly Dell Data Protection | Virtual Edition)

Note:
  • Amazon Web Services hosts destinations through dynamic IPs. The IPs are not static and are subject to change without notice.
  • Alternatively *.cylance.com, *.dell.com, & *.credant.com may be used.
  • An existing HTTP or HTTPS proxy server may be used in place of direct connectivity through the firewall.

External Destinations for Dell Security Management Server Virtual also vary based on tenant region that is selected during provisioning. Click the appropriate region for more information.

Function Port Source Destination
On-the-Box Entitlement Validation 443 BE Product Server cloud.dell.com
Product Server Updates 443 BE Product Server act.credant.com1
iFrame Reporting 443 BE Product Server login.cylance.com
iFrame Reporting 443 BE Product Server protect.cylance.com
iFrame Reporting 443 Managed Endpoint data.cylance.com
Client Updating 443 Managed Endpoint update.cylance.com
Server Provisioning 443 BE Product Server api.cylance.com
Server Provisioning 443 BE Product Server protect-api.cylance.com
Product Download 443 Managed Endpoint download.cylance.com

1Required only for Dell Security Management Server Virtual (formerly Dell Data Protection | Virtual Edition)

Note:
  • Amazon Web Services hosts destinations through dynamic IPs. The IPs are not static and are subject to change without notice.
  • Alternatively *.cylance.com, *.dell.com, & *.credant.com may be used.
  • An existing HTTP or HTTPS proxy server may be used in place of direct connectivity through the firewall.
Function Port Source Destination
On-the-Box Entitlement Validation 443 BE Product Server cloud.dell.com
Product Server Updates 443 BE Product Server act.credant.com1
iFrame Reporting 443 BE Product Server login-euc1.cylance.com
iFrame Reporting 443 BE Product Server protect-euc1.cylance.com
iFrame Reporting 443 Managed Endpoint data-euc1.cylance.com
Client Updating 443 Managed Endpoint update-euc1.cylance.com
Server Provisioning 443 BE Product Server api.cylance.com
Server Provisioning 443 BE Product Server protect-api-euc1.cylance.com
Product Download 443 Managed Endpoint download.cylance.com

1Required only for Dell Security Management Server Virtual (formerly Dell Data Protection | Virtual Edition)

Note:
  • Amazon Web Services hosts destinations through dynamic IPs. The IPs are not static and are subject to change without notice.
  • Alternatively *.cylance.com, *.dell.com, & *.credant.com may be used.
  • An existing HTTP or HTTPS proxy server may be used in place of direct connectivity through the firewall.
Function Port Source Destination
On-the-Box Entitlement Validation 443 BE Product Server cloud.dell.com
Product Server Updates 443 BE Product Server act.credant.com1
iFrame Reporting 443 BE Product Server login-au.cylance.com
iFrame Reporting 443 BE Product Server protect-au.cylance.com
iFrame Reporting 443 Managed Endpoint data-au.cylance.com
Client Updating 443 Managed Endpoint update-au.cylance.com
Server Provisioning 443 BE Product Server api.cylance.com
Server Provisioning 443 BE Product Server protect-api-au.cylance.com
Product Download 443 Managed Endpoint download.cylance.com

1Required only for Dell Security Management Server Virtual (formerly Dell Data Protection | Virtual Edition)

Note:
  • Amazon Web Services hosts destinations through dynamic IPs. The IPs are not static and are subject to change without notice.
  • Alternatively *.cylance.com, *.dell.com, & *.credant.com may be used.
  • An existing HTTP or HTTPS proxy server may be used in place of direct connectivity through the firewall.
Function Port Source Destination
On-the-Box Entitlement Validation 443 BE Product Server cloud.dell.com
Product Server Updates 443 BE Product Server act.credant.com1
iFrame Reporting 443 BE Product Server login.cylance.com
iFrame Reporting 443 BE Product Server protect.cylance.com
iFrame Reporting 443 Managed Endpoint data.cylance.com
Client Updating 443 Managed Endpoint update.cylance.com
Server Provisioning 443 BE Product Server api.cylance.com
Server Provisioning 443 BE Product Server protect-api.cylance.com
Product Download 443 Managed Endpoint download.cylance.com

1Required only for Dell Security Management Server Virtual (formerly Dell Data Protection | Virtual Edition)

Note:
  • Amazon Web Services hosts destinations through dynamic IPs. The IPs are not static and are subject to change without notice.
  • Alternatively *.cylance.com, *.dell.com, & *.credant.com may be used.
  • An existing HTTP orHTTPS proxy server may be used in place of direct connectivity through the firewall.

Minimum Hardware Requirements:

  • 500 MB free disk space
  • 2 GB RAM
  • 10/100/1000 or Wi-Fi network card

Click the appropriate operating system tab for specific platform software requirements.

The Windows version of Dell Endpoint Security Suite Enterprise integrates Cylance’s Advanced Threat Protection (ATP) client with Dell Data Security (formerly Dell Data Protection) encryption options. This article covers only the ATP client requirements. For information about other Dell Data Security encryption options, reference:

General Requirements:

  • Local Administration rights for installation
  • Dell Security Management Server version 9.2 or later
  • Dell Endpoint Security Suite Enterprise license

Exclusion Requirements:

Anti-virus solutions (for example, Symantec, McAfee, Trend Micro, and more) running on the same endpoint as Dell Endpoint Security Suite Enterprise files must have the following files that are added as exclusions:

C:\Program Files\Dell\Dell Data Protection*
C:\ProgramData\Cylance*
C:\ProgramData\Dell\Dell Data Protection*
C:\Windows\Temp\CylanceDesktopArchive
C:\Windows\Temp\CylanceDesktopRemoteFile
C:\Windows\System32\Drivers\CylanceDrv*.sys
C:\Windows\System32\Drivers\CyProtectDrv*.sys
C:\Program Files\Cylance\Desktop
Note: Exclusions are based on the default installation location of Dell Endpoint Security Suite Enterprise.

Software Requirements:

Software requirements vary by version of Dell Endpoint Security Suite Enterprise for Windows. Click the appropriate software version for more information. For more information about versioning, reference How to Identify the Dell Endpoint Security Suite Enterprise Version.

Operating Systems (32 and 64 bit):

  • Desktop:
    • Windows 11 Education, Enterprise, Pro
    • Windows 10 Education, Enterprise, Pro1
      • v21H2 (November 2021 Update)
      • v21H1 (May 2021 Update)
      • v20H2 (October 2020 Update)
      • v2004 (May 2020 Update / 20H1)
      • v1909 (November 2019 Update/19H2)
      • v1903 (May 2019 Update/19H1)
      • v1809 (October 2018 Update/Redstone 5)
        • Windows 10 Enterprise 2019 LTSC
      • v1803 (Spring Creators Update/Redstone 4)
      • v1709 (Fall Creators Update/Redstone 3)
      • v1703 (Creators Update/Redstone 2)
      • v1607 (Anniversary Update/Redstone)
        • Windows 10 Enterprise 2016 LTSC
    • Windows 8.1 Update 0-1, Enterprise234
    • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate456
    • Windows 7 Embedded Standard56
  • Server:
    • Windows Server 2019: Standard, Datacenter7
    • Windows Server 2016: Standard, Essentials, Datacenter678
    • Windows Server 2012 R2: Standard, Essentials, Datacenter367
    • Windows Server 2012: Standard, Essentials, Datacenter367
    • Windows Server 2008 R2 SP1: Standard, Datacenter, Enterprise, Webserver3678

1Unlisted Windows 10 feature updates are not supported. For a status on all feature updates, reference Dell Data Security / Dell Data Protection Windows Version Compatibility.
1Requires Microsoft Update KB4054517 (https://support.microsoft.com/help/4054517 External Link).
2Windows 8.1 RT is not supported.
3Requires Microsoft Update KB2999226 (https://support.microsoft.com/help/2999226 External Link).
4Requires Microsoft Update KB4054519 (https://support.microsoft.com/help/4054519 External Link).
5Requires Microsoft Update KB4054518 (https://support.microsoft.com/help/4054518 External Link).
6Requires Microsoft KB Update 4474419 (https://support.microsoft.com/help/4474419 External Link) and 4490628 (https://support.microsoft.com/help/4490628 External Link ). For more information about this requirement, reference SHA-1 Signing Certificate Expiration and Deprecation on Dell Data Security / Dell Data Protection Products.
7Server Core is not supported.
8Requires Microsoft Update KB3004394 (https://support.microsoft.com/help/3004394 External Link).

Note: To determine Windows 10 feature update versions, reference Which Version of Windows Operating System am I Running? External Link

Software Prerequisites:

  • Dell Client Security Framework (EMAgent.exe)
  • Visual C++ 2017 or later Redistributable Package (x86/x64)
  • Visual C++ 2012 or later Redistributable Package (x86/x64)
Note:
  • Dell Client Security Framework and Visual C++ 2017 and Visual C++ 2012 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
  • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Enterprise. Failure to use the appropriate version may lead to product issues.
  • Microsoft .NET Framework 4.5.2 (or later)
Note: Reference How to Determine Which .NET Framework Versions Are Installed External Link for more information.

    Operating Systems (32 and 64 bit):

    • Desktop:
      • Windows 10 Education, Enterprise, Pro1
        • v20H2 (October 2020 Update)
        • v2004 (May 2020 Update / 20H1)
        • v1909 (November 2019 Update/19H2)
        • v1903 (May 2019 Update/19H1)
        • v1809 (October 2018 Update/Redstone 5)
          • Windows 10 Enterprise 2019 LTSC
        • v1803 (Spring Creators Update/Redstone 4)
        • v1709 (Fall Creators Update/Redstone 3)
        • v1703 (Creators Update/Redstone 2)
        • v1607 (Anniversary Update/Redstone)
          • Windows 10 Enterprise 2016 LTSC
      • Windows 8.1 Update 0-1, Enterprise234
      • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate456
      • Windows 7 Embedded Standard56
    • Server:
      • Windows Server 2019: Standard7
      • Windows Server 2016: Standard, Essentials, Datacenter678
      • Windows Server 2012 R2: Standard, Essentials, Datacenter367
      • Windows Server 2012: Standard, Essentials, Datacenter367
      • Windows Server 2008 R2 SP1: Standard, Datacenter, Enterprise, Webserver3678

    1Unlisted Windows 10 feature updates are not supported. For a status on all feature updates, reference Dell Data Security / Dell Data Protection Windows Version Compatibility.
    1Requires Microsoft Update KB4054517 (https://support.microsoft.com/help/4054517 External Link).
    2Windows 8.1 RT is not supported.
    3Requires Microsoft Update KB2999226 (https://support.microsoft.com/help/2999226 External Link).
    4Requires Microsoft Update KB4054519 (https://support.microsoft.com/help/4054519 External Link).
    5Requires Microsoft Update KB4054518 (https://support.microsoft.com/help/4054518 External Link).
    6Requires Microsoft KB Update 4474419 (https://support.microsoft.com/help/4474419 External Link) and 4490628 (https://support.microsoft.com/help/4490628 External Link). For more information about this requirement, reference SHA-1 Signing Certificate Expiration and Deprecation on Dell Data Security / Dell Data Protection Products.
    7Server Core is not supported.
    8Requires Microsoft Update KB3004394 (https://support.microsoft.com/help/3004394 External Link).

    Note: To determine Windows 10 feature update versions, reference Which Version of Windows Operating System am I Running? External Link

    Software Prerequisites:

    • Dell Client Security Framework (EMAgent.exe).
    • Visual C++ 2017 or later Redistributable Package (x86/x64).
    • Visual C++ 2012 or later Redistributable Package (x86/x64).
    Note:
    • Dell Client Security Framework and Visual C++ 2017 and Visual C++ 2012 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
    • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Enterprise. Failure to use the appropriate version may lead to product issues.
    • Microsoft .NET Framework 4.5.2 (or later)
    Note: Reference How to Determine Which .NET Framework Versions Are Installed External Link for more information.

      Operating Systems (32 and 64 bit):

      • Desktop:
        • Windows 10 Education, Enterprise, Pro1
          • v2004 (May 2020 Update / 20H1)2
          • v1909 (November 2019 Update/19H2)
          • v1903 (May 2019 Update/19H1)
          • v1809 (October 2018 Update/Redstone 5)
            • Windows 10 Enterprise 2019 LTSC
          • v1803 (Spring Creators Update/Redstone 4)
          • v1709 (Fall Creators Update/Redstone 3)
          • v1703 (Creators Update/Redstone 2)
          • v1607 (Anniversary Update/Redstone)
            • Windows 10 Enterprise 2016 LTSC
        • Windows 8.1 Update 0-1, Enterprise345
        • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate567
        • Windows 7 Embedded Standard67
      • Server:
        • Windows Server 2019: Standard8
        • Windows Server 2016: Standard, Essentials, Datacenter789
        • Windows Server 2012 R2: Standard, Essentials, Datacenter478
        • Windows Server 2012: Standard, Essentials, Datacenter478
        • Windows Server 2008 R2 SP1: Standard, Datacenter, Enterprise, Webserver4789

      1Unlisted Windows 10 feature updates are not supported. For a status on all feature updates, reference Dell Data Security / Dell Data Protection Windows Version Compatibility.
      1Requires Microsoft Update KB4054517 (https://support.microsoft.com/help/4054517 External Link).
      2Validated post operating system launch.
      3Windows 8.1 RT is not supported.
      4Requires Microsoft Update KB2999226 (https://support.microsoft.com/help/2999226 External Link).
      5Requires Microsoft Update KB4054519 (https://support.microsoft.com/help/4054519 External Link).
      6Requires Microsoft Update KB4054518 (https://support.microsoft.com/help/4054518 External Link).
      7Requires Microsoft KB Update 4474419 (https://support.microsoft.com/help/4474419 External Link) and 4490628 (https://support.microsoft.com/help/4490628 External Link). For more information about this requirement, reference SHA-1 Signing Certificate Expiration and Deprecation on Dell Data Security / Dell Data Protection Products.
      8Server Core is not supported.
      9Requires Microsoft Update KB3004394 (https://support.microsoft.com/help/3004394 External Link).

      Note: To determine Windows 10 feature update versions, reference Which Version of Windows Operating System am I Running? External Link

      Software Prerequisites:

      • Dell Client Security Framework (EMAgent.exe)
      • Visual C++ 2017 or later Redistributable Package (x86/x64)
      • Visual C++ 2012 or later Redistributable Package (x86/x64)
      Note:
      • Dell Client Security Framework and Visual C++ 2017 and Visual C++ 2012 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
      • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Enterprise. Failure to use the appropriate version may lead to product issues.
      • Microsoft .NET Framework 4.5.2 (or later)
      Note: Reference How to Determine Which .NET Framework Versions Are Installed External Link for more information.

        Operating Systems (32 and 64 bit):

        • Desktop:
          • Windows 10 Education, Enterprise, Pro1
            • v1903 (May 2019 Update/19H1)
            • v1809 (October 2018 Update/Redstone 5)
              • Windows 10 Enterprise 2019 LTSC
            • v1803 (Spring Creators Update/Redstone 4)
            • v1709 (Fall Creators Update/Redstone 3)
            • v1703 (Creators Update/Redstone 2)
            • v1607 (Anniversary Update/Redstone)
              • Windows 10 Enterprise 2016 LTSC
          • Windows 8.1 Update 0-1, Enterprise234
          • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate456
          • Windows 7 Embedded Standard56
        • Server:
          • Windows Server 2019: Standard7
          • Windows Server 2016: Standard, Essentials, Datacenter678
          • Windows Server 2012 R2: Standard, Essentials, Datacenter367
          • Windows Server 2012: Standard, Essentials, Datacenter367
          • Windows Server 2008 R2 SP1: Standard, Datacenter, Enterprise, Webserver3678

        1Unlisted Windows 10 feature updates are not supported. For a status on all feature updates, reference Dell Data Security / Dell Data Protection Windows Version Compatibility.
        1Requires Microsoft Update KB4054517 (https://support.microsoft.com/help/4054517 External Link).
        2Windows 8.1 RT is not supported.
        3Requires Microsoft Update KB2999226 (https://support.microsoft.com/help/2999226 External Link).
        4Requires Microsoft Update KB4054519 (https://support.microsoft.com/help/4054519 External Link).
        5Requires Microsoft Update KB4054518 (https://support.microsoft.com/help/4054518 External Link).
        6Requires Microsoft KB Update 4474419 (https://support.microsoft.com/help/4474419 External Link) and 4490628 (https://support.microsoft.com/help/4490628 External Link). For more information about this requirement, reference SHA-1 Signing Certificate Expiration and Deprecation on Dell Data Security / Dell Data Protection Products.
        7Server Core is not supported.
        8Requires Microsoft Update KB3004394 (https://support.microsoft.com/help/3004394 External Link).

        Note: To determine Windows 10 feature update versions, reference Which Version of Windows Operating System am I Running? External Link

        Software Prerequisites:

        • Dell Client Security Framework (EMAgent.exe)
        • Visual C++ 2017 or later Redistributable Package (x86/x64)
        • Visual C++ 2012 or later Redistributable Package (x86/x64)
        Note:
        • Dell Client Security Framework and Visual C++ 2017 and Visual C++ 2012 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
        • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Enterprise. Failure to use the appropriate version may lead to product issues.
        • Microsoft .NET Framework 4.5.2 (or later)
        Note: Reference How to Determine Which .NET Framework Versions Are Installed External Link for more information.

          Operating Systems (32 and 64 bit):

          • Desktop:
            • Windows 10 Education, Enterprise, Pro1
              • v1809 (October 2018 Update/Redstone 5)
                • Windows 10 Enterprise 2019 LTSC
              • v1803 (Spring Creators Update/Redstone 4)
              • v1709 (Fall Creators Update/Redstone 3)
              • v1703 (Creators Update/Redstone 2)
              • v1607 (Anniversary Update/Redstone)
                • Windows 10 Enterprise 2016 LTSC
            • Windows 8.1 Update 0-1, Enterprise234
            • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate456
            • Windows 7 Embedded Standard56
          • Server:
            • Windows Server 2016: Standard, Essentials, Datacenter678
            • Windows Server 2012 R2: Standard, Essentials, Datacenter367
            • Windows Server 2012: Standard, Essentials, Datacenter367
            • Windows Server 2008 R2 SP1: Standard, Datacenter, Enterprise, Webserver3678

          1Unlisted Windows 10 feature updates are not supported. For a status on all feature updates, reference Dell Data Security / Dell Data Protection Windows Version Compatibility.
          1Requires Microsoft Update KB4054517 (https://support.microsoft.com/help/4054517 External Link).
          2Windows 8.1 RT is not supported.
          3Requires Microsoft Update KB2999226 (https://support.microsoft.com/help/2999226 External Link).
          4Requires Microsoft Update KB4054519 (https://support.microsoft.com/help/4054519 External Link).
          5Requires Microsoft Update KB4054518 (https://support.microsoft.com/help/4054518 External Link).
          6Requires Microsoft KB Update 4474419 (https://support.microsoft.com/help/4474419 External Link) and 4490628 (https://support.microsoft.com/help/4490628 External Link). For more information about this requirement, reference SHA-1 Signing Certificate Expiration and Deprecation on Dell Data Security / Dell Data Protection Products.
          7Server Core is not supported.
          8Requires Microsoft Update KB3004394 (https://support.microsoft.com/help/3004394 External Link).

          Note: To determine Windows 10 feature update versions, reference Which Version of Windows Operating System am I Running? External Link

          Software Prerequisites:

          • Dell Client Security Framework (EMAgent.exe).
          • Visual C++ 2015 Update 3 Redistributable Package (x86 and x64).
          • Visual C++ 2012 or later Redistributable Package (x86/x64).
          Note:
          • Dell Client Security Framework, Visual C++ 2015 Update 3, and Visual C++ 2012 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
          • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Enterprise. Failure to use the appropriate version may lead to product issues.
          • Microsoft .NET Framework 4.5.2 (or later)
          Note: Reference How to Determine Which .NET Framework Versions Are Installed External Link for more information.

            Operating Systems (32 and 64 bit):

            • Desktop:
              • Windows 10 Education, Enterprise, Pro1
                • v1803 (Spring Creators Update/Redstone 4)
                • v1709 (Fall Creators Update/Redstone 3)
                • v1703 (Creators Update/Redstone 2)
                • v1607 (Anniversary Update/Redstone)
                  • Windows 10 Enterprise 2016 LTSC
              • Windows 8.1 Update 0-1, Enterprise234
              • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate456
              • Windows 7 Embedded Standard56
            • Server:
              • Windows Server 2016: Standard, Essentials, Datacenter678
              • Windows Server 2012 R2: Standard, Essentials, Datacenter367
              • Windows Server 2012: Standard, Essentials, Datacenter367
              • Windows Server 2008 R2 SP1: Standard, Datacenter, Enterprise, Webserver3678

            1Unlisted Windows 10 feature updates are not supported. For a status on all feature updates, reference Dell Data Security / Dell Data Protection Windows Version Compatibility.
            1Requires Microsoft Update KB4054517 (https://support.microsoft.com/help/4054517 External Link).
            2Windows 8.1 RT is not supported.
            3Requires Microsoft Update KB2999226 (https://support.microsoft.com/help/2999226 External Link).
            4Requires Microsoft Update KB4054519 (https://support.microsoft.com/help/4054519 External Link).
            5Requires Microsoft Update KB4054518 (https://support.microsoft.com/help/4054518 External Link).
            6Requires Microsoft KB Update 4474419 (https://support.microsoft.com/help/4474419 External Link) and 4490628 (https://support.microsoft.com/help/4490628 External Link). For more information about this requirement, reference SHA-1 Signing Certificate Expiration and Deprecation on Dell Data Security / Dell Data Protection Products.
            7Server Core is not supported.
            8Requires Microsoft Update KB3004394 (https://support.microsoft.com/help/3004394 External Link).

            Note: To determine Windows 10 feature update versions, reference Which Version of Windows Operating System am I Running? External Link

            Software Prerequisites:

            • Dell Client Security Framework (EMAgent.exe)
            • Visual C++ 2015 Update 3 Redistributable Package (x86 and x64)
            • Visual C++ 2012 or later Redistributable Package (x86/x64)
            Note:
            • Dell Client Security Framework, Visual C++ 2015 Update 3, and Visual C++ 2012 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
            • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Enterprise. Failure to use the appropriate version may lead to product issues.
            • Microsoft .NET Framework 4.5.2 (or later)
            Note: Reference How to Determine Which .NET Framework Versions Are Installed External Link for more information.

              Operating Systems (32 and 64 bit):

              • Desktop:
                • Windows 10 Education, Enterprise, Pro1
                  • v1709 (Fall Creators Update/Redstone 3)
                  • v1703 (Creators Update/Redstone 2)
                  • v1607 (Anniversary Update/Redstone)
                    • Windows 10 Enterprise 2016 LTSC
                • Windows 8.1 Update 0-1, Enterprise234
                • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate456
                • Windows 7 Embedded Standard56
              • Server:
                • Windows Server 2016: Standard, Essentials, Datacenter678
                • Windows Server 2012 R2: Standard, Essentials, Datacenter367
                • Windows Server 2012: Standard, Essentials, Datacenter367
                • Windows Server 2008 R2 SP1: Standard, Datacenter, Enterprise, Webserver3678

              1Unlisted Windows 10 feature updates are not supported. For a status on all feature updates, reference Dell Data Security / Dell Data Protection Windows Version Compatibility.
              1Requires Microsoft Update KB4054517 (https://support.microsoft.com/help/4054517 External Link).
              2Windows 8.1 RT is not supported.
              3Requires Microsoft Update KB2999226 (https://support.microsoft.com/help/2999226 External Link).
              4Requires Microsoft Update KB4054519 (https://support.microsoft.com/help/4054519 External Link).
              5Requires Microsoft Update KB4054518 (https://support.microsoft.com/help/4054518 External Link).
              6Requires Microsoft KB Update 4474419 (https://support.microsoft.com/help/4474419 External Link) and 4490628 (https://support.microsoft.com/help/4490628 External Link). For more information about this requirement, reference SHA-1 Signing Certificate Expiration and Deprecation on Dell Data Security / Dell Data Protection Products.
              7Server Core is not supported.
              8Requires Microsoft Update KB3004394 (https://support.microsoft.com/help/3004394 External Link).

              Note: To determine Windows 10 feature update versions, reference Which Version of Windows Operating System am I Running? External Link

              Software Prerequisites:

              • Dell Client Security Framework (EMAgent.exe)
              • Visual C++ 2015 Update 3 Redistributable Package (x86 and x64)
              • Visual C++ 2012 or later Redistributable Package (x86/x64)
              Note:
              • Dell Client Security Framework, Visual C++ 2015 Update 3, and Visual C++ 2012 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
              • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Enterprise. Failure to use the appropriate version may lead to product issues.
              • Microsoft .NET Framework 4.5.2 (or later)
              Note: Reference How to Determine Which .NET Framework Versions Are Installed External Link for more information.

                Operating Systems (32 and 64 bit):

                • Desktop:
                  • Windows 10 Education, Enterprise, Pro1
                    • v1709 (Fall Creators Update/Redstone 3)
                    • v1703 (Creators Update/Redstone 2)
                    • v1607 (Anniversary Update/Redstone)
                      • Windows 10 Enterprise 2016 LTSC
                  • Windows 8.1 Update 0-1, Enterprise234
                  • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate456
                  • Windows 7 Embedded Standard56
                • Server:
                  • Windows Server 2016: Standard, Essentials, Datacenter678
                  • Windows Server 2012 R2: Standard, Essentials, Datacenter367
                  • Windows Server 2012: Standard, Essentials, Datacenter367
                  • Windows Server 2008 R2 SP1: Standard, Datacenter, Enterprise, Webserver3678

                1Unlisted Windows 10 feature updates are not supported. For a status on all feature updates, reference Dell Data Security / Dell Data Protection Windows Version Compatibility.
                1Requires Microsoft Update KB4054517 (https://support.microsoft.com/help/4054517 External Link).
                2Windows 8.1 RT is not supported.
                3Requires Microsoft Update KB2999226 (https://support.microsoft.com/help/2999226 External Link).
                4Requires Microsoft Update KB4054519 (https://support.microsoft.com/help/4054519 External Link).
                5Requires Microsoft Update KB4054518 (https://support.microsoft.com/help/4054518 External Link).
                6Requires Microsoft KB Update 4474419 (https://support.microsoft.com/help/4474419 External Link) and 4490628 (https://support.microsoft.com/help/4490628 External Link). For more information about this requirement, reference SHA-1 Signing Certificate Expiration and Deprecation on Dell Data Security / Dell Data Protection Products.
                7Server Core is not supported.
                8Requires Microsoft Update KB3004394 (https://support.microsoft.com/help/3004394 External Link).

                Note: To determine Windows 10 feature update versions, reference Which Version of Windows Operating System am I Running? External Link

                Software Prerequisites:

                • Dell Client Security Framework (EMAgent.exe)
                • Visual C++ 2015 Update 3 or later Redistributable Package (x86 and x64)
                • Visual C++ 2012 or later Redistributable Package (x86/x64)
                Note:
                • Dell Client Security Framework, Visual C++ 2015 Update 3, and Visual C++ 2012 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
                • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Enterprise. Failure to use the appropriate version may lead to product issues.
                • Microsoft .NET Framework 4.5.2 (or later)
                Note: Reference How to Determine Which .NET Framework Versions Are Installed External Link for more information.

                  Operating Systems (32 and 64 bit):

                  • Desktop:
                    • Windows 10 Education, Enterprise, Pro1
                      • v1709 (Fall Creators Update/Redstone 3)
                      • v1703 (Creators Update/Redstone 2)
                      • v1607 (Anniversary Update/Redstone)
                      • v1511 (November Update/Threshold 2)
                    • Windows 8.1 Update 0-1, Enterprise234
                    • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate456
                    • Windows 7 Embedded Standard56
                  • Server:
                    • Windows Server 2016: Standard, Essentials, Datacenter678
                    • Windows Server 2012 R2: Standard, Essentials, Datacenter367
                    • Windows Server 2012: Standard, Essentials, Datacenter367
                    • Windows Server 2008 R2 SP1: Standard, Datacenter, Enterprise, Webserver3678

                  1Unlisted Windows 10 feature updates are not supported. For a status on all feature updates, reference Dell Data Security / Dell Data Protection Windows Version Compatibility.
                  1Requires Microsoft Update KB4054517 (https://support.microsoft.com/help/4054517 External Link).
                  2Windows 8.1 RT is not supported.
                  3Requires Microsoft Update KB2999226 (https://support.microsoft.com/help/2999226 External Link).
                  4Requires Microsoft Update KB4054519 (https://support.microsoft.com/help/4054519 External Link).
                  5Requires Microsoft Update KB4054518 (https://support.microsoft.com/help/4054518 External Link).
                  6Requires Microsoft KB Update 4474419 (https://support.microsoft.com/help/4474419 External Link) and 4490628 (https://support.microsoft.com/help/4490628 External Link). For more information about this requirement, reference SHA-1 Signing Certificate Expiration and Deprecation on Dell Data Security / Dell Data Protection Products.
                  7Server Core is not supported.
                  8Requires Microsoft Update KB3004394 (https://support.microsoft.com/help/3004394 External Link).

                  Note: To determine Windows 10 feature update versions, reference Which Version of Windows Operating System am I Running? External Link

                  Software Prerequisites:

                  • Dell Client Security Framework (EMAgent.exe)
                  • Visual C++ 2015 Update 3 or later Redistributable Package (x86 and x64)
                  • Visual C++ 2012 or later Redistributable Package (x86/x64)
                  Note:
                  • Dell Client Security Framework, Visual C++ 2015 Update 3, and Visual C++ 2012 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
                  • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Enterprise. Failure to use the appropriate version may lead to product issues.
                  • Microsoft .NET Framework 4.5.2 (or later)
                  Note: Reference How to Determine Which .NET Framework Versions Are Installed External Link for more information.

                    Operating Systems (32 and 64 bit):

                    • Desktop:
                      • Windows 10 Education, Enterprise, Pro1
                        • v1607 (Anniversary Update/Redstone)
                        • v1511 (November Update/Threshold 2)
                      • Windows 8.1 Update 0-1, Enterprise234
                      • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate456
                    • Server:
                      • Windows Server 2016: Standard, Essentials, Datacenter678
                      • Windows Server 2012 R2: Standard, Essentials, Datacenter367
                      • Windows Server 2012: Standard, Essentials, Datacenter367
                      • Windows Server 2008 R2 SP1: Standard, Datacenter, Enterprise, Webserver3678

                    1Unlisted Windows 10 feature updates are not supported. For a status on all feature updates, reference Dell Data Security / Dell Data Protection Windows Version Compatibility.
                    1Requires Microsoft Update KB4054517 (https://support.microsoft.com/help/4054517 External Link).
                    2Windows 8.1 RT is not supported.
                    3Requires Microsoft Update KB2999226 (https://support.microsoft.com/help/2999226 External Link).
                    4Requires Microsoft Update KB4054519 (https://support.microsoft.com/help/4054519 External Link).
                    5Requires Microsoft Update KB4054518 (https://support.microsoft.com/help/4054518 External Link).
                    6Requires Microsoft KB Update 4474419 (https://support.microsoft.com/help/4474419 External Link) and 4490628 (https://support.microsoft.com/help/4490628 External Link). For more information about this requirement, reference SHA-1 Signing Certificate Expiration and Deprecation on Dell Data Security / Dell Data Protection Products.
                    7Server Core is not supported.
                    8Requires Microsoft Update KB3004394 (https://support.microsoft.com/help/3004394 External Link).

                    Note: To determine Windows 10 feature update versions, reference Which Version of Windows Operating System am I Running? External Link

                    Software Prerequisites:

                    • Dell Client Security Framework (EMAgent.exe)
                    • Visual C++ 2012 Update 4 Redistributable Package (x86 and x64)
                    Note:
                    • Dell Client Security Framework and Visual C++ 2012 Update 4 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
                    • Failure to use the associated Dell Client Security Framework version that is part of the Dell Endpoint Security Suite Enterprise prevents product functionality.
                    • Microsoft .NET Framework 4.5.2 (or later)
                    Note: Reference How to Determine Which .NET Framework Versions Are Installed External Link for more information.

                      Operating Systems (32 and 64 bit):

                      • Desktop:
                        • Windows 10 Education, Enterprise, Pro1
                          • v1607 (Anniversary Update/Redstone)
                          • v1511 (November Update/Threshold 2)
                        • Windows 8.1 Update 0-1, Enterprise234
                        • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate456
                      • Server:
                        • Windows Server 2012 R2: Standard, Essentials, Datacenter367
                        • Windows Server 2012: Standard, Essentials, Datacenter367
                        • Windows Server 2008 R2 SP1: Standard, Datacenter, Enterprise, Webserver3678

                      1Unlisted Windows 10 feature updates are not supported. For a status on all feature updates, reference Dell Data Security / Dell Data Protection Windows Version Compatibility.
                      1Requires Microsoft Update KB4054517 (https://support.microsoft.com/help/4054517 External Link).
                      2Windows 8.1 RT is not supported.
                      3Requires Microsoft Update KB2999226 (https://support.microsoft.com/help/2999226 External Link).
                      4Requires Microsoft Update KB4054519 (https://support.microsoft.com/help/4054519 External Link).
                      5Requires Microsoft Update KB4054518 (https://support.microsoft.com/help/4054518 External Link).
                      6Requires Microsoft KB Update 4474419 (https://support.microsoft.com/help/4474419 External Link) and 4490628 (https://support.microsoft.com/help/4490628 External Link). For more information about this requirement, reference SHA-1 Signing Certificate Expiration and Deprecation on Dell Data Security / Dell Data Protection Products.
                      7Server Core is not supported.
                      8Requires Microsoft Update KB3004394 (https://support.microsoft.com/help/3004394 External Link).

                      Note: To determine Windows 10 feature update versions, reference Which Version of Windows Operating System am I Running? External Link

                      Software Prerequisites:

                      • Dell Client Security Framework (EMAgent.exe)
                      • Visual C++ 2012 Update 4 Redistributable Package (x86 and x64)
                      Note:
                      • Dell Client Security Framework and Visual C++ 2012 Update 4 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
                      • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Enterprise. Failure to use the appropriate version may lead to product issues.
                      • Microsoft .NET Framework 4.5.2 (or later)
                      Note: Reference How to Determine Which .NET Framework Versions Are Installed External Link for more information.

                        Operating Systems (32 and 64 bit):

                        • Desktop:
                          • Windows 10 Education, Enterprise, Pro1
                            • v1511 (November Update/Threshold 2)
                          • Windows 8.1 Update 0-1, Enterprise234
                          • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate456
                        • Server:
                          • Windows Server 2012 R2: Standard, Essentials, Datacenter367
                          • Windows Server 2012: Standard, Essentials, Datacenter367
                          • Windows Server 2008 R2 SP1: Standard, Datacenter, Enterprise, Webserver3678

                        1Unlisted Windows 10 feature updates are not supported. For a status on all feature updates, reference Dell Data Security / Dell Data Protection Windows Version Compatibility.
                        1Requires Microsoft Update KB4054517 (https://support.microsoft.com/help/4054517 External Link).
                        2Windows 8.1 RT is not supported.
                        3Requires Microsoft Update KB2999226 (https://support.microsoft.com/help/2999226 External Link).
                        4Requires Microsoft Update KB4054519 (https://support.microsoft.com/help/4054519 External Link).
                        5Requires Microsoft Update KB4054518 (https://support.microsoft.com/help/4054518 External Link).
                        6Requires Microsoft KB Update 4474419 (https://support.microsoft.com/help/4474419 External Link) and 4490628 (https://support.microsoft.com/help/4490628 External Link). For more information about this requirement, reference SHA-1 Signing Certificate Expiration and Deprecation on Dell Data Security / Dell Data Protection Products.
                        7Server Core is not supported.
                        8Requires Microsoft Update KB3004394 (https://support.microsoft.com/help/3004394 External Link).

                        Note: To determine Windows 10 feature update versions, reference Which Version of Windows Operating System am I Running? External Link

                        Software Prerequisites:

                        • Dell Client Security Framework (EMAgent.exe)
                        • Visual C++ 2012 Update 4 Redistributable Package (x86 and x64)
                        Note:
                        • Dell Client Security Framework and Visual C++ 2012 Update 4 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
                        • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Enterprise. Failure to use the appropriate version may lead to product issues.
                        • Microsoft .NET Framework 4.5.2 (or later)
                        Note: Reference How to Determine Which .NET Framework Versions Are Installed External Link for more information.

                        The Mac version of Dell Endpoint Security Suite Enterprise integrates Cylance’s Advanced Threat Protection client with Dell Encryption Enterprise for Mac.

                        This article covers only the Advanced Threat Protection client requirements. Reference Dell Encryption Enterprise for Mac / Dell Data Protection Enterprise Edition for Mac System Requirements for information about the encryption client.

                        General Requirements:

                        • Local Administration rights for installation
                        • Dell Security Management Server (formally Dell Data Protection Server) version 9.5 or later
                        • Dell Endpoint Security Suite Enterprise license

                        Exclusion Requirements:

                        Anti-virus solutions (for example, Symantec, McAfee, Trend Micro, and more) running on the same endpoint as Dell Endpoint Security Suite Enterprise files must have the following files that are added as exclusions:

                        /Library/Application Support/Cylance/Desktop/q
                        /Library/Application Support/Cylance/
                        /System/Library/Extensions/CyProtectDrvOSX.kext/
                        /private/tmp/CylanceDesktopArchive
                        /private/tmp/CylanceDesktopRemoteFile
                        Note: Exclusions are based on the default installation location of Dell Endpoint Security Suite Enterprise.

                        Software Requirements:

                        Software requirements vary by version of Dell Endpoint Security Suite Enterprise for Mac. Click the appropriate software version for more information. For more information about versioning, reference How to Identify the Dell Endpoint Security Suite Enterprise Version.

                        Warning:

                        Operating Systems (64 bit):

                        • macOS Catalina 10.15.0 to 10.15.7
                        • macOS Mojave 10.15.0 to 10.15.7
                        • macOS High Sierra 10.13.5 to 10.13.6
                        • macOS Sierra 10.12.6

                        Operating Systems (64 bit):

                        • macOS Mojave 10.15.0 to 10.15.4
                        • macOS Mojave 10.14.0 to 10.14.6
                        • macOS High Sierra 10.13.5 to 10.13.6
                        • macOS Sierra 10.12.6

                        Operating Systems (64 bit):

                        • macOS Mojave 10.14.0 to 10.14.6
                        • macOS High Sierra 10.13.5 to 10.13.6
                        • macOS Sierra 10.12.6
                        • Mac OS X El Capitan 10.11.6
                        Warning: Memory Protection and Script Control features on macOS Mojave require client v1511 and later.

                        Operating Systems (64 bit):

                        • macOS Mojave 10.14.0 to 10.14.2
                        • macOS High Sierra 10.13.5 to 10.13.6
                        • macOS Sierra 10.12.6
                        • Mac OS X El Capitan 10.11.6

                        Operating Systems (64 bit):

                        • macOS High Sierra 10.13.5 to 10.13.6
                        • macOS Sierra 10.12.4 to 10.12.6
                        • Mac OS X El Capitan 10.11.6

                        Operating Systems (64 bit):

                        • macOS High Sierra 10.13.3 to 10.13.6
                        • macOS Sierra 10.12.4 to 10.12.6
                        • Mac OS X El Capitan 10.11.6

                        Operating Systems (64 bit):

                        • macOS High Sierra 10.13.0 to 10.13.4
                        • macOS Sierra 10.12.3 to 10.12.6
                        • Mac OS X El Capitan 10.11.6
                        • Mac OS X Yosemite 10.10.5

                        Operating Systems (64 bit):

                        • macOS Sierra 10.12.3 to 10.12.6
                        • Mac OS X El Capitan 10.11.6
                        • Mac OS X Yosemite 10.10.5

                        Operating Systems (64 bit):

                        • macOS Sierra 10.12.3
                        • Mac OS X El Capitan 10.11.6
                        • Mac OS X Yosemite 10.10.5
                        • Mac OS X Mavericks 10.9.5

                        Operating Systems (64 bit):

                        • Mac OS X El Capitan 10.11.6
                        • Mac OS X Yosemite 10.10.5
                        • Mac OS X Mavericks 10.9.5

                        General Requirements:

                        • Local Administration rights for installation
                        • Dell Security Management Server version 9.11 or later
                        • Dell Endpoint Security Suite Enterprise license

                        Exclusion Requirements:

                        Anti-virus solutions (for example, Symantec, McAfee, Trend Micro, and more) running on the same endpoint as Dell Endpoint Security Suite Enterprise files must have the following files that are added as exclusions:

                        /opt/Cylance
                        /usr/lib/systemd/system/cylancesvc.service
                        /etc/sysconfig/modules/cylance.modules
                        /usr/src/CyProtectDrv-1.2
                        /tmp/CylanceDesktopArchive
                        /tmp/CylanceDesktopRemoteFile
                        Note: Exclusions are based on the default installation location of Dell Endpoint Security Suite Enterprise.

                        Operating Systems:

                        • CentOS Linux v7.0 to 7.5
                        • Red Hat Enterprise Linux v7.0 to 7.5

                        Operating Systems:

                        • CentOS Linux v7.0 to 7.3
                        • Red Hat Enterprise Linux v7.0 to 7.3

                        To contact support, reference Dell Data Security International Support Phone Numbers.
                        Go to TechDirect to generate a technical support request online.
                        For additional insights and resources, join the Dell Security Community Forum.

                        Additional Information

                         

                        Videos

                         

                        Article Properties


                        Affected Product

                        Dell Endpoint Security Suite Enterprise

                        Last Published Date

                        14 Jul 2022

                        Version

                        21

                        Article Type

                        Solution