PowerEdge: Unable to ping an iDRAC from within an OS using the same LOM that is being shared
Summary: This article provides information about pinging an iDRAC from within an Operating System when the iDRAC is being shared with the same LOM.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
An iDRAC that shares a network port with the OS can only be reached if the OS and iDRAC work in separate VLANs.
Users can configure a Dell EMC PowerEdge iDRAC to operate on one or more of the LOM ports. This is a common practice to limit the number of physical switch ports required in the network environment or provide physical redundancy to the iDRAC. With this configuration, an end-user may notice that the Host Operating System cannot ping or connect to its own iDRAC IP on the shared port.
Cause
This behavior is a Layer-2 networking limitation when both the Host Operating System and iDRAC are using the same VLAN. When a broadcast packet is sent from the Host Operating System, the broadcast excludes the source switch port. In this scenario, the iDRAC will not the broadcast request.
Resolution
In order to resolve this issue, Dell Technologies Engineering recommends the Host Operating System and iDRAC exist on separate VLANs. In order to achieve this configuration, there are some considerations that must be considered:
- The leveraged LOM port must connect to a trunk switch port that is a member of both VLANs.
- See Network Adapter User Guides or Host Operating System documentation on how to tag VLAN IDs from within the Host Operating System for the shared NIC.
- Enable VLAN ID Settings in the F2 System Setup >> iDRAC Settings >> Network Settings >> VLAN Settings.
Affected Products
C Series, Modular Infrastructure, Rack Servers, Tower Servers, XR Servers, OEM Server SolutionsProducts
iDRAC8, iDRAC9Article Properties
Article Number: 000139059
Article Type: Solution
Last Modified: 03 Apr 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.