Precision 7820 and 7920 Workstations Have Errors in Windows 10 Device Manager after an Intel Cascade Lake Processor Upgrade

Summary: This article explains how to troubleshoot and fix errors in Windows Device Manager after processor upgrade on Dell Precision 7820 or 7920.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


Error in Device Manager after processor upgrade

You may notice Windows 10 Device Manager errors for Other Devices (Unknown Device) or Other Devices (Performance Counters) after you upgrade your Precision Tower or Rack systems to a Cascade Lake processor using operating system images that were created before May 28, 2019.

Affected Systems

  • Precision 7820 Tower
  • Precision 7920 Tower
  • Precision 7920 Rack

Cause


No Cause information

Resolution


Install Intel Chipset Device Software Driver

NOTE: To learn more about downloading and installing device drivers on your Dell computer, see Drivers & downloads - FAQ.
  1. Browse to the Dell Drivers & Downloads page:
  2. Ensure you have selected the correct Operating System.
  3. Under Category, select Chipset.
  4. Locate the latest Intel Chipset Device Software Driver.
  5. Click Download and save the file to your computer.
  6. Open File Explorer and browse to the location where the downloaded file is saved.
  7. Double-click the Intel Chipset Device Software Driver setup file and follow the on-screen instructions to complete the installation process.
  8. Restart the computer.

Affected Products

Precision 7820 Tower, Precision 7920 Tower, Precision 7920 Rack
Article Properties
Article Number: 000139131
Article Type: Solution
Last Modified: 22 Apr 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.