Avamar:バックアップがデータなしステータスで失敗する - プラグインのバージョンを判断できない

Summary: バックアップが「No Data」ステータスで失敗する - Avagentで「プラグインのバージョンを特定できない」とレポートされる

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

スケジュール設定されたバックアップまたは[ポリシー]ウィンドウから開始されたバックアップは、ただちに失敗し、「データなし」のステータスになります。

アクティビティ モニターにデータがない場合のエラーを示す画像 

  • ステータスにカーソルを合わせると、「アクティビティー失敗 - クライアントにはデータセットで指定されたデータがありません」と表示されます。

    アクティビティ モニターにデータがない場合のエラーを示す画像 
  • [アクティビティー レポート]タブには、次のように表示されます。

    状態コード 30915 を示す画像   データセットにデータがないためにアクティビティーが失敗したことを示す画像 
    • Status_code "30915" とstatus_code_summary "アクティビティが失敗しました - クライアントにはデータセットで指定されたデータがありません
  • [アクティビティ - 失敗]レポートでは、次のように表示されます。

    レポートの実行時にデータがないためにエラー30915アクティビティーが失敗したことを示す画像 
    • ステータス「30915: アクティビティが失敗しました - クライアントにはデータセットで指定されたデータがありません

Cause

このエラーの原因となる要因はいくつかあります。

  • 以下に記載されていないエラーについては、その他の原因と解決策について解決パスを参照してください
  • これが、Data Domainへのポイント バックアップのみにロックされているAVEまたはシングル ノードの場合、これは想定どおりの動作です。
    • Avamar-DataDomainの統合: AvamarおよびAvamar Virtual Editionのすべてのバックアップをシングル ノードのData Domainバックエンドにロックする方法
      • [Server]列に「DD-server-name」と表示されていることに注目してください。
        アクティビティ モニターにデータがない場合のエラーを示す画像 
      • バックアップ、リストア、管理ウィンドウのバックアップタブを使用して、クライアントのアクセス性を確認します。

        参照を使用した接続の検証を示す画像 
        • プラグインが表示され、参照可能な場合は、解決パスを参照してください。
      • プラグインが表示されず、「このクライアントの構成はブラウズをサポートしていません」または「クライアントxxxxxのプラグインが見つかりません」というウィンドウが表示された場合。次に、クライアント マシン上のavagent.logを調べる必要があります。

        クライアント プラグインが検出されず、参照に失敗した場合の障害を示す画像  

        クライアント プラグインが検出されない場合の障害を示す画像 
        • avagent.logは、デフォルトでC:\Program Files\avs\varにあります。
      • Avamarグリッド上の管理コンソール サーバー(MCS)またはクライアント マシン自体がプラグインを無効にしています。
        • MCSがプラグインを無効にしている場合は、「解決パス」を参照して適切な解決策を確認してください。
        • クライアント マシン自体がプラグインを無効にしている場合、ログには次のようなエラーが記録されます。
avagent Error <5451>: Failed to get plugin 'Windows' version with code 0xc0000142: No error description string
avagent Error <5924>: Unable to determine plugin version for Windows pin file C:\Program Files\avs\bin\windows.pin
avagent Error <5937>: Plugin Windows disabled
  • または
 
avagent Error <5451>: Failed to get plugin 'Windows' version with code 128: There are no child processes to wait for 
avagent Error <5924>: Unable to determine plugin version for Windows pin file C:\Program Files\avs\bin\windows.pin 
avagent Error <5937>: Plugin Windows disabled 
  • または
     
avagent Error <5451>: Failed to get plugin 'Windows' version with code 255: The extended attributes are inconsistent
avagent Error <5924>: Unable to determine plugin version for Windows pin file C:\Program Files\avs\bin\windows.pin
avagent Error <5937>: Plugin Windows disabled


これらのエラーは、「Windows VSS」、アップデート、SQLなどのマシンにインストールされているすべてのプラグインで繰り返されます

ログでは、次の内容が報告されます(インストールされているAvamarクライアントのバージョンによって異なります)。

avagent Warning <7145>: No pin files found

 

  • または
     
avagent Warning <7184>: No pin files found

 

Windowsイベント ビューアーでシステム ログを開き、次のようなイベントID 243を探します。
 
Log Name:      System
Source:        Win32k
Date:          4/24/2014 10:54:54 AM
Event ID:      243
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      Workstation.emc.com
Description:
A desktop heap allocation failed.


デスクトップヒープは、ローカルシステムアカウントを使用するすべてのアプリケーションのための共有メモリストレージスペースです。イベント ビューアーのシステム ログに「デスクトップ ヒープ割り当て」エラー メッセージが表示される場合は、メモリー リークが原因である可能性があります。クライアント上のアプリケーションは、RAM使用率が低い場合でも、デスクトップヒープに割り当てられたすべてのメモリを使用している可能性があり、この問題を引き起こしています

この問題が発生した場合、再起動が実行されるまで、バックアップは同じエラーで失敗し続けます。再起動後、バックアップは数日間再び機能し、その後再び失敗し始めます。もう一度再起動すると、さらに数日間問題が修正されます。
 

注:  クライアントの初期アクティベーション中にプラグインの登録に失敗した場合は、ウイルス対策ソフトウェアもこの問題を引き起こす可能性があります。
Symantecなどの一部のウイルス対策ソフトウェアでは、安全性の高い設定や厳密なスキャン設定が設定されている場合があり、avtarおよびデータベース プラグインの登録を妨げています。
Avamar Clientのインストールおよび登録時に、ウイルス対策ソフトウェアでavtar.exeおよびavagent.exeプロセスを除外しても機能しない場合があります。

Resolution

これがAVEまたはシングル ノードで、Data Domainへのポイント バックアップのみにロックされている場合は、データセットを調整して適切なData Domainに直接バックアップします。

ウイルス対策のためにプラグインが登録されない場合は、次の手順を実行します。ウイルス対策ソフトウェアを一時的に無効にして、実行中の既存のウイルス対策プロセスをすべて強制終了します。その後、通常どおりにAvamar ClientのMSIパッケージを再インストールします。

デスクトップ ヒープ割り当ての失敗によりプラグインが無効になっている場合のオプションは次のとおりです。

  1. メモリー リークが発生している可能性のあるアプリケーション/プログラムを無効にするか、削除します。問題のあるプログラムを見つけるために、Microsoftサポートと協力してください。または、スケジュールに基づいてマシンを再起動すると、デスクトップヒープが一時的にフラッシュされます。
  2. レジストリーの最大ヒープ値を引き上げ、Windowsクライアントを再起動して変更を有効にします。手順と推奨される値については、次のURLを使用してください。
  3. 問題のあるアプリケーションを特定できない場合、またはアプリケーションが識別されている間に推奨される長期的修正。
    • Avamarの「Backup Agent」サービスをデフォルトのNT Authority\SYSTEMアカウントから、Windowsクライアントで十分な権限を持つドメイン ユーザー アカウントに変更し、サービスを再起動して変更を有効にします。バックアップ エージェント サービスはデフォルトでシステム アカウントとして実行されますが、Windowsクライアントで少なくとも読み書きアクセス権を持つ任意のNTドメイン アカウントを使用できます。これが機能するのは、Avamarサービスがシステムとしてログインしている他のプログラム(メモリー リークのあるプログラムを含む)と同じヒープを使用しなくなるためです。
    • 以下のURLには、この問題およびその他の回避策の詳細が記載されています。

Affected Products

Avamar Client, Avamar Plug-in
Article Properties
Article Number: 000159530
Article Type: Solution
Last Modified: 19 Nov 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.