Avamar:備份失敗,無資料狀態 - 無法判斷外掛程式版本
Summary: 備份失敗並顯示「無資料」狀態 - Avagent 回報「無法判定附掛程式版本」。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
排定備份或從「原則」視窗啟動的備份會立即失敗,狀態為「無資料」。
- 將滑鼠停留在狀態上會顯示「活動失敗 - 用戶端沒有資料集指定的資料」
- 在「活動報告」標籤上,會顯示為:
- Status_code「30915」和status_code_summary「活動失敗 - 用戶端沒有資料集指定的資料
- 在「活動 - 失敗」報告中,會顯示為:
- 狀態「30915:活動失敗 - 用戶端沒有資料集指定的資料」
Cause
有幾件事可能會導致此錯誤。
- 對於下面未列出的錯誤,請參閱解決方法路徑,瞭解其他原因和解決方案。
- 如果這是 AVE 或單一節點鎖定至僅點備份至 Data Domain,這是正常現象。
- Avamar-DataDomain 整合:如何將所有 Avamar 和 Avamar Virtual Edition 備份鎖定至 Data Domain 後端的單一節點。
- 請注意,在「伺服器」欄中應顯示 DD-server-name
- 使用「備份」、「還原」及「管理」視窗中的「備份」標籤,確認用戶端存取功能。
- 如果附掛程式可看見且可流覽,請參閱解決方案路徑。
- 如果外掛程式不可見,並且出現一個視窗,指出“此用戶端的配置不支援流覽”或“找不到用戶端 xxxxx 的外掛程式”。然後,必須檢查客戶端電腦上的avagent.log。
- avagent.log預設位於 C:\Program Files\avs\var 中。
- Avamar Grid 上的管理主控台伺服器 (MCS) 或用戶端機器本身正在停用附掛程式。
- 如果 MCS 停用附掛程式,請參閱解決方案路徑以取得適當的解決方案。
- 如果用戶端電腦本身禁用外掛程式,日誌將記錄如下錯誤。
- 請注意,在「伺服器」欄中應顯示 DD-server-name
- Avamar-DataDomain 整合:如何將所有 Avamar 和 Avamar Virtual Edition 備份鎖定至 Data Domain 後端的單一節點。
avagent Error <5451>: Failed to get plugin 'Windows' version with code 0xc0000142: No error description string
avagent Error <5924>: Unable to determine plugin version for Windows pin file C:\Program Files\avs\bin\windows.pin
avagent Error <5937>: Plugin Windows disabled
- 或
avagent Error <5451>: Failed to get plugin 'Windows' version with code 128: There are no child processes to wait for
avagent Error <5924>: Unable to determine plugin version for Windows pin file C:\Program Files\avs\bin\windows.pin
avagent Error <5937>: Plugin Windows disabled
- 或
avagent Error <5451>: Failed to get plugin 'Windows' version with code 255: The extended attributes are inconsistent
avagent Error <5924>: Unable to determine plugin version for Windows pin file C:\Program Files\avs\bin\windows.pin
avagent Error <5937>: Plugin Windows disabled
這些錯誤會在安裝在「Windows VSS」、更新、SQL 等電腦上的所有外掛程式重複發生。
記錄報告 (視安裝的 Avamar 用戶端的版本而定):
avagent Warning <7145>: No pin files found
- 或
avagent Warning <7184>: No pin files found
在 Windows 事件檢視器中,開啟 系統記錄 並尋找 事件 ID 243 ,如下所示:
Log Name: System
Source: Win32k
Date: 4/24/2014 10:54:54 AM
Event ID: 243
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
Computer: Workstation.emc.com
Description:
A desktop heap allocation failed.
桌面堆是使用本地系統帳戶的所有應用程式的共用記憶體存儲空間。如果在事件查看器的系統日誌中看到「桌面堆分配」失敗消息,則可能是由於記憶體洩漏。即使 RAM 使用率較低,用戶端上的應用程式也可能正在使用分配給桌面堆的所有記憶體,從而導致此問題。
發生這種情況時,備份會繼續失敗並出現相同的錯誤,直到執行重新開機為止。重新開機後,備份會再次運作數天,然後再次開始失敗。再次重新開機會再修復幾天的問題。
注意: 如果附掛程式在初始用戶端啟動期間無法註冊,防毒軟體也可能會導致此問題。
某些防毒軟體(如 Symantec)可能配置了高度安全和/或嚴格的掃描設置,這會阻止註冊 avtar 和資料庫外掛程式。
甚至在 Avamar 用戶端安裝和註冊期間,排除防毒軟體中的avtar.exe和avagent.exe程序也可能無法運作。
Resolution
如果這是 AVE 或單一節點鎖定至僅點備份至 Data Domain,請調整資料集以直接備份至適當的 Data Domain。
如果附掛程式因 防毒軟體而未註冊:暫時停用防毒軟體,並終止任何正在執行的現有防毒程序。然後正常重新安裝 Avamar 用戶端 MSI 套件。
如果由於 桌面堆分配失敗而禁用外掛程式,則選項如下:
- 停用或移除任何可能發生記憶體洩漏的應用程式/程式。與Microsoft支援合作,以找到有問題的程式。或者,按計劃重新啟動計算機會暫時刷新桌面堆。
- 增加註冊表中的最大堆值,然後重新啟動 Windows 用戶端以使更改生效。使用以下 URL 取得程序和建議值:
- 如果無法識別違規應用程式或正在識別應用程式,則首選長期修復。
- 將 Avamar「備份代理程式」服務從預設的 NT Authority\SYSTEM 帳戶變更為在 Windows 用戶端上具有足夠權限的網域使用者帳戶,然後重新啟動服務以使變更生效。雖然預設情況下備份代理服務作為 SYSTEM 帳戶運行,但您可以使用在 Windows 用戶端上至少具有 R/W 訪問許可權的任何 NT 域帳戶。這有效,是因為 Avamar 服務將不再使用與以系統身分登錄的其他程式(包括發生記憶體洩漏的程式)相同的堆。
- 以下 URL 提供有關此措施和其他因應措施的更多詳細資料:
Affected Products
Avamar Client, Avamar Plug-inArticle Properties
Article Number: 000159530
Article Type: Solution
Last Modified: 19 Nov 2025
Version: 7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.