Avamar: Hyper-V yedeklemeleri Erişim Reddedildi hatalarıyla başarısız oluyor

Summary: Avamar - Hyper-V yedeklemeleri Erişim Reddedildi hatalarıyla başarısız oluyor.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Bu senaryoda, Hyper-V yedekleme hatalarıyla karşılaşırız ve yedekleme günlüklerinde aşağıdaki örnekteki gibi "AccessDenied" hata mesajları gösterilir:

From Hyper-V Plugin log:
================
avhypervvss Info <0000>: Error in connecting with the namespace: Exception 'GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))'
avhypervvss Info <0000>: Failed to get the VM info: Excpetion 'GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))'
avhypervvss Info <0000>: QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
avhypervvss Info <0000>: QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
avhypervvss Info <0000>: GetClusterVMs : QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : 
                         Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
avhypervvss Info <0000>: Exception in GetClusterVMs GetClusterVMs : QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection :
                         Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)).

avhypervvss Error <41753>: Unable to get the clustered VMs for backup. 
avhypervvss Error <41731>: Failed to collect the list of local VMs on this host
avhypervvss Error <41581>: Failed to backup targets. Unable to expand targets.
avhypervvss Error <41662>: Failed to validate and expand the targets.
avhypervvss Error <41659>: Backup did not complete successfully


From cluster service log:
================
winclustersvc DEBUG<0000>: ===> QueryVmsFull 
winclustersvc INFO<0000>:  Get the basic info for the target VMs 
winclustersvc INFO<0000>:  Start getting the basic of the VMs 
winclustersvc DEBUG<0000>: Connect with namespace '\\xxxxxxxx\root\virtualization\v2' 
winclustersvc ERROR<0000>: Error in connecting with the namespace: Exception 'GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))' 
winclustersvc ERROR<0000>: Failed to get the VM info: Excpetion 'GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))' 
winclustersvc ERROR<0000>: QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) 
winclustersvc ERROR<0000>: QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) 
winclustersvc ERROR<0000>: GetClusterVMs : QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : 
                           Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) 
winclustersvc ERROR<0000>: Exception in GetClusterVMs GetClusterVMs : QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : 
                           Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)).

 

 

Cause

Bu tür hatalar kendi kendini açıklayıcıdır. Bu hatalar, Avamar hizmetlerinin (yerel aracı ve küme aracısı) kullanıcı hesabının Windows Yönetim Araçları (WMI) sorgularını çalıştırmak için yeterli izinlere sahip olmadığı anlamına gelir.

 

Bu sorunu çözmek için Avamar istemci hizmetlerini çalıştırmak üzere kullanılan kullanıcı hesabına doğru izinleri verin.

 

Resolution

Additional Information

Bu, "Hyper-V İçin Dell Avamar Kullanıcı Kılavuzu"nda da daha ayrıntılı olarak belirtilmiştir. 19.10 sürümüne ait rehber bağlantısına bakın veya başka bir sürüm için Avamar destek sayfasına bakın.

 

Affected Products

Avamar

Products

Avamar, Avamar Plug-in for Hyper-V VSS
Article Properties
Article Number: 000165638
Article Type: Solution
Last Modified: 10 Oct 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.