AppSync. Операция восстановления завершилась сбоем. Не удалось запустить базу данных Oracle в режиме монтирования.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Сбой операции восстановления новой установки
. Не удалось запустить базу данных Oracle в режиме монтирования.
Не удалось восстановить одну или несколько баз данных. Подробные сведения см. в журналах сервера и агента.
AppSync успешно смонтировано, но не удалось выполнить восстановление.
Не удалось запустить базу данных Oracle в режиме монтирования.
Клиент AppSync версии 3.8.0.0. Операционная система хоста — Redhat RHEL 6 и RHEL 7.
<Дата> oracle.py[4117]:_execSql() SQLresult:
ORA-01078: сбой в обработке параметров
<системы Дата> oracle.py[4117]:_execSql() SQLresult:
ORA-00823: Указанное значение sga_target больше
sga_max_size
<Дата> oracle.py[4117]:_execSql() SQLresult: Отключенная
<дата> oracle.py[4120]:_execSql() Ошибка:
Создание даты исключения SQLPlusException
<oracle.py> [4117]:_execSql()() SQLresult: SYS:CAD13141>SYS:CAD13141>ORA-01078:сбой
при обработке системных параметров
. Не удалось запустить базу данных Oracle в режиме монтирования.
Не удалось восстановить одну или несколько баз данных. Подробные сведения см. в журналах сервера и агента.
AppSync успешно смонтировано, но не удалось выполнить восстановление.
Не удалось запустить базу данных Oracle в режиме монтирования.
Клиент AppSync версии 3.8.0.0. Операционная система хоста — Redhat RHEL 6 и RHEL 7.
<Дата> oracle.py[4117]:_execSql() SQLresult:
ORA-01078: сбой в обработке параметров
<системы Дата> oracle.py[4117]:_execSql() SQLresult:
ORA-00823: Указанное значение sga_target больше
sga_max_size
<Дата> oracle.py[4117]:_execSql() SQLresult: Отключенная
<дата> oracle.py[4120]:_execSql() Ошибка:
Создание даты исключения SQLPlusException
<oracle.py> [4117]:_execSql()() SQLresult: SYS:CAD13141>SYS:CAD13141>ORA-01078:сбой
при обработке системных параметров
Cause
При использовании пользователя root для установки клиента
Oracle AppSync LinuxAppSync унаследует некоторые параметры профиля пользователя root.
Пользователь Oracle, которого использует AppSync, унаследует настройки ULIMIT пользователя root, когда AppSync эмулирует пользователя Oracle.
AppSync требует, чтобы настройки ulimit для пользователя root были равны или больше значений ulimit для пользователя Oracle.
Для установки клиента Oracle AppSync Linux рекомендуется использовать пользователя SUDO.
Это позволит заказчику установить ограничения ulimits пользователя SUDO выше или соответствовать лимитам Oracle.
Oracle AppSync LinuxAppSync унаследует некоторые параметры профиля пользователя root.
Пользователь Oracle, которого использует AppSync, унаследует настройки ULIMIT пользователя root, когда AppSync эмулирует пользователя Oracle.
AppSync требует, чтобы настройки ulimit для пользователя root были равны или больше значений ulimit для пользователя Oracle.
Для установки клиента Oracle AppSync Linux рекомендуется использовать пользователя SUDO.
Это позволит заказчику установить ограничения ulimits пользователя SUDO выше или соответствовать лимитам Oracle.
Resolution
Настройки ulimit для Oracle и ulimit для пользователя root.
Во время этой установки была необычная настройка, при которой параметры пользователя Oracle ublimit были больше, чем у пользователя root.
Временное решение. Проблема была решена путем ручного изменения системы для сопоставления ulimits между root и oracle. Добавление корневого ulimits в /etc/security/limits.conf
Исправление: Рекомендуется использовать пользователя SUDO. Это позволит заказчику установить ограничения для пользователя SUDO в соответствии с ограничениями Oracle.
См. статью базы знаний (https://support.emc.com/kb/485322), чтобы узнать, как настроить пользователя SUDO.
Affected Products
AppSyncProducts
AppSyncArticle Properties
Article Number: 000168560
Article Type: Solution
Last Modified: 18 Sep 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.