AppSync: Cannot add UNIX client to AppSync Server using SUDO user

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Symptoms

New UNIX (AIX) Host Plug-In install in AppSync GUI.

The user has to use a SUDO UNIX user and does not allow direct root login.

Cannot add UNIX client to AppSync Server using SUDO user.

AppSync GUI dialog message:

User does not have requisite permissions to run deployment. Configure user in the sudousers file on unix agent or provide the required permissions.

 AppSync Server Log

service.xio.XIOServiceBean.discoverXMS(com.emc.archway.context.ExecutionContext,com.emc.archway.objectmodel.storage.xio.XIOManagementServer)
throws com.emc.archway.service.eventservice.exceptions.XIOManagementServerInvalidLoginException,
com.emc.archway.service.eventservice.exceptions.XIOConnectionFailureException,
com.emc.archway.errorMessages.XIORequestFailedException,com.emc.archway.errorMessages.XIORESTException

acp.....OK.
aix/host.pyc.....FAILED.
generic/oracle.pyc.....FAILED.
library.zip.....OK.
WARNING: 2 of 4 files do not have the same message-digest.

INFO [Thread-189340 (HornetQ-client-global-threads-1147589765)] 
[] Verification failed, deploying latest acp
ERROR [Thread-189340 (HornetQ-client-global-threads-1147589765)] 
[] slibclean failed: ksh: slibclean: 0403-006 Execute permission denied.
WARN [Thread-189340 (HornetQ-client-global-threads-1147589765)]
[] File is already deleted: appsync.tar

Cause

Incorrect entries in the sudoers file and sftp-server not running as the correct user.

Resolution

  1. Confirm the following entries in sudo file. If the operator wants to use the sudo user 'appsync', then entry should be:
Required entries in the sudo file:
Defaults:appsync !requiretty
Defaults:appsync !env_reset
Defaults secure_path = /sbin:/bin:/usr/sbin:/usr/bin
appsync ALL = (root) NOPASSWD: /opt/emc/appsync/acp
  1. IMPORTANT: Verify the SFTP server service is running.
Run the following command to check SFTP is working properly 
sftp  P <Port-Number> <User-Name@AppSync-Server-IPAddress>
 
EXAMPLE GOOD RESPONSE:
#sftp  P 22 asadmin@10.10.10.10
asadmin@10.10.10.10 password:
connected to 10.10.10.10
sftp>
 
EXAMPLE BAD RESPONSE:
#sftp  P 22 asadmin@10.10.10.10
asadmin@10.10.10.10 password:
subsystem request failed on channel 0
connection closed
#
  1. Delete all the files on the client side in the /opt/emc/appsync directory.
Create a folder /appsync under /opt/emc, with read, write, and execute permissions for SUDO user appsync for the install path /opt/emc/appsync/.
This means that the directory has to be owned by "appsync" user.
  1. The ownership and correct write permissions should be there on the /opt/emc/appsync directory.
For the appsync user, umask should be set to 037 Use chmod -R 775 /opt/emc/appsync or chmod g+s /opt/emc/appsync
  1. Check the permissions of the .rsp file on the AppSync client.
By default, it always gets generated with root as the owner (a default behavior for SUDO user) and we have to programmatically change the ownership to SUDO user.
  1. Confirm there are no firewalls blocking the SFTP operation. Try to manually transfer a file using sftp as the appsync user.

Additional Information

Also see: Reference guide: AppSync-2.2.3-Installation-and-Configuration-Guide
UNIX host plugin push install with SUDO user -> Refer AIX section.
In this case 'appsync' is the sudo user. You should add lines under sudoer file:
Defaults:appsync !requiretty
Defaults:appsync !env_reset
Defaults secure_path = /sbin:/bin:/usr/sbin:/usr/bin

appsync ALL = (root)NOPASSWD:/opt/emc/appsync/acp

Also See: KB article 483004: AppSync: Push install to Linux host fails when performed by a SUDO user

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000056621
Article Type: Solution
Last Modified: 18 Sep 2025
Version:  3
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