NetWorker Management Console: Delete or Decommission Policy Not Disappearing from Monitoring Tab
Summary: After deleting a policy that previously ran, the policy gets disabled and cannot be removed from the monitor tab in NetWorker Management Console (NMC).
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
After deleting a policy that previously ran, the policy gets disabled and cannot be removed from the monitoring tab.
After deleting a policy, it gets automatically removed from the Policy tab:
However, event though it is disabled, the policy still shows under the monitoring tab:
After deleting a policy, it gets automatically removed from the Policy tab:
Cause
The status of a policy as displayed in the Monitoring tab is stored in the
jobsdb database. The nsrjobd daemon is one of the NetWorker server daemons. It is responsible for spawning and monitoring of jobs of NetWorker client binaries. This database is not automatically updated, the policy shows under the monitoring tab until the jobsdb retention period is met.Resolution
The policy information is stored in the
To check or modify the
From the NetWorker Management Console (NMC) UI:
jobsdb database. The policy disappears from the Monitoring tab when the jobsdb is reset upon reaching the retention time.
To check or modify the
jobsdb retention, do the following:
From the NetWorker Management Console (NMC) UI:
- Log in to the NMC UI.
- Go to the Protection Tab.
- On the upper left you find the name of the NetWorker Server, right click it and open the Properties.
- Under the NetWorker Server Properties change to the Configuration tab:
- Check or change the
jobsdbretention.
- Open an elevated command prompt or login as root in your NetWorker server.
- Initialize the NetWorker Administrative program:
>nsradmin
- Display the NetWorker Server resources and verify what the retention time for the
jobsdbis:>p type: nsr
- If you want to modify the retention time, use the following command:
>update Jobsdb retention in hours: <time in hours>
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000168599
Article Type: Solution
Last Modified: 14 Aug 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.