AppSync: SQL-godkendelse mislykkes efter ændring af forbindelsesoplysningerne for SQL og derefter har en eller få vellykkede kørsler.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Adgangskoden blev ændret for SQL-forbindelsen.
I eksemplet i denne artikel er adgangskoden ændret fra 7 alfanumeriske tegn/symboltegn til 12. 
Efter denne ændring kørte serviceplanen fint to gange, men mislykkedes, som denne artikel dokumenterer ved tredje kørsel.

Når du har ændret legitimationsoplysningerne for en SQL-forbindelse, kan en serviceplan køre én eller nogle få gange med succes.
Efter en eller få vellykkede kørsler mislykkes serviceplanen imidlertid med følgende:

 AppSync CSV-hændelserne viser:
 
2019-10-10 09:52:02.18, Programregistrering, ,GENL_000003,kildevært,Kunne<> ikke godkende ved hjælp af de angivne legitimationsoplysninger.
 Kontroller, at legitimationsoplysningerne er korrekte, og at kontoen har de nødvendige rettigheder og privilegier.
 Yderligere oplysninger: Logonfejl: ukendt brugernavn eller ugyldig adgangskode.

AppSync-pluginloggen for kildeværten viser:
 
2019-10-10 09:52:05.197 INFO [<sourcehost>] [<unikt nummer>] SQL: Oprette forbindelse til database <DBName.master>
2019-10-10 09:52:05.197 INFO [<sourcehost>] [<unikt nummer>] SQL: efterligner <domæne\bruger>
2019-10-10 09:52:05.228 FEJL [<sourcehost>] [<unikt nummer>] SQL: Kunne ikke godkendes ved hjælp af de angivne legitimationsoplysninger. Kontroller, at legitimationsoplysningerne er korrekte, og at de har de nødvendige rettigheder og rettigheder. Yderligere oplysninger: Logonfejl: ukendt brugernavn eller ugyldig adgangskode.

AppSync-serverlog vil vise:
 
10-10-2019 09:52:00.805 INFO [Tråd-3009 /id<>domæne><Domæne<>/domæneadgangskode><<>/adgangskode<>brugernavn<>Bruger></brugernavn></legitimationsoplysninger
<>
10-10-2019 09:52:02.180 FEJL [Thread-3009 (HornetQ-client-global-threads-216778052)] [org.jboss.as.ejb3.invocation] [] [] WFLYEJB0034: EJB-aktivering mislykkedes på komponenten SqlServiceBean for metode offentlig com.emc.archway.objectmodel.host.sql.SqlServerInstances com.emc.archway.service.sqlservice. <fjernet>... HostPluginDownException: javax.ejb.EJBException: java.lang.RuntimeException

Bemærk: De første eller få vellykkede kørsler kan vise et andet antal stjerner i serverloggen, hvis den nye adgangskode indeholder et andet antal alfanumeriske tegn/specialtegn. Som i nedenstående eksempel, hvor adgangskoden blev ændret fra at have 7 alfanumeriske / specialtegn til 12.
 
10-10-2019 09:15:05.704 INFO [Tråd-2952 /id><domæne>MESSA< / domæne><adgangskode<> / adgangskode><brugernavn>Bruger< / brugernavn / legitimationsoplysninger<>
<> 

 
Ved en efterfølgende mislykket kørsel skal du derefter bemærke, at adgangskoden er kortere:
 
10-10-2019 09:52:00.805 INFO [Tråd-3009 /id<>domæne><Domæne<>/domæneadgangskode><<>/adgangskode<>brugernavn<>Bruger></brugernavn></legitimationsoplysninger
<>

Cause

Softwarefejl, hvor AppSync opdaterer legitimationsoplysningerne, brugte et andet og upassende tidspunkt, hvilket er under serviceplanens kørsel.

Resolution

Løsning:

Der findes et hotfix, som kan løse dette problem med AppSync 3.8.

Angiv denne artikel, når du indkalder en serviceanmodning vedrørende problemet.

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000168662
Article Type: Solution
Last Modified: 19 Aug 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.