Multiple Deployed Instances of Dell Security Management Server Virtual May Receive the Same IP Address

Summary: Deploying multiple v10.2.14 to 11.1.1 Dell Security Management Server instances that obtain an IP address with DHCP results in duplicate IP addresses being assigned.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Product:

  • Dell Security Management Server

Affected Versions:

  • v10.2.14 to 11.1.1

Affected Operating System:

  • Ubuntu 18.04

The same IP address is assigned to each instance, when deploying multiple instances of Dell Security Management Server Virtual with a single OVA version, within a single DHCP domain.

Cause

This issue is the result of the Dell Security Management Server Virtual upgrade to Ubuntu 18.04 and the change to network management using Netplan. By default, Netplan sends a randomly generated machine ID instead of the device’s MAC address when requesting an IP address from the DHCP server. This machine ID is already set in the Device Management Server Virtual OVA. This results in a nonunique machine ID when multiple Dell Security Management Server devices are deployed.

Resolution

To avoid this issue, update the Machine ID using the following steps.

  1. Before changing the Dell Security Management Server Virtual device, take a backup and offload it from the server or take a snapshot of the VM.
    Note: For more information about creating and offloading a backup, reference How to Backup and Restore Dell Security Management Server Virtual / Dell Data Protection Virtual Edition.
  2. From the Dell Security Management Server Virtual Console Main Menu, select Launch Shell and then press Enter.
    Image depicts the main menu of Dell Security Management Server Virtual with Launch Shell selected.
  3. Type su dellsupport and then press Enter.
    Image depicts the su dellsupport command in Shell.
  4. Type the password for dellsupport and then press Enter.
    Image depicts Shell prompting for the dellsupport account password.
    Note:
    • The default credentials for Dell Security Management Server Virtual are:
      • Username: dellsupport
      • Password: dellsupport
    • An administrator can change the default password within the product’s virtual appliance menu.
  5. Type the command cat /etc/machine-id and then press Enter to check the current machine ID.
    Image depicts the cat /etc/machine-id command in Shell with an example result.
  6. Type the command sudo rm /etc/machine-id and then press Enter to remove the current machine ID.
    Image depicts the sudo rm /etc/machine-id command in Shell.
  7. Type the command sudo systemd-machine-id-setup and then press Enter to generate a new machine ID.
    Image depicts the sudo systemd-machine-id-setup command in Shell.
  8. Type the command sudo netplan apply and then press Enter to apply the new machine ID.
    Image depicts the sudo netplan apply command in Shell.
  9. Type the command cat /etc/machine-id and then press Enter to validate the new machine ID.
    Image depicts the cat /etc/machine-id command in Shell.

To contact support, reference Dell Data Security International Support Phone Numbers.
Go to TechDirect to generate a technical support request online.
For additional insights and resources, join the Dell Security Community Forum.

Affected Products

Dell Encryption
Article Properties
Article Number: 000191828
Article Type: Solution
Last Modified: 19 Sep 2024
Version:  6
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