AppSync: AppSync UI is slow and spinning while listing SQL related copies of service plan or copies under host
Summary: While listing the SQL copies of a service plan or of a host, the AppSync UI slowed and continued to spin. The environment has a service plan which was running at 30 minutes interval through out the day and configured to retain 96 copies. ...
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Symptoms
If we go to AppSync UI > Copy Management > Copies & Application type (SQL) > Select into the host, the UI is spinning and the copy details never display.
If we look at the server logs at the same timestamp, we see AppSync server performing the REST request to list copies but this does not result in any output and throughout. The logs see AppSync checking the rotation policy to retain the required number of copies:
If we look at the server logs at the same timestamp, we see AppSync server performing the REST request to list copies but this does not result in any output and throughout. The logs see AppSync checking the rotation policy to retain the required number of copies:
<DATE & TIME> INFO [default task-1189] [com.emc.archway.restapi.restresources.phasepit.AtomPhaseStatus] [<AppSync Server>] [] d1a556fa-1dde-435c-af3a-7dd794057948->>> baseUriStr = https://<AppSync Server>.xxx.com:8445/appsync/rest/instances/phasepit::f22e2756-e6ff-425c-bdf9-92f5b2bec8b5/relationships/phaseStatus [<AppSync Server> ]
<DATE & TIME> INFO [default task-1203] [com.emc.archway.restapi.RestPreprocessorInterceptor] [<AppSync Server>] [] HttpRequest [GET] : https://<AppSync Server>.xxx.com:8445/appsync/rest/instances/servicePlan::f30755ab-5ff9-45e2-a6a9-da9c62e8aa78/relationships/copies?GUI=true&startTime=2021-11-29-08:43:49AM [<AppSync Server> ]
<DATE & TIME> INFO [default task-1203] [com.emc.archway.restapi.restresources.serviceplan.ServicePlanInstancesResource] [<AppSync Server>] [] 419910c5-078b-4e65-9970-252e6f0b485e->>> Getting all copies for service plan: f30755ab-5ff9-45e2-a6a9-da9c62e8aa78
<DATE & TIME> INFO [default task-1226] [com.emc.archway.restapi.restresources.serviceplan.ServicePlanTypesResource] [<AppSync Server>] [] 5f015c54-c866-49ca-a59e-8c50f5f44c1f->>> Getting all service plans
<DATE & TIME> INFO [default task-1203] [com.emc.archway.restapi.RestPreprocessorInterceptor] [<AppSync Server>] [] HttpRequest [GET] : https://<AppSync Server>.xxx.com:8445/appsync/rest/instances/servicePlan::f30755ab-5ff9-45e2-a6a9-da9c62e8aa78/relationships/copies?GUI=true&startTime=2021-11-29-08:43:49AM [<AppSync Server> ]
<DATE & TIME> INFO [default task-1203] [com.emc.archway.restapi.restresources.serviceplan.ServicePlanInstancesResource] [<AppSync Server>] [] 419910c5-078b-4e65-9970-252e6f0b485e->>> Getting all copies for service plan: f30755ab-5ff9-45e2-a6a9-da9c62e8aa78
<DATE & TIME> INFO [default task-1226] [com.emc.archway.restapi.restresources.serviceplan.ServicePlanTypesResource] [<AppSync Server>] [] 5f015c54-c866-49ca-a59e-8c50f5f44c1f->>> Getting all service plans
Cause
From reviewing the logs, it seems the AppSync server is not able to manage copy expiring efficiently and gets tied up on this.
Resolution
This issue is addressed in AppSync 4.3.0.1 and later. Upgrade to AppSync 4.3.0.1 or later to resolve this issue.
Products
AppSyncArticle Properties
Article Number: 000194692
Article Type: Solution
Last Modified: 28 Oct 2025
Version: 2
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