NetWorker:バックアップが失敗し、「Authentication error; why = Server rejected credential」と表示される
Summary: ストレージ ノード上のピア情報の問題により、バックアップが失敗して「Authentication error; why = Server rejected credential」というエラーが表示されます。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
バックアップが次のエラーで失敗します。
NetWorkerサーバーとNetWorkerクライアントのNSRピア情報はクリアされましたが、エラーが解決しません。
RPC Authentication: Client failed to obtain RPCSEC_GSS credentials: Authentication error; why = Server rejected credential
NetWorkerサーバーとNetWorkerクライアントのNSRピア情報はクリアされましたが、エラーが解決しません。
Cause
ピア証明書は、各NetWorkerシステムに保存されます。NetWorkerクライアント、ストレージ ノード、および/またはNetWorkerサーバー間のピア情報に関する問題により、このエラーが発生します。
Resolution
NSRピア情報をクリアする場合は、ストレージ ノードを含む、リストされているすべてのクライアント ピアのクライアント ピア情報をクリアしてください。
1.クライアント システムでadminまたはrootコマンド プロンプトを開き、次のコマンドを実行します。
2. a.ピア情報を手動で削除するには、システムのadminまたはrootコマンド プロンプトから次のコマンドを実行します。
b. nsradminは、-s remote_hostオプションを使用して、任意のNetWorkerシステムからリモートで実行することもできます。
次回、システム間でNetWorker通信が確立されると、新しいピア情報と証明書が自動的に生成されます。
1.クライアント システムでadminまたはrootコマンド プロンプトを開き、次のコマンドを実行します。
nsradmin -C -y -p nsrexecd "nsr peer information"
メモ: このコマンドは、ピアの不一致を検出して修正を試みます。その後、出力を確認し、修正に失敗したシステムをメモしておきます。このため、nsradminプロンプトからピア情報を手動で削除する必要があります。この同じコマンドを、コマンド出力で返されたすべてのシステムで実行して、対応する各システム上のピア証明書をフラッシュすることができます。
2. a.ピア情報を手動で削除するには、システムのadminまたはrootコマンド プロンプトから次のコマンドを実行します。
nsradmin -p nsrexec nsradmin> p type: nsr peer information; name: client_name nsradmin> delete
b. nsradminは、-s remote_hostオプションを使用して、任意のNetWorkerシステムからリモートで実行することもできます。
nsradmin -s server_name -p nsrexec nsradmin> p type: nsr peer information; name: client_name nsradmin> delete
メモ: server_nameとclient_nameを、nsradmin -C出力で返された値に置き換えます。これは、NetWorkerのサーバーとクライアントの構成の正確なエントリーと一致する必要があります。
次回、システム間でNetWorker通信が確立されると、新しいピア情報と証明書が自動的に生成されます。
Affected Products
NetWorkerArticle Properties
Article Number: 000203002
Article Type: Solution
Last Modified: 21 Feb 2023
Version: 8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.