PowerStore: Node Reboot due to internal tool causing memory leak
Summary: Node Reboot due to internal tool causing a memory leak.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Whenever a Data Collect is run there may be an unusual scenario where an internal tool does not exit properly. Resulting in a memory leak that grows until the node reboots. This issue was found to appear when Data Collect is used but the same issue may occur on other flows that use this internal tool.
Cause
Data Collects use various internal tools for collecting information about the appliance. One such tool was found to be causing a memory leak over a period of time (mostly several months).
Resolution
Workaround:
Contact Technical Support for assistance.
Permanent fix:
This issue is planned to be fixed in a future release.
Contact Technical Support for assistance.
Permanent fix:
This issue is planned to be fixed in a future release.
Affected Products
PowerStoreProducts
PowerStoreOSArticle Properties
Article Number: 000205076
Article Type: Solution
Last Modified: 27 Jun 2023
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.