NetWorker Management Console: Monitoring displays job timestamp in the wrong date and time format

Summary: NetWorker Management Console (NMC) UI Monitoring displays a job's timestamp in the date format as mm/dd/yyyy and time in 12-hour format instead of the regional setting of yyyy/mm/dd and time in 24-hour time format. ...

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Symptoms

NMC UI Monitoring displays a job's timestamp in the date format as mm/dd/yyyy and time in 12-hour format.
 
NMC Job's Timestamp Showing in Incorrect Format
Figure 1:
 NMC Job's Timestamp Showing in Incorrect Format

Cause

In the operating system, the Country and Region are set to Hungary and the Regional format is set to Hungarian, while the Language setting is set to UK English.

The operating system setting on the NMC server is still in English locale. NMC reads the locale using the Locale.getDefault() API and hence, it is not honoring the date and time settings specific to the Hungary region.

Resolution

Update the locale to match the Region's locale (in this case the Region is Hungary).
  1. In the Windows Search bar, search for Date & time format. The Window below opens. Click Language.
Windows Search bar > Date and Time > LanguageFigure 2: Windows Search bar > Date & time > Language 
  1. Click Add a Language.
Click Add a Language.
Figure 3: Click Add a Language.
  1. Select Hungarian and Install.
Install Hungarian (Magyar) Language.
Figure 4: Install Hungarian (Magyar) Language.
  1. Launch the NetWorker Management Console. The timestamps on the NMC Monitoring jobs now shows the Regional date and time format.

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000214607
Article Type: Solution
Last Modified: 14 Sep 2023
Version:  4
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