NetWorker: Unable to set Direct save - No Matching devices as Storage Node is Configured Wrong

Summary: NetWorker Unable to set Direct save - no matching devices for save of client.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Backup fails with the below errors:
Unable to set Direct save with < server name> no matching devices for save of client check storage node ,devices or pools

Cause

  • It Might be due to Wrong Storage Node being Selected in the Action level.
  • It Might be due to Device pointing to wrong Storage Node.

Resolution

Action Plan: 

Kindly Check and confirm if the device selected is pointing to correct Storage node.

If the device selected was pointing to Wrong Storage node. Proceed with below:

  • Correct the Right Storage Node on Action level as its was client cannot over ride behavior.

Note: If the Behavior is client can Over ride, then we can change it in Client properties itself. Find below:

https://www.dell.com/support/kbdoc/en-au/000067041

  • Go to Policy->Workflow->backup->Right click on storage node->edit Storage node->Ok
Client properties page
 
  • Right click on storage node
 
Storage mode drop down menu
 
  • Then select edit Storage node option
 
Edit storage node option
 
  • Select the Appropriate Storage node name and click on Okay 
 

Then Triggered the Backup and it will be Successful.

 

Additional Information

https://www.dell.com/support/kbdoc/en-au/000079448

https://www.dell.com/support/kbdoc/en-au/000067041

Article Properties
Article Number: 000214677
Article Type: Solution
Last Modified: 08 Jun 2023
Version:  1
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