PowerStore: SCSI LUN RESET command did not complete in time resulting in Module PANIC

Summary: An unexpected internal software Module PANIC may be observed if SCSI LUN RESET command does not complete in time.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

An unexpected internal software Module PANIC may be observed if SCSI LUN RESET command does not complete in time (19 seconds).

This condition may occur when SCSI LUN RESET commands are issued by hosts for various environmental reasons.
In addition to the above condition, this symptom tends to occur when the PowerStore is under heavy load such as during performance testing or when migrating data from external storage using the PowerStore Import functionality.
In addition to the above conditions, this symptom tends to occur when several SCSI UNMAP or SCSI RESERVATION requests are sent by the hosts in the same timeframe.

Cause

Due to the current timeout value defined for the SCSI LUN RESET command in the PowerStore, under certain conditions, if SCSI LUN RESET processing is not completed within 19 seconds on a node, it may result in the software module panic.

Resolution

This issue is fixed in PowerStoreOS 3.5.0 by increasing the timeout value for SCSI LUN RESET command from 19 seconds to 1 minute.

Workaround
Reducing intensive, heavy, workloads from the hosts or from the external storage if it is connected, reduces the possibility of this symptom occurring.

For assistance contact technical support

Affected Products

PowerStore
Article Properties
Article Number: 000216320
Article Type: Solution
Last Modified: 14 Jun 2025
Version:  3
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