Dell Unity: Los arreglos que ejecutan el código 5.3.0 con SupportAssist habilitado pueden experimentar estados de alarma del procesador de almacenamiento (SP) después de ~2 meses de tiempo de actividad (corregible por el usuario)
Summary: Los arreglos Unity que ejecutan el código 5.3.0.0.5.120 con SupportAssist habilitado pueden experimentar un estado de alarma del SP después de estar activos durante aproximadamente 2 meses con una configuración de dos SCG o después de aproximadamente 4 meses con una configuración de un solo SCG o conexión directa. ...
Symptoms
5.3.0.0.5.120 SupportAssist está configurado y habilitado para el acceso remoto.
Las configuraciones de conexión directa y de gateway se ven afectadas.
Situación de pánico y reinicio inesperado del SP después de aproximadamente 2 meses de tiempo de ejecución con una configuración
de dos SCG; estado de alarma del SP y reinicio inesperado después de aproximadamente 4 meses de tiempo de ejecución con una configuración de un solo SCG o una conexión directa.
Cause
La alarma solo debe ocurrir en el SP principal que ejecuta el proceso de ESE y, después de la alarma, se liberan los recursos.
Resolution
Este problema se resolvió en el entorno operativo (OE) Unity versión 5.3.1.0.5.008.
Solución:
Hay varias soluciones alternativas disponibles; consulte la sección Información adicional para conocer los pasos detallados de cada solución alternativa.
Additional Information
Opción de solución alternativa #1:
Reiniciar SupportAssist cuando la cantidad de procesos curl zombis sea alta los borrará y evitará que se produzca un estado de alarma del SP. El umbral recomendado para reiniciar SupportAssist es 5000. A continuación, se muestran los comandos para comprobar el número de procesos curl zombie (desaparecidos) y reiniciar SupportAssist.
14:01:20 service@none spb:~/user# ps -ef |grep curl|grep defunct|wc -l
4702 <----------------Cantidad actual de procesos
de curl zombie 14:01:52 service@none spb:~/user# svc_supportassist --restart
Restart in progress........ ¡Completado!
14:03:59 service@none spb:~/user# svc_supportassist --status
State: Tipo de ejecución
: Conectarse a través de un servidor
de gateway Conectividad: Gateway principal accesible
: https://1.2.3.4:9443 Acceso remoto (accesible):
Sí, RSC está habilitado: Sin
versión: 4.7.7.21
Inicializado:
Sí Modo proxy: ninguno
14:04:22 service@none spb:~/user# ps -ef |grep curl|grep defunct|wc -l
0 <----------------- Cantidad de procesos de curl zombie después del reinicio
de SupportAssistOpción de solución alternativa #2:
Se desarrolló un nuevo script de UDoctor (udoctor_update_supportassist) y se está poniendo a disposición de los arreglos Unity conectados en una implementación escalonada. Si se acepta e instala, el nuevo script de Udoctor borrará todos los procesos de curl zombie (extintos) y también evitará la acumulación de nuevos procesos curl zombie (difuntos) en el futuro.
El script de UDoctor se envía automáticamente a los sistemas que tienen Call Home habilitado y que tienen Call Home e indican que tienen 5.3.0 instalado. En el pasado, se daba prioridad a los sistemas que tenían un gran número de procesos zombis, pero esa prioridad se ha eliminado y ahora estamos acelerando el despliegue a todos los sistemas que se conectan a casa indicando 5.3.0. Una vez que el paquete se haya enviado al sistema, verá una alerta similar a la que se muestra:
Los paquetes de UDoctor se utilizan para aplicar actualizaciones específicas, soluciones alternativas y cambios en la configuración al arreglo Unity, independientemente de una actualización completa del entorno operativo de software.
Artículo de la base de conocimientos de referencia Dell Unity: El paquete de UDoctor (xxxxxx) ahora está disponible para la instalación. (Corregible por el usuario) para saber cómo identificar si hay un nuevo paquete de UDoctor disponible y cómo aceptar e instalar uno nuevo.
NOTA 1:
Cuando se realiza una actualización (NDU) de Unity OE, sobrescribirá cualquier cambio realizado por el paquete de UDoctor. Esto significa que cuando la corrección de software está disponible en una nueva versión de Unity OE, se puede realizar una NDU estándar y no se requieren pasos adicionales.
NOTA 2:
No hay manera de reemplazar el proceso de inventario/inserción y forzar que el paquete de UDoctor se envíe a un sistema Unity en particular. El proceso de inventario/inserción se produce semanalmente. Para los clientes que deseen aplicar la corrección antes, la solución correcta es actualizar a la versión 5.3.1.0.5.008 (5.3 SP1) de Unity OE. Como alternativa, los clientes pueden utilizar las otras soluciones alternativas mencionadas anteriormente.