Säkerhetskopieringen av PowerProtect Data Manager VM misslyckas med kod AVB0016 SyncInProgress

Summary: Säkerhetskopieringen av den virtuella PowerProtect Data Manager-datorn (VM) misslyckas med kod AVB0016. "SyncInProgress": "Det går inte att starta fullständig synkronisering på grund av befintlig aktiv ögonblicksbild." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerProtect Data Manager-gränssnittet visar följande meddelanden för felet:

ABV0016: VM Direct engine 'localhost' is unable to back up the virtual machine 'VM1' on vCenter 'vcsa01' because of a vCenter API issue.

The VM Direct engine cannot complete the backup of this virtual machine because a vCenter API operation did not complete successfully.
To troubleshoot this issue:

     *Verify that the vCenter can be reached.
     *If the vCenter is busy, wait for some activities to complete and then retry the operation.
     *Verify that the virtual machine exists on the vCenter.
----
Read Less 
The error cannot be retried. Unable to successfully complete SDM Delta Sync operation. Unsuccessful after 'xx' attempts over 5m0.627607105s The vCenter task for 'SDM Snapshot Sync deltaSync' completed with state 'error': DPD Sync in progress

Fel 1:

PowerProtect Data Manager vmdm.log har följande felmeddelanden:

Result: {
  "sessionId" : "61e7c5f0-bb85-4474-a23f-95c990c917d6",
  "state" : "Failure",
  "logFile" : "/opt/emc/vmdirect/runtime/logs/vpod/BackupJobSessions-61e7c5f0-bb85-4474-a23f-95c990c917d6.log",
  "error" : "The error cannot be retried.  Unable to successfully complete SDM Delta Sync operation.  Unsuccessful after 70 attempts over 5m1.694291645s.  The vCenter task for 'SDM Snapshot Sync deltaSync' completed with state 'error':  DPD Sync in progress (500)",
  "proxyHostName" : "localhost",
  "errorCode" : "ABV0016"

dpd.log (på ESXi) har följande fel:

dpd.log:YYYY-MM-DDTHH:MM:SSZ error dpd[16520988] [Originator@6876 sub=Task opID=1d0ce776-e77a] Task 'Dp.Task.Sync.475.b2616635-352a-4726-986e-e42be7e94bac-1.52f20afe-9cef-83ec-b147-ce7acd07c2ca' failed with error: (dp.fault.SyncInProgress)

Fel 2:

En annan variant av det här felet finns nedan:

PowerProtect Data Manager vmdm.log:

Result: {
  "sessionId" : "126c6bcf-635f-4579-97d7-8dd831a22048",
  "state" : "Failure",
  "logFile" : "/opt/emc/vmdirect/runtime/logs/vpod/BackupJobSessions-126c6bcf-635f-4579-97d7-8dd831a22048.log",
  "error" : "Unable to successfully complete SDM Full Sync operation.  Unsuccessful after 39 attempts over 10m14.630663716s.  The vCenter task for 'SDM Snapshot Sync fullSync' completed with state 'error':  DPD Sync in progress (500)",
  "proxyHostName" : "localhost",
  "errorCode" : "ABV0016"

dpd.log (ESXi-värd)

YYYY-MM-DDTHH:MM:SSZ error dpd[2216236] [Originator@6876 sub=Snapshot opID=055f891e-8923] StartFullSyncIpc: Failed for disk '2d21e5b0-15a9-469e-1bbf-03d75e771c31': error 'Cannot start full sync due to existing active snapshot' 

Cause

Problem med tjänsten VMware Data Protection Daemon (DPD).

Resolution

Lösning 1:

För fel 1 där DPD returnerar ett SyncInProgress-meddelande startar du om DPD-tjänsten på den berörda ESXi-värden enligt nedan:

  1. Leta reda på den berörda virtuella datorn i vSphere-användargränssnittet och leta reda på ESXi-värden där den virtuella datorn finns.
  2. Starta om DPD-tjänsten:

vSphere-användargränssnitt som visar hur man startar om DPD-tjänsten på den berörda ESXi-värden

  1. Du kan få ett felmeddelande när du startar om DPD-tjänsten. Om du gör det startar du om TSDM-tjänsten först och startar sedan om DPD-tjänsten.
  2. Starta om TSDM-tjänsten.
  3. Försök säkerhetskopiera igen.


Lösning

Berörda versioner:
vSphere 7.0.3 (alla), 8.0.0
Korrigering förväntas i en framtida version av vSphere för berörda vSphere-versioner.


Lösning på fel 2:

För fel 2 där DPD returnerar meddelandet "Det går inte att starta fullständig synkronisering på grund av befintlig aktiv ögonblicksbild" är lösningen att återställa LWD. LWD kan återställas enligt nedan:


Metod 1:

  1. Ändra skyddsmekanismen på VM från VAPD och tillbaka till LWD enligt nedan:

Användargränssnitt för PowerProtect Data Manager som visar hur du ändrar skyddsmekanismen till VAPD

  1. Ändra tillbaka skyddsmekanismentill Transparent Snapshots:

Användargränssnitt för PowerProtect Data Manager som visar hur du ändrar skyddsmekanismen till transparenta snapshots

Metod 2:

Ta bort den virtuella datorn från skyddsprincipen och lägg till den igen. OmvVersion av PowerProtect Data Manager är 19.12, använd sedan antingen metod 1 eller metod 3. Metod 2 fungerar inte med PowerProtect Data Manager 19.12.


Metod 3:

Inaktivera och återaktivera LWD med hjälp av vmconfig-verktyget.


Lösning:

Berörda versioner:
7.0.3 (alla) och 8.0.0
Grundorsaken till det här problemet undersöks fortfarande av VMware.

Affected Products

PowerProtect Data Manager
Article Properties
Article Number: 000217246
Article Type: Solution
Last Modified: 16 Feb 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.