Dell NativeEdge: Troubleshooting Certificate Issues During NativeEdge Orchestrator Deployment
Summary: This article intends to help with troubleshooting issues with certificates noted during NativeEdge Orchestrator deployments which report error 0x016030001. 0x016030001 is the event code reported by the NativeEdge Orchestrator installer when communication using docker to the repository fails. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Deployment fails to start due to certificate issue.
Scenarios:
Error response from daemon: Get "https://repository.nativeedge.local/v2/": x509: certificate relies on legacy Common Name field, use SANs instead Login failed. Please check the image registry credentials. Error code: 0x016030001
Error response from daemon: Get "https://repository.nativeedge.local/v2/": Get "https://<ip>/service/token?account=admin&client_id=docker&offline_token=true&service=harbor-registry": tls: failed to verify certificate: x509: certificate signed by unknown authority Login failed. Please check the image registry credentials. Error code: 0x016030001
Error response from daemon: Get "https://repository.nativeedge.local/v2/": Get "https://<ip>/service/tokenaccount=admin&client_id=docker&offline_token=true&service=harbor-registry": tls: failed to verify certificate: x509: cannot validate certificate for <ip> because it doesn't contain any IP SANs Login failed. Please check the image registry credentials. Error code: 0x016030001
Cause
In the above scenarios, the causes were the following:
- The SSL certificate configured on the repository did not have any Subject Alternative Name(SANs) fields setup in the certificate, only legacy Common Name fields.
- When reviewing this error it turned out the repository had a misconfigured IP address during setup, so it was querying the incorrect repository when docker was attempting to upload the NativeEdge installer to the repository.
- The SSL certificate configured on the repository did not have an IP address configured in its SANs x509 extension
Resolution
In the above scenarios, the resolutions were the following:
- Correct the certificate on the repository to include Subject Alternative Name(SANs) information
- Reconfigure the repository correctly so it was using the correct address for communication
- Correct the certificate on the repository to include SANs IP information
Affected Products
NativeEdge Solutions, NativeEdgeArticle Properties
Article Number: 000217449
Article Type: Solution
Last Modified: 22 Jan 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.