Teilkonfiguration der Dell Networking SONiC-Aktualisierung ist nach dem Neustart verloren gegangen

Summary: In diesem Artikel wird der Verlust der Dell SONiC-Konfiguration während des Upgradeprozesses und ein Workaround erläutert.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 

 Wenn ausstehende Konfigurationsänderungen in der Startkonfiguration gespeichert werden sollen, müssen wir darauf achten, wenn wir die Konfiguration speichern, da diese beiden etwas ähnlichen Aktionen unterschiedliche Ergebnisse haben.

Diese Reihenfolge spiegelt alle Änderungen nach dem Neustart korrekt wider.

     Sonic# copy running-configuration startup-configuration
Sonic# image install http://SONiC_EntStd_4.1.1.bin
Sonic# reboot
 

Diese Reihenfolge führt dazu, dass alle nicht gespeicherten Konfigurationsänderungen in der Startkonfiguration nach dem Neustart verloren gehen.

     Installation von Sonic# Image http://SONiC_EntStd_4.1.1.bin
Sonic# copy running-configuration startup-configuration
Sonic# reboot

Wir werden im nächsten Abschnitt besprechen, warum dies geschieht.

Cause

Wenn wir die Image-Installation http://< DELL-SONIC-INSTALL-FILE.bin> durchführen, wird der folgende Vorgang durchgeführt.

- Die startup_config /etc/sonic/config_db.json wird in /host/old_config/config_db.json migriert, um alle erforderlichen Schemaänderungen in der Konfiguration für die neue Version anzuwenden.
Während des Switches starten Sie diese Konfiguration, die in /host/old_config/config_db.json gespeichert ist, neu, nachdem Änderungen in Bezug auf die neue Version an /etc/sonic/config_db.json übertragen wurden.
 

Daher werden alle ausstehenden Änderungen, die nach der Ausführung der Image-Installation http://< DELL-SONIC-INSTALL-FILE.bin> gespeichert wurden, nicht in /host/old_config/config_db.json widergespiegelt. In der Folge geht diese Konfigurationsänderung während des Neustarts verloren. 


 

 

Resolution

Es kann einige Workarounds geben, sobald Sie in diese Situation geraten, zwei der einfachsten wäre:
 

Option 1

 Starten Sie den Switch in der alten SONiC-Version, löschen Sie die neue Version und installieren Sie die neue Version erneut:

Sonic# show image list
Sonic# image set-default <Old-SONIC version>
Sonic# reboot

Wenn der Switch mit der alten Version zurückkommt:

Sonic# show image list
Sonic# image remove <new-SONiC-version>
Sonic# image install <http://new-SONIC version>
Sonic# reboot


HINWEIS: Es wird davon ausgegangen, dass die Konfiguration nach dem Image-Installationsbefehl gespeichert, erfolgreich durchgeführt und vor dem Neustart gespeichert wurde.

Beispielausgabe

admin@sonic:~$ sonic-cli
sonic# show image list
Current: SONiC-OS-4.0.6-Enterprise_Standard
Next: SONiC-OS-4.0.6-Enterprise_Standard
Available: 
SONiC-OS-4.0.3-Enterprise_Base
SONiC-OS-4.0.6-Enterprise_Standard
sonic# image set-default SONiC-OS-4.0.3-Enterprise_Base
sonic# reboot

reboot in process .....
Waiting for the reboot operation to complete
11, 32, 15, 00068001, 19, 00068000, 

Wenn der Switch zurückkommt:

sonic login: admin
Password: 
Last login: Wed Oct  4 10:10:30 UTC 2023 on ttyS0
Linux sonic 4.19.0-9-2-amd64 #1 SMP Debian 4.19.118-2+deb10u1 (2020-06-07) x86_64
You are on
  ____   ___  _   _ _  ____
 / ___| / _ \| \ | (_)/ ___|
 \___ \| | | |  \| | | |
  ___) | |_| | |\  | | |___
 |____/ \___/|_| \_|_|\____|

-- Software for Open Networking in the Cloud --

Unauthorized access and/or use are prohibited.
All access and/or use are subject to monitoring.

Help:    http://azure.github.io/SONiC/

admin@sonic:~$ sonic-cli
sonic# show image list
Current: SONiC-OS-4.0.3-Enterprise_Base
Next: SONiC-OS-4.0.3-Enterprise_Base
Available: 
SONiC-OS-4.0.3-Enterprise_Base
SONiC-OS-4.0.6-Enterprise_Standard
sonic# image remove SONiC-OS-4.0.6-Enterprise_Standard
Remove image SONiC-OS-4.0.6-Enterprise_Standard? [y/N]:y
sonic# show image list
Current: SONiC-OS-4.0.3-Enterprise_Base
Next: SONiC-OS-4.0.3-Enterprise_Base
Available: 
SONiC-OS-4.0.3-Enterprise_Base
sonic# image install http://10.24.30.105/software/Dell%20EMC/Networ
king/SONiC_EntStd_4.0.6.bin
%Info: Check 'show image status' for image install progress.
sonic# show image status
-----------------------------------------------------------
Global operation status  : GLOBAL_STATE_SUCCESS
-----------------------------------------------------------
File operation status    : TRANSFER_STATE_SUCCESS
File size(bytes)         : 1055807512
File transfer bytes      : 1055807512
File progress            : 100%
Transfer start time      : 2023-10-04 10:17:40+0000
Transfer end time        : 2023-10-04 10:17:49+0000
-----------------------------------------------------------
Install operation status : INSTALL_STATE_SUCCESS
Install start time       : 2023-10-04 10:17:49+0000
Install end time         : 2023-10-04 10:18:26+0000
sonic# show image list
Current: SONiC-OS-4.0.3-Enterprise_Base
Next: SONiC-OS-4.0.6-Enterprise_Standard
Available: 
SONiC-OS-4.0.3-Enterprise_Base
SONiC-OS-4.0.6-Enterprise_Standard
sonic# reboot

 

Option 2

Wenden Sie die fehlende Konfiguration im neuen SONiC-Betriebssystem an. 

HINWEIS: Wenn wir versuchen, die config_db.json von der alten Partition in die neue Partition zu kopieren, können andere Probleme auftreten, da sich das Schema der Konfigurationsdatei möglicherweise zwischen den Versionen geändert hat.

Additional Information

Dieses Verhalten wurde sowohl bei 4.0.x-Upgrades in Zweigstellen als auch bei 4.1.x-Upgrades in derselben Zweigstelle validiert. Es wird erwartet, dass für alle Upgrades beibehalten wird.

Affected Products

Enterprise SONiC Distribution, PowerSwitch E3200-ON Series, Dell EMC Networking N3200-ON, PowerSwitch S5212F-ON, PowerSwitch S5224F-ON, PowerSwitch S5232F-ON, PowerSwitch S5248F-ON, PowerSwitch S5296F-ON, PowerSwitch Z9264F-ON, PowerSwitch Z9332F-ON , PowerSwitch Z9432F-ON ...
Article Properties
Article Number: 000218166
Article Type: Solution
Last Modified: 11 Oct 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.