PowerEdge: Trusted Platform Module (TPM) Secure Bootin ja ESXi:n vianmääritys

Summary: Tämä tietämyskannan artikkeli sisältää yksityiskohtaisen oppaan Trusted Platform Module (TPM) 2.0-, Secure Boot- ja ESXi-ongelmien vianmääritykseen Dell-palvelimissa. Se tarjoaa vaiheittaiset ohjeet yleisten ongelmien ratkaisemiseksi ja varmistaa palvelimen moitteettoman toiminnan ja turvallisuuden. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Isännän tila Todistus-sarakkeessa näkyy "Host Secure Boot was disabled"
  • Trusted Platform Module (TPM) 2.0 -laite havaittu, mutta yhteyttä ei voi muodostaa
  • Isännän tila Todistus-sarakkeessa näkyy "N/A"
  • Kun ESXi-isännässä käytetään TPM 2.0 (Trusted Platform Module) -laitetta, isäntä ei läpäise vahvistusvaihetta
  • Virheilmoitus on "Hyväksymisavainta ei voi provisioida TPM 2.0 -laitteessa: Tukiavaimen luonti epäonnistui laitteessa"

Cause

Suojatun käynnistyksen ja TPM-ongelmien syitä ovat pois käytöstä poistettu suojattu käynnistys, väärin määritetty BIOS, laitteistoyhteensopivuus, viallinen TPM 2.0 -moduuli ja TPM-asetukset.

Resolution

TPM:n ja suojatun käynnistyksen ongelmien vianmääritys Dell-palvelimissa

Sisällysluettelo:

Johdanto
Edellytykset
TPM:n ja suojatun käynnistyksen ongelmien
vianmääritysTodistusongelmien
vianmääritysTPM-hierarkian ottaminen käyttöön


Johdanto

Tämä tietämyskannan artikkeli sisältää vaiheittaiset ohjeet TPM (Trusted Platform Module)- ja Secure Boot -turvapiiriin liittyvien yleisten ongelmien vianmääritykseen ja ratkaisemiseen Dell-palvelimissa. Nämä ongelmat voivat haitata oikeanlaista todentamista ja järjestelmän toimintaa. Varmista Dell-palvelimen optimaalinen suorituskyky tämän asiakirjan ohjeiden mukaisesti.


Edellytykset

  • Varmista, että iDRAC havaitsee TPM 2.0 -laitteen ja toimii sen toiminnassa.
  • Varmista, että UEFI, TPM ja Secure Boot ovat käytössä.
  • Käytä TPM 2.0 -algoritmia "SHA256", ota Intel TXT käyttöön 

Tarkat tiedot ja vianmääritysohjeet ongelmaan "TPM 2.0 -laite havaittu, mutta yhteyttä ei voida muodostaa" on artikkelissa 000193231 saatavilla täältä:

PowerEdge: ESXi 7.0 TPM 2.0 -laitteen virhe havaittu, mutta yhteyttä ei voida muodostaa
 


TPM:n ja suojatun käynnistyksen ongelmien vianmääritys

Suojatun käynnistyksen ottaminen käyttöön

  1. Tarkastele ESXi-isännän hälytyksen tilaa ja siihen liittyvää virheilmoitusta.
  2. Muodosta yhteys vCenter Serveriin vSphere Clientilla.
  3. Valitse konesali ja napsauta Näyttö-välilehteä.
  4. Valitse Turvallisuus.
  5. Tarkista isännän tila Todistus-sarakkeessa ja lue siihen liittyvä viesti Viesti-sarakkeesta.
  6. Jos virhesanoma on "Isännän suojattu käynnistys oli poistettu käytöstä", ratkaise ongelma seuraavasti:
    • Tarkista, voiko Secure Bootin ottaa käyttöön. Jos sitä ei voi ottaa käyttöön, ota yhteys Dellin tekniseen tukeen.
    • Voit ottaa suojatun käynnistyksen käyttöön seuraavasti:
      • Siirrä yksi solmu VMware vCenter vSphere Clientissa huoltotilaan.
      • Kirjaudu iDRACiin Secure Bootin määritystä varten ja valitse Määritä-välilehti > BIOS Settings > System Security > TPM Advanced Settings.
      • Valitse Secure Boot "enable" ja napsauta Apply>OK>Apply and Reboot.
      • Valitse Työjono. Odota, että kaikki työt valmistuvat 100-prosenttisesti.
      • Kirjaudu VMware vCenter vSphere Clientiin ja aseta solmu poistumaan huoltotilasta.
    • Suorita vaihe 6 jokaisessa solmussa, kunnes suojattu käynnistys on otettu käyttöön iDRACissa.
    • Kirjaudu VMware vCenter vSphere Clientiin ja valitse konesali.
    • Valitse Näyttö-välilehti > Suojaus ja varmista, että viimeisimmän todistuksen tila on Hyväksytty.
    • Jos näet hälytyksen, jossa on punainen kuvake, valitse se ja napsauta PALAUTA VIHREÄKSI.

TPM:n ja suojatun käynnistyksen ottaminen käyttöön

  1. Tarkastele ESXi-isännän hälytyksen tilaa ja siihen liittyvää virheilmoitusta.
  2. Muodosta yhteys VMware vCenter Serveriin VMware vSphere Clientilla.
  3. Valitse konesali ja napsauta Näyttö-välilehteä.
  4. Valitse Turvallisuus.
  5. Tarkista isännän tila Todistus-sarakkeessa ja lue siihen liittyvä viesti Viesti-sarakkeesta.
  6. Jos virhesanoma on "N/A", sinun on otettava TPM ja Secure Boot käyttöön, jotta ongelma voidaan ratkaista.
    • Tarkista, voiko Secure Bootin ottaa käyttöön. Jos sitä ei voi ottaa käyttöön, ota yhteys Dellin tekniseen tukeen.
    • Ota TPM ja Secure Boot käyttöön seuraavasti:
      • Siirrä yksi solmu VMware vCenter vSphere Clientissa huoltotilaan.
      • Kirjaudu iDRACiin Secure Bootin määrittämistä varten ja valitse Määritä-välilehti > BIOS-asetukset > System Security > TPM Security "On" TPM > Advanced Settings.
      • Valitse Secure Boot "enable" ja napsauta Apply>OK>Apply and Reboot.
      • Valitse Työjono. Odota, että kaikki työt valmistuvat 100-prosenttisesti.
      • Siirry Dashboard > Virtual Consoleen ja tarkista, näkyykö konsolissa "successfully completed". Jos kyllä, jatka.
      • Kirjaudu VMware vCenter vSphere Clientiin ja irrota solmu.
      • Yhdistä solmu uudelleen ja poistu sitten huoltotilasta.
    • Suorita vaiheet 6 kussakin solmussa, kunnes kaikissa solmuissa TPM ja Secure Boot on otettu käyttöön iDRACissa.
    • Kirjaudu VMware vCenter vSphere Clientiin ja siirry konesaliin.
    • Valitse Näyttö-välilehti>Suojaus ja vahvista, että viimeisimmän vahvistusviestin tilaksi on "Hyväksytty".
    • Jos näet hälytyksen, jossa on punainen kuvake, valitse tietty laukaistu hälytys ja napsauta PALAUTA VIHREÄKSI.

Isännän vahvistusongelmat

Kun TPM 2.0 -laitetta käytetään ESXi-isännässä, sen todennus ilman tarkkoja vSphere-asiakastietoja saattaa epäonnistua. Voit tehdä ongelman vianmäärityksen seuraavasti:

  1. Siirry konesaliin ja valitse Näyttö-välilehti .
  2. Valitse Turvallisuus.
  3. Tarkista isännän tila Todistus-sarakkeessa ja lue siihen liittyvä viesti Viesti-sarakkeessa.

Nyt voit tunnistaa ratkaisun kohtaamastasi virheilmoituksesta riippuen:

  • Jos virhesanoma on Host Secure Boot was disabled, korjaa ongelma kohdasta Suojatun käynnistyksen ottaminen käyttöön. Varmista ensin, että suojattu käynnistys toimii.
  • Jos isännän todistuksen tila epäonnistuu, tarkista vCenter Server -lokista seuraava viesti: "Ei välimuistissa olevaa identiteettiavainta, ladataan DB: stä." Tämä ilmoitus ilmaisee, että olet lisäämässä TPM 2.0 -sirua vCenter Serverin jo hallitsemaan ESXi-isäntään. Katkaise ensin isännän yhteys ja liitä se sitten uudelleen.

Hierarkian ottaminen käyttöön

Jos virhesanoma on "Hyväksymisavainta ei voi provisioida TPM 2.0 -laitteessa: Tukiavaimen luonti epäonnistui laitteessa", sinun on otettava TPM-hierarkia käyttöön ongelman ratkaisemiseksi. Ota TPM-hierarkia käyttöön seuraavasti:

  1. Tarkastele ESXi-isännän hälytyksen tilaa ja siihen liittyvää virheilmoitusta.
  2. Muodosta yhteys VMware vCenter Serveriin VMware vSphere Clientilla.
  3. Valitse konesali ja napsauta Näyttö-välilehteä.
  4. Valitse Turvallisuus.
  5. Tarkista isännän tila Todistus-sarakkeessa ja lue siihen liittyvä viesti Viesti-sarakkeessa.
  6. Jos virhesanoma on "Hyväksymisavainta ei voi provisioida TPM 2.0 -laitteessa: Tukiavaimen luonti epäonnistui laitteessa", sinun on otettava TPM-hierarkia käyttöön ongelman ratkaisemiseksi.
  7. Jos näet hälytyksen, jossa on punainen kuvake, valitse tietty laukaistu hälytys ja napsauta PALAUTA VIHREÄKSI.
  8. Ota TPM-hierarkia käyttöön seuraavasti:
    • Siirrä yksi solmu VMware vCenter vSphere Clientissa huoltotilaan.
    • Määritä suojattu käynnistys kirjautumalla iDRACiin ja valitsemalla Määritä-välilehti > BIOS-asetukset > Järjestelmän suojaus > TPM.
    • Valitse TPM-hierarkia Enable ja valitse Apply>OK>, Apply andReboot.
    • Valitse Työjono. Odota, että kaikki työt valmistuvat 100-prosenttisesti.
    • Siirry Dashboard > Virtual Consoleen ja tarkista, näkyykö konsolissa "successfully completed". Jos kyllä, jatka.
    • Kirjaudu VMware vCenter vSphere Clientiin ja valitse Exit Maintenance Mode.
  9. Suorita vaiheet 7 ja 8 kussakin solmussa, kunnes TPM-hierarkia on otettu käyttöön kaikissa solmuissa iDRACissa.
  10. Kirjaudu VMware vCenter vSphere Clientiin ja valitse konesali.
  11. Valitse Näyttö-välilehti>Suojaus ja vahvista, että viimeisimmän vahvistusviestin tilaksi on "Hyväksytty".
Huomautus: VMware QuickBootia ei tueta, kun Secure Boot on käytössä.

Ota meihin yhteyttä, jos vianmääritysvaiheet eivät ratkaisseet ongelmaa. 

Affected Products

OEMR R240, OEMR R250, OEMR XE R250, OEMR R260, OEMR XE R260, OEMR R340, OEMR R350, OEMR XE R350, OEMR R360, OEMR XE R360, OEMR R440, PowerEdge XR2, OEMR R450, OEMR R540, OEMR R550, OEMR R640, OEMR XL R640, OEMR R6415, OEMR R650, OEMR R650xs , OEMR R6515, OEMR R6525, OEMR R660, OEMR XL R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR XL R740, OEMR R740xd, OEMR XL R740xd, OEMR R740xd2, OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR XL R760, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, OEMR T140, OEMR T150, OEMR T340, OEMR T350, OEMR T360, OEMR T440, OEMR T550, OEMR T560, OEMR T640, OEMR XL T640, OEMR XL R240, OEMR XL R340, OEMR XL R660xs, OEMR XL R6615, OEMR XL R6625, OEMR XL R6715, OEMR XL R6725, OEMR XL R760xs, OEMR XL R7615, OEMR XL R7625, OEMR XL R7715, OEMR XL R7725, OEMR XR11, OEMR XR12, OEMR XR4510c, OEMR XR4520c, OEMR XR5610, OEMR XR7620, OEMR XR8610t, OEMR XR8620t, Poweredge C4140, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640, PowerEdge HS5610, PowerEdge HS5620, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R470, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R7715, PowerEdge R7725, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T40, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640, PowerEdge XE2420, PowerEdge XE7420, PowerEdge XE7440, PowerEdge XE8545, PowerEdge XE8640, PowerEdge XE9640, PowerEdge XE9680, PowerEdge XR11, PowerEdge XR12, PowerEdge XR4510c, PowerEdge XR4520c, PowerEdge XR5610, PowerEdge XR7620, PowerEdge XR8610t, PowerEdge XR8620t, PowerFlex appliance R650, PowerFlex appliance R6525, PowerFlex appliance R660, PowerFlex appliance R6625, Powerflex appliance R750, PowerFlex appliance R760, PowerFlex appliance R7625, PowerFlex custom node R650, PowerFlex custom node R6525, PowerFlex custom node R660, PowerFlex custom node R6625, PowerFlex custom node R750, PowerFlex custom node R760, PowerFlex custom node R7625, PowerFlex custom node R860, VxFlex Ready Node, VxFlex Ready Node R640, VxFlex Ready Node R740xd, VMware ESXi 7.x, VMware ESXi 8.x, Dell EMC vSAN C6420 Ready Node, Dell EMC vSAN MX740c Ready Node, Dell EMC vSAN MX750c Ready Node, Dell vSAN Ready Node MX760c, Dell EMC vSAN R440 Ready Node, Dell EMC vSAN R640 Ready Node, Dell EMC vSAN R6415 Ready Node, Dell EMC vSAN R650 Ready Node, Dell EMC vSAN R6515 Ready Node, vSAN Ready Node R660, Dell vSAN R6615 Ready Node, Dell EMC vSAN R740 Ready Node, Dell EMC vSAN R740xd Ready Node, Dell EMC vSAN R750 Ready Node, Dell EMC vSAN R7515 Ready Node, Dell EMC vSAN R760 Ready Node, Dell vSAN R7615 Ready Node, Dell vSAN Ready Node R7625, Dell EMC vSAN R840 Ready Node, Dell EMC vSAN T350 Ready Node, PowerFlex appliance R640, PowerFlex appliance R740XD, PowerFlex appliance R7525, PowerFlex appliance R840, VxFlex Ready Node R840 ...
Article Properties
Article Number: 000218542
Article Type: Solution
Last Modified: 12 Feb 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.