PowerEdge: Fejlfinding af Trusted Platform Module (TPM) Secure Boot og ESXi

Summary: Denne Knowledge Base-artikel indeholder en detaljeret vejledning til fejlfinding af Trusted Platform Module (TPM) 2.0, sikker start og ESXi-relaterede problemer på Dell-servere. Den indeholder trinvise instruktioner til at løse almindelige problemer, så din server kan fungere korrekt og sikre. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Værtsstatussen i kolonnen Attestation viser "Host Secure Boot was disabled"
  • Trusted Platform Module (TPM) 2.0-enhed registreret, men der kan ikke oprettes forbindelse
  • Værtsstatussen i kolonnen Attestation viser "Ikke relevant"
  • Når du bruger en TPM 2.0-enhed (Trusted Platform Module) på en ESXi-vært, består værten ikke attestationsfasen
  • Fejlmeddelelsen er "Kan ikke klargøre godkendelsesnøglen på TPM 2.0-enhed: Oprettelse af godkendelsesnøgle mislykkedes på enheden"

Cause

Årsager til Secure Boot- og TPM-problemer omfatter deaktiveret Secure Boot, forkert konfigureret BIOS, hardwarekompatibilitet, defekt TPM 2.0-modul og TPM-indstillinger.

Resolution

Fejlfinding af TPM- og Secure Boot-problemer på Dell-servere

Indholdsfortegnelse:

Indførelsen
Forudsætninger
Fejlfinding af problemer med TPM og sikker
startFejlfinding af problemer med
attesteringAktivering af TPM-hierarki


Indledning

Denne Knowledge Base-artikel indeholder trinvise instruktioner til fejlfinding og løsning af almindelige problemer i forbindelse med TPM (Trusted Platform Module) og Secure Boot på Dell-servere. Disse problemer kan hindre korrekt attestering og systemfunktionalitet. Følg instruktionerne i dette dokument for at sikre optimal ydeevne for din Dell-server.


Forudsætninger

  • Sørg for, at TPM 2.0-enheden registreres og er korrekt fra iDRAC.
  • Sørg for, at UEFI, TPM og Secure Boot er aktiveret.
  • Brug TPM 2.0-algoritmen "SHA256", aktiver Intel TXT 

Du kan finde detaljerede oplysninger og fejlfindingsvejledning vedrørende problemet med "TPM 2.0-enhed registreret, men der kan ikke oprettes forbindelse" i artiklen 000193231 tilgængelig her:

PowerEdge: Fejl på ESXi 7.0 TPM 2.0-enhed registreret, men der kan ikke oprettes forbindelse
 


Fejlfinding af problemer med TPM og sikker start

Sådan aktiveres sikker opstart

  1. Se status for ESXi-værtsalarmen og den tilhørende fejlmeddelelse.
  2. Opret forbindelse til vCenter Server ved hjælp af vSphere Client.
  3. Vælg et datacenter, og klik på fanen Skærm.
  4. Klik på Sikkerhed.
  5. Gennemse værtsstatus i kolonnen Attestation, og læs den medfølgende meddelelse i kolonnen Meddelelse.
  6. Hvis fejlmeddelelsen er "Vært for sikker opstart blev deaktiveret", skal du følge disse trin for at løse problemet:
    • Kontroller, om Sikker start kan aktiveres. Hvis den ikke kan aktiveres, skal du kontakte Dells tekniske support.
    • Følg disse trin for at aktivere sikker bootstart:
      • Fra VMware vCenter vSphere Client skal du flytte en node til Skift til vedligeholdelsestilstand.
      • Log på iDRAC for at konfigurere Secure Boot, og vælg fanen Konfigurer BIOS-indstillinger >> , Systemsikkerhed > , TPM, avancerede indstillinger.
      • Vælg Secure Boot "aktiver", og klik på Anvend>OK>, anvend og genstart.
      • Klik på Jobkø. Vent på, at alle job er fuldført 100 %.
      • Log på VMware vCenter vSphere Client, og indstil noden til Afslut vedligeholdelsestilstand.
    • Udfør trin 6 på hver node, indtil Secure Boot er aktiveret fra iDRAC til alle noder.
    • Log på VMware vCenter vSphere Client, og vælg datacenteret.
    • Klik på fanen>Sikkerhed for skærm for at kontrollere, at den seneste attesteringsstatus viser "Bestået".
    • Hvis du ser en alarm med et rødt ikon, skal du vælge den og klikke på NULSTIL TIL GRØN.

Sådan aktiverer du TPM og Secure Boot

  1. Se status for ESXi-værtsalarmen og den tilhørende fejlmeddelelse.
  2. Opret forbindelse til VMware vCenter Server ved hjælp af VMware vSphere Client.
  3. Vælg et datacenter, og klik på fanen Skærm .
  4. Klik på Sikkerhed.
  5. Gennemse værtsstatus i kolonnen Attestation, og læs den medfølgende meddelelse i kolonnen Meddelelse.
  6. Hvis fejlmeddelelsen er "Ikke relevant", skal du aktivere TPM og Secure Boot for at løse problemet.
    • Kontroller, om Sikker start kan aktiveres. Hvis den ikke kan aktiveres, skal du kontakte Dells tekniske support.
    • Følg disse trin for at aktivere TPM og Sikker start:
      • Fra VMware vCenter vSphere Client skal du flytte en node til Skift til vedligeholdelsestilstand.
      • Log på iDRAC for at konfigurere Secure Boot, og vælg fanen Konfigurer BIOS-indstillinger >> Systemsikkerhed > TPM Security "Til" > TPM Avancerede indstillinger.
      • Vælg Secure Boot "aktiver", og klik på Anvend>OK>, anvend og genstart.
      • Klik på Jobkø. Vent på, at alle job er fuldført 100 %.
      • Gå til Dashboard > Virtual Console for at se, om konsollen viser "fuldført". Hvis ja, fortsæt.
      • Log på VMware vCenter vSphere Client, og frakobl noden.
      • Tilslut noden igen, og afslut derefter vedligeholdelsestilstand.
    • Udfør trin 6 på hver node, indtil alle noder har TPM og Secure Boot aktiveret fra iDRAC.
    • Log på VMware vCenter vSphere Client, og gå til datacenteret.
    • Klik på fanen>Sikkerhed for skærm for at kontrollere den seneste attestationsmeddelelse som "Bestået".
    • Hvis du ser en alarm med et rødt ikon, skal du vælge den specifikke udløste alarm og klikke på NULSTIL TIL GRØN.

Problemer med værtsattestering

Når du bruger en TPM 2.0-enhed på en ESXi-vært, mislykkes attesteringen muligvis uden detaljerede vSphere-klientoplysninger. Følg disse trin for at fejlfinde dette problem:

  1. Gå til et datacenter, og klik på fanen Skærm .
  2. Klik på Sikkerhed.
  3. Gennemse værtens status i kolonnen Attestering, og læs den ledsagende meddelelse i kolonnen Meddelelse.

Afhængigt af den fejlmeddelelse, du støder på, kan du nu identificere en løsning:

  • Hvis fejlmeddelelsen er, at Vært for sikker opstart blev deaktiveret, skal du se afsnittet Sådan aktiveres sikker start for at løse dette problem. Sørg for, at Secure Boot fungerer først.
  • Hvis værtens attesteringsstatus mislykkes, skal du kontrollere vCenter Server-loggen for følgende meddelelse: "Ingen cachelagret identitetsnøgle, indlæsning fra DB." Denne meddelelse angiver, at du føjer en TPM 2.0-chip til en ESXi-vært, som vCenter Server allerede administrerer. Du skal først afbryde forbindelsen til værten og derefter tilslutte den igen.

Sådan aktiveres hierarki

Hvis fejlmeddelelsen er "Kan ikke klargøre godkendelsesnøglen på TPM 2.0-enheden: Oprettelse af godkendelsesnøgle mislykkedes på enheden", skal du aktivere TPM-hierarki for at løse problemet. Følg disse trin for at aktivere TPM-hierarki:

  1. Se status for ESXi-værtsalarmen og den tilhørende fejlmeddelelse.
  2. Opret forbindelse til VMware vCenter Server ved hjælp af VMware vSphere Client.
  3. Vælg et datacenter, og klik på fanen Skærm.
  4. Klik på Sikkerhed.
  5. Gennemse værtens status i kolonnen Attestering, og læs den ledsagende meddelelse i kolonnen Meddelelse.
  6. Hvis fejlmeddelelsen er "Kan ikke klargøre godkendelsesnøglen på TPM 2.0-enheden: Oprettelse af godkendelsesnøgle mislykkedes på enheden", skal du aktivere TPM-hierarki for at løse problemet.
  7. Hvis du ser en alarm med et rødt ikon, skal du vælge den specifikke udløste alarm og klikke på NULSTIL TIL GRØN.
  8. Følg disse trin for at aktivere TPM-hierarki:
    • Fra VMware vCenter vSphere Client skal du flytte en node til Skift til vedligeholdelsestilstand.
    • Log på iDRAC for at konfigurere Secure Boot, og vælg fanen Konfigurer BIOS-indstillinger >> Systemsikkerhed > TPM.
    • Vælg TPM-hierarki "Enable", og klik på Anvend>OK>, anvend og genstart.
    • Klik på Jobkø. Vent på, at alle job er fuldført 100 %.
    • Gå til Dashboard > Virtual Console for at se, om konsollen viser "fuldført". Hvis ja, fortsæt.
    • Log på VMware vCenter vSphere Client, og vælg Afslut vedligeholdelsestilstand.
  9. Udfør trin 7 og 8 på hver node, indtil TPM-hierarkiet er aktiveret fra iDRAC for alle noder.
  10. Log på VMware vCenter vSphere Client, og vælg et datacenter.
  11. Klik på fanen>Sikkerhed for skærm for at kontrollere den seneste attestationsmeddelelse som "Bestået".
Bemærk: VMware QuickBoot understøttes ikke, når Sikker start er aktiveret.

Kontakt os , hvis fejlfindingstrinnene ikke løste problemet. 

Affected Products

OEMR R240, OEMR R250, OEMR XE R250, OEMR R260, OEMR XE R260, OEMR R340, OEMR R350, OEMR XE R350, OEMR R360, OEMR XE R360, OEMR R440, PowerEdge XR2, OEMR R450, OEMR R540, OEMR R550, OEMR R640, OEMR XL R640, OEMR R6415, OEMR R650, OEMR R650xs , OEMR R6515, OEMR R6525, OEMR R660, OEMR XL R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR XL R740, OEMR R740xd, OEMR XL R740xd, OEMR R740xd2, OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR XL R760, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, OEMR T140, OEMR T150, OEMR T340, OEMR T350, OEMR T360, OEMR T440, OEMR T550, OEMR T560, OEMR T640, OEMR XL T640, OEMR XL R240, OEMR XL R340, OEMR XL R660xs, OEMR XL R6615, OEMR XL R6625, OEMR XL R6715, OEMR XL R6725, OEMR XL R760xs, OEMR XL R7615, OEMR XL R7625, OEMR XL R7715, OEMR XL R7725, OEMR XR11, OEMR XR12, OEMR XR4510c, OEMR XR4520c, OEMR XR5610, OEMR XR7620, OEMR XR8610t, OEMR XR8620t, Poweredge C4140, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640, PowerEdge HS5610, PowerEdge HS5620, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R470, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R7715, PowerEdge R7725, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T40, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640, PowerEdge XE2420, PowerEdge XE7420, PowerEdge XE7440, PowerEdge XE8545, PowerEdge XE8640, PowerEdge XE9640, PowerEdge XE9680, PowerEdge XR11, PowerEdge XR12, PowerEdge XR4510c, PowerEdge XR4520c, PowerEdge XR5610, PowerEdge XR7620, PowerEdge XR8610t, PowerEdge XR8620t, PowerFlex appliance R650, PowerFlex appliance R6525, PowerFlex appliance R660, PowerFlex appliance R6625, Powerflex appliance R750, PowerFlex appliance R760, PowerFlex appliance R7625, PowerFlex custom node R650, PowerFlex custom node R6525, PowerFlex custom node R660, PowerFlex custom node R6625, PowerFlex custom node R750, PowerFlex custom node R760, PowerFlex custom node R7625, PowerFlex custom node R860, VxFlex Ready Node, VxFlex Ready Node R640, VxFlex Ready Node R740xd, VMware ESXi 7.x, VMware ESXi 8.x, Dell EMC vSAN C6420 Ready Node, Dell EMC vSAN MX740c Ready Node, Dell EMC vSAN MX750c Ready Node, Dell vSAN Ready Node MX760c, Dell EMC vSAN R440 Ready Node, Dell EMC vSAN R640 Ready Node, Dell EMC vSAN R6415 Ready Node, Dell EMC vSAN R650 Ready Node, Dell EMC vSAN R6515 Ready Node, vSAN Ready Node R660, Dell vSAN R6615 Ready Node, Dell EMC vSAN R740 Ready Node, Dell EMC vSAN R740xd Ready Node, Dell EMC vSAN R750 Ready Node, Dell EMC vSAN R7515 Ready Node, Dell EMC vSAN R760 Ready Node, Dell vSAN R7615 Ready Node, Dell vSAN Ready Node R7625, Dell EMC vSAN R840 Ready Node, Dell EMC vSAN T350 Ready Node, PowerFlex appliance R640, PowerFlex appliance R740XD, PowerFlex appliance R7525, PowerFlex appliance R840, VxFlex Ready Node R840 ...
Article Properties
Article Number: 000218542
Article Type: Solution
Last Modified: 12 Feb 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.