Dell VxRail: VxRail upgrade mislukt met "Bad script return code: 1"
Summary: Tijdens een VxRail upgrade voor 4.7.X, 7.0.X of 8.0.X, is er de volgende foutmelding "Bad script return code: 1".
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Tijdens een VxRail upgrade voor 4.7.X, 7.0.X of 8.0.X, is er de volgende foutmelding "Bad script return code: 1".
lcm-web.log:
Wanneer u de vCenter VAMI controleert, geeft de VMware vSphere Profile-Driven Storage Servicede status 'Healthy with errors' (of waarschuwingen) weer en wordt de status 'Started' (Gestart) weergegeven.
Als u de VAMI wilt controleren, meldt u zich aan als root bij de vCenter VAMI vanuit een webbrowser met behulp van https://vCenter FQDN of IP-adres:5480.
Klik op Services.
lcm-web.log:
INFO : Starting adding new disk sdc
INFO : Checkiing whether sdc exists ...
INFO : No sdc disk on VXM, need to perform add.
INFO : Handling VM <VxM Name Here>
INFO : Get VM Storage Profile name VXRAIL-SYSTEM-STORAGE-PROFILE, id <Long string of characters>.
INFO : Vm profileId is <Long string of characters>.
ERROR : Failed to add a new disk: (vodl.fault.SystemError)
{
dynamicType = <unset>
dynamicProperty = (vmodl.DynamicProperty) []
Msg = 'A general system error occurred: PBM error occurred during Pre-ReconfigureCallback: Fault cause: vmodl.fault.SystemError\n;\n'
faultCause = <unset>
faultMessage = (vmodl.LocalizableMessage) []
Reason = 'PBM error occurred during Pre-ReconfigurCallback: Fault cause: vmodl.fault.SystemError\n;\n'
}
Als u de VAMI wilt controleren, meldt u zich aan als root bij de vCenter VAMI vanuit een webbrowser met behulp van https://vCenter FQDN of IP-adres:5480.
Klik op Services.
Cause
De VMware vSphere Profile-Driven Storage Service is niet correct gestart. Dit veroorzaakt problemen bij het weergeven van storageprofielen in de vSphere Client.
Resolution
Om dit probleem op te lossen, volgt u de onderstaande stappen om vCenter (en PSC voor 6.7 en lager) opnieuw op te starten:
Als de vCenter versie 6.7.X of lager is:
Als de vCenter versie 7.0 of nieuwer is:
Als de vCenter versie 6.7.X of lager is:
- Klik in de vSphere-client op de vCenter VM.
- Zoek op welke host de vCenter VM wordt uitgevoerd.
- Klik vervolgens op de PSC VM.
- Migreer de PSC VM naar dezelfde ESXi-host als de vCenter VM.
- Meld u aan als root bij de ESXi-host vanuit een webbrowser met behulp van https en het ESXi FQDN- of beheer-IP-adres.
- Klik met de linkermunknop op Virtuele machines.
- Klik met de linkermuist op het vak voor de vCenter VM.
- Klik met de linkermunknop op Acties.
- Beweeg de muisaanwijzer over het gastbesturingssysteem.
- Klik met de linkermunknop op Afsluiten.
- Klik met de linkermunknop op Virtuele machines.
- Klik met de linkermuistknop op het vak voor de vCenter VM om deze te wissen.
- Klik met de linkermuist op het vak voor de PSC VM.
- Klik met de linkermunknop op Acties.
- Beweeg de muisaanwijzer over het gastbesturingssysteem.
- Klik met de linkermunknop op Opnieuw opstarten.
- Wacht ongeveer 3-5 minuten.
- Klik met de linkermuistknop op het vak voor de PSC VM om deze te wissen.
- Klik met de linkermuist op het vak voor de vCenter VM.
- Klik met de linkermunknop op Acties.
- Beweeg de muisaanwijzer over het gastbesturingssysteem.
- Klik met de linkermunknop op Opnieuw opstarten.
Als de vCenter versie 7.0 of nieuwer is:
- Klik in vSphere op de vCenter VM.
- Zoek op welke host de vCenter VM wordt uitgevoerd.
- Meld u aan als root bij de ESXi-host vanuit een webbrowser met behulp van https en het ESXi FQDN- of beheer-IP-adres.
- Klik met de linkermunknop op Virtuele machines.
- Klik met de linkermuist op het vak voor de vCenter VM.
- Klik met de linkermunknop op Acties.
- Beweeg de muisaanwijzer over het gastbesturingssysteem.
- Klik met de linkermunknop op Opnieuw opstarten.
Article Properties
Article Number: 000218572
Article Type: Solution
Last Modified: 24 Oct 2023
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.