Dell VxRail: O upgrade do VxRail falha com "Bad script return code: 1"

Summary: Durante um upgrade do VxRail para 4.7.X, 7.0.X ou 8.0.X, há o seguinte erro "Bad script return code: 1".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Durante um upgrade do VxRail para 4.7.X, 7.0.X ou 8.0.X, há o seguinte erro "Bad script return code: 1".

lcm-web.log:
INFO : Starting adding new disk sdc
INFO : Checkiing whether sdc exists ...
INFO : No sdc disk on VXM, need to perform add.
INFO : Handling VM <VxM Name Here>
INFO : Get VM Storage Profile name VXRAIL-SYSTEM-STORAGE-PROFILE, id <Long string of characters>.
INFO : Vm profileId is <Long string of characters>.
ERROR : Failed to add a new disk: (vodl.fault.SystemError)
{
dynamicType = <unset>
dynamicProperty = (vmodl.DynamicProperty) []
Msg = 'A general system error occurred: PBM error occurred during Pre-ReconfigureCallback: Fault cause: vmodl.fault.SystemError\n;\n'
faultCause = <unset>
faultMessage = (vmodl.LocalizableMessage) []
Reason = 'PBM error occurred during Pre-ReconfigurCallback: Fault cause: vmodl.fault.SystemError\n;\n'
}

 
Ao verificar o VAMI do vCenter, o serviço de armazenamento orientado por perfil do VMware vSphere mostra a integridade como "Healthy with errors" (ou warnings) e State como "Started".
Para verificar o VAMI, faça log-in como root no VAMI do vCenter a partir de um navegador da Web usando https://vCenter FQDN ou endereço IP:5480.
Clique em Serviços.
image.png

Cause

O serviço de armazenamento orientado por perfil do VMware vSphere não foi iniciado corretamente.  Isso está causando problemas de visualização de perfis de armazenamento no vSphere Client.

Resolution

Para resolver esse problema, siga as etapas abaixo para reiniciar o vCenter (e o PSC para a versão 6.7 e abaixo):

se a versão do vCenter for 6.7.X ou inferior:
  1. No vSphere Client, clique na VM do vCenter.
  2. Localize em qual host a VM do vCenter está sendo executada.
  3. Em seguida, clique na VM do PSC.
  4. Migre a VM do PSC para o mesmo host ESXi que a VM do vCenter.
  5. Faça log-in como root no host do ESXi a partir de um navegador da Web usando https e o FQDN ou endereço IP de gerenciamento do ESXi.
  6. Clique com o botão esquerdo do mouse em Máquinas virtuais.
  7. Clique com o botão esquerdo na caixa da VM do vCenter.
  8. Clique com o botão esquerdo do mouse em Ações.
  9. Passe o mouse sobre o sistema operacional convidado.
  10. Clique com o botão esquerdo do mouse em Desligar.
  11. Clique com o botão esquerdo do mouse em Máquinas virtuais.
  12. Clique com o botão esquerdo na caixa para limpar a VM do vCenter.
  13. Clique com o botão esquerdo na caixa da VM do PSC.
  14. Clique com o botão esquerdo do mouse em Ações.
  15. Passe o mouse sobre o sistema operacional convidado.
  16. Clique com o botão esquerdo do mouse em Reiniciar.
  17. Aguarde cerca de 3 a 5 minutos.
  18. Clique com o botão esquerdo na caixa para limpar a VM do PSC.
  19. Clique com o botão esquerdo na caixa da VM do vCenter.
  20. Clique com o botão esquerdo do mouse em Ações.
  21. Passe o mouse sobre o sistema operacional convidado.
  22. Clique com o botão esquerdo do mouse em Reiniciar.

Se a versão do vCenter for 7.0 ou mais recente:
  1. No vSphere, clique na VM do vCenter.
  2. Localize em qual host a VM do vCenter está sendo executada.
  3. Faça log-in como root no host do ESXi a partir de um navegador da Web usando https e o FQDN ou endereço IP de gerenciamento do ESXi.
  4. Clique com o botão esquerdo do mouse em Máquinas virtuais.
  5. Clique com o botão esquerdo na caixa da VM do vCenter.
  6. Clique com o botão esquerdo do mouse em Ações.
  7. Passe o mouse sobre o sistema operacional convidado.
  8. Clique com o botão esquerdo do mouse em Reiniciar.
Article Properties
Article Number: 000218572
Article Type: Solution
Last Modified: 24 Oct 2023
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.