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OpenManage Enterprise: 4.0 Migration Fails With 'Failed To Decrypt Backup Archive'

Summary: In some migration scenarios, the OpenManage Enterprise 4.0 target import operation may fail with an error 'Failed to decrypt backup archive' during migration. Use the following article to help in troubleshooting this scenario and various ways to address the failure. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Shortly after the 'migrate in' is started from the target, the import appears to stop abruptly, and the login screen is displayed.
 
After logging back into the web user interface, the following yellow banner is shown: 
Last Import job failed. Click on view logs for details.
Last import job failure banner
 
Clicking the View Logs link brings up the import-job details, and the following error is seen:
Unable to decrypt the backup file. Please check the provided encryption passphrase.
Failed to perform import task. 
Import task failure details showing decryption error

Cause

Several scenarios exist where the migration import operation may fail with the decryption error. They are as follows:
  • Scenario 1: Hash comparison failure between exported files
  • Scenario 2: An incorrect passphrase used during the 'migrate-in' operation

Resolution

To better understand what could be causing the decryption error, first download a console log bundle from the OpenManage Enterprise version 4.0 (target) web interface.

  1. Browse to Monitor -> Troubleshoot -> Logs.
  2. Click the 'Generate Log' button and wait for the log collection job to complete.
  3. After the log bundle is available, click the 'Download Log,' and save the compressed file to a local location.
  4. Extract the console log bundle.
  5. Once the extraction is completed, browse to the.\backuprestoreservice folder, and open the ome_encryption_decryption.log file.

Scenario 1: Hash comparison failure:

With the ome_encryption_decryption log file open, the following error is shown if the backup file checksums between the source and target appliances do not match.

2024.01.05-21:20:09 ome_backup_encryption - error: Hash comparison failed 

If this error is seen in the logs, update the target appliance to version 4.0.1 and retry the migration.

 

Scenario 2: An incorrect passphrase is used during the 'migrate-in' operation:

With the ome_encryption_decryption log file open, the following error is shown if an incorrect passphrase is being entered on the target appliance.

2024.01.25-15:44:02 ome_backup_encryption - Decryption command result -> 2 

This passphrase is used during the encryption of the source backup file. The same passphrase must be used on the target appliance for the decryption of the backup file. 

  1. From the source appliance, browse to Backup-Restore -> Migrate - Migrate Out, and expand Step 4.
  2. Click the 'Abort Migration' link to cancel the migration and return the source appliance into the READY state.
  3. Restart the migration operation from Step 3, and ensure the passphrase used on the source appliance is the same passphrase entered on the target appliance for the 'Migrate In' operation.  

A successful decryption of the source file during the migration on the target appliance shows a result code 0:

2024.01.05-21:20:09 ome_backup_encryption - Decryption command result -> 0

Affected Products

Dell EMC OpenManage Enterprise

Products

C Series, Modular Infrastructure, Rack Servers, Tower Servers, XE Servers, XR Servers, OEM Server Solutions
Article Properties
Article Number: 000221490
Article Type: Solution
Last Modified: 06 May 2025
Version:  3
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