NetWorker:メディア データベースのメンテナンスとトラブルシューティング
Summary: この記事では、メディア データベースに関連する問題を特定して処理する方法と、メンテナンスと保護のベスト プラクティスについて説明します。
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Symptoms
- サービス開始の失敗。
- 毎日の Server Protection>Serverバックアップ ワークフローの失敗。
- mminfoコマンドによって返されるセーブセットまたはクライアントに関連する情報が不完全であるか誤解を招く情報、またはNMC(NetWorker管理コンソール)またはNWUI(NetWorker Webユーザー インターフェイス)管理でセーブセットをクエリーまたは参照する場合。
- セーブセット、クライアント、またはボリュームを特定できないことに関連したバックアップ、リカバリー、またはクローン作成の問題。
- メディア データベースに関連するサーバー デーモン ログまたはコンソールのエラー:
nsrmmdbd WiSS code assertion error (st_nextrec: rec loop detected)
nsrmmdbd error, ss_clone_ensure_clone_eligibility: assertion, invalid parameters or code segment
nsrmmdbd XCHK ssid:saveset_short_ssid host:saveset_hostname name:saveset_name has a fragment with an invalid volid:saveset_volid
nsrmmdbd NSR warning WiSS code assertion error (ST_readvdir: directory read failed)
nsrmmdbd NSR critical Unexpected error reading long record directory: an invalid slot number
nsrmmdbd NSR warning partial record error, ssid: saveset_short_ssid saveset_long_ssid flags:0x00010101 size:0 files:0 tm:datetime cloneid
nsrmmdbd NSR notice media db must be scavenged
nsrmmdbd NSR critical media db scavenge failed
nsrmmdbd NSR warning Cannot scavenge path_to_mmvolume6 (Permission denied) - recover from backup media
nsrmmdbd NSR warning Cannot scavenge path_to_mmvolume6 (unknown error code) - recover from backup media
nsrmmdbd MDB warning can't fetch save set <saveset ID>
nsrmmdbd MDB warning Unable to fetch child save set <saveset ID> for cover set <saveset ID>
- メディア データベースから多数のセーブ セットが突然失われた、または使用可能なディスク ストレージの空き領域が突然急増した。
- ソフトウェアがセーブセットを期限切れにしたり削除したりできず、ストレージが急速に消費される。
Cause
他のデータベースと同様に、メディア データベースは、次のような通常のオペレーションに何らかの推論がある場合、程度の差こそあれ損傷を受ける可能性があります。
- nsrmmdbdプロセスの予期しないシャットダウン(コア ダンプ、システム クラッシュ、再起動、電源喪失)。
- トランザクションの中断(外部セキュリティ ソフトウェアの干渉またはディスク領域の枯渇)。
- 論理内部の問題(コードのバグまたは未処理の状態)。
- NetWorkerが管理するストレージ上のメディア データベース ファイルまたはセーブセット ファイルとの直接干渉。
- 可能であれば、nsr/mmフォルダー用に個別のローカル ディスク パーティションを使用します。これにより、他のプロセスによるディスク領域の枯渇などの状況から保護できます。このパーティションは、メディア データベースのサイズの少なくとも3倍にする必要があります。現在、大規模なメディア データベースは 10 GB です。したがって、どのようなインストールでも100 GBで十分です。
- 災害発生時にメディア データベースと重要なディザスター リカバリー リソース( ブートストラップ)のバックアップを使用できるように、サーバー バックアップ ワークフローが毎日完了していることを確認します。
- mminfo -B コマンドを使用して、ブートストラップの場所を定期的に確認します。
- データ ロスにつながる可能性があるため、別のNetWorkerサーバーがNetWorkerサーバーのストレージ ボリュームに同時にアクセスしないようにします。
- ウイルス対策ソフトウェアがNetWorkerサーバーにインストールされている場合は、/nsrディレクトリに除外を作成して、ウイルス対策ソフトウェアがNetWorkerファイルをスキャン、変更、または削除できないようにします。
- 領域を解放するために、NetWorkerストレージ内のファイルを手動で削除しないようにします。NetWorkerには、毎日実行されるスペース再利用ルーチンがあり、これらが失敗していると考えられる場合は、サポートに連絡する必要があります。
- 一般に、データゾーンのプランニングでは、必要に応じてメンテナンスを容易にするために、同じタイプのデータを同じプールに保持します(vProxyセーブ セット、ファイル システム セーブ セット、Oracleデータベース セーブ セットなど)。
- メディア データベース エラーに関連するメッセージを無視しないでください。懸念がある場合は、サポートにお問い合わせください。
- NetWorkerは、サーバ バックアップ ワークフローの一環として、有効期限プロセスを毎日実行します。このジョブは保存期間と依存関係を計算し、保存期間を過ぎていて期限が切れていない依存物がないセーブセットを期限切れにします。これが完了すると、NetWorkerは期限切れのディスクボリューム セーブセットをすべて削除しようとします。その後、各ボリュームに対してスペース再利用操作が実行され、対応するメディア データベース エントリーがないディスク メディアからセーブセット ファイルが削除されます。つまり、メディア データベースが破損した場合、またはデータベースを以前のポイント イン タイムにリカバリーした場合、有効なデータが削除される可能性があります。
- ディスク ボリュームに問題があると思われる場合は、有効なデータが削除されないように、ボリュームがアンマウントされ、スキャンが必要とマークされていることを確認します。これは、以前のポイント イン タイムにリカバリーした後のボリュームにも適用されます(リカバリー ポイントの後に作成されたディスクに有効なセーブ セットが存在し、リカバリーされたデータベースにエントリーがない場合があります)。
- [Scan Needed]では、通常のバックアップ、リカバリー、クローン作成は可能ですが、通常の有効期限や削除はできません。そのため、危険であると認識されたボリュームを保護するためにのみ使用し、通常の操作に戻ったときに削除するようにしてください。このフラグを設定または削除するには、ボリュームをアンマウントする必要があります。通常、NetWorkerサーバー ディザスター リカバリー(nsrdr)後に、ディザスター リカバリー シナリオでの不要なデータ ロスを防ぐために、ボリュームに「スキャンが必要」とマークされます。
Resolution
メディア データベースの問題を確認して修正するには、いくつかの方法があります。これらのいずれかを試す前に、影響を評価するために前後のレポートを作成して、セーブセット、ボリューム、クライアント、その他が削除されたかどうかを確認します。
コマンド ラインで、出力をホストするディレクトリーで、次のコマンドを実行して、手順の前後にメディア データベースのプロパティを比較します。
このプロセスを毎日実行できない限り、何かが変わる可能性は低くありません。デーモン ログで nsrim の日次完了を確認します。
このコマンドは、完了するためには、ストレージ ノードがオンラインで接続可能であることを想定しています。
コマンド ラインで、出力をホストするディレクトリーで、次のコマンドを実行して、手順の前後にメディア データベースのプロパティを比較します。
- mminfo-C mminfo-C_pre.mmi
- mminfo-X mminfo-X_pre.mmi
- mminfo-ar "volid、タイプ、場所、プール、ボリューム、状態、volflags、書き込み済み、セーブセット"-q family = disk -xc、 > mminfo-vol_pre.mmi
nsrim - 日次サーバー保護
毎日、Server Protection > Server のバックアップワークフローが実行され、それに伴い有効期限アクションが実行されます。Expirationアクションは、NetWorkerのネイティブ メンテナンス ユーティリティーであるnsrimを実行します。これは直接実行することもできますが、サーバーの負荷とメディア データベースのサイズに応じて、数分から数時間かかる場合があります。
nsrim -X > nsrim.out 2> & 1
このプロセスを毎日実行できない限り、何かが変わる可能性は低くありません。デーモン ログで nsrim の日次完了を確認します。
サービスの再開
NetWorkerサービスを再起動すると、さまざまな起動チェックが強制的に実行され、デーモン ログのエラー メッセージに問題が表示される可能性がありますが、修正される可能性があります。データベースの問題が重大であると思われる場合は、サービスを停止する前に、十分な空き容量があり、ブートストラップの場所がわかっていることを確認します(mminfo -B出力)。理想的には、最初にnsrmmdbasm -s nsr/mm/mmvolrel_path > mm.xdrを実行して、現在のメディア データベース コピーの抽出を試みます。後でフォレンジックまたはリカバリーの目的で必要になる可能性があるため、サービスを再起動する前にmmvolrelフォルダーのコピーを作成します。メディア データベースのエクスポートと再インポート
このプロセスでは、実行可能なメディア データベース レコードのみを抽出し、サービスを停止せずにサーバーに再インポートすることで、完全なディザスター リカバリーを回避します。ただし、これはサーバーがアイドル状態のときにのみ行う必要があり、ジョブの実行中には絶対に試行しないでください。mmvolrelの代わりにフル パスを使用します(インストールまたはオペレーティング システムによって異なる場合があります)。- 作業を開始する前に、アンマウント後にすべてのディスク ボリュームをスキャンが必要としてマークします。ディスク ボリュームをホストするデバイスに対して 自動メディア管理 が設定されている場合は、最初にこれを無効にする必要があります。テープ ボリュームでは、この手順は必要ありません。
- プリアンブルで説明されている mminfo コマンドを実行して、予備レポートを準備します。
- メディア データベースのmmvolrelフォルダーとレコードのサイズを確認します
- nsrck、nsrim、nsrmmdbasmプロセスが実行されていないことを確認します。MMの親フォルダーにmm[英数字]などの大きなファイル、古いファイル、または最近変更されていないファイルがある場合、どのプロセスによってもロックされていない場合は移動または削除します。
- 次のコマンドを実行して、メディア データベースを抽出します:nsrmmdbasm -s mmvolrel > mm.xdr
- 新しいファイルのサイズをmmvolrelフォルダーのサイズと比較します(サイズが似ている場合)。小さい場合(4 Bまたは数KB)、コマンドは失敗しました。大幅に小さい場合は、プロセスの一環として破損したレコードが削除された可能性があります。
- NMC/NWUIでサーバー の状態 フィールドを ディザスター リカバリ ーに設定するか 、nwadminを使用して、サーバーがメディア データベースをリカバリーできるように準備します。
- 再度 nsrmmdbasm コマンドを使用して、メディア データベースの抽出ファイルから直接リカバリーします。nsrmmdbasm -r -2 < mm.xdr
- 完了したら、プリアンブルで説明したのと同じ mminfoを実行し、ボリュームごとに セーブセット と 書き込まれた 値を比較して、すべてのボリュームが存在することを確認します。同様に、 mminfo -C の値は同一である必要があります。
- 不一致がある場合は、メモを取り、続行する方法を慎重に検討してください。表示される結果に確信が持てない場合は、サポートにお問い合わせください。
- 正常と表示されるボリュームについては、[スキャンが必要]フラグを削除してボリュームをマウントできます。 セーブセット と 書き込まれた 値に整合性があれば、ボリュームから削除されたセーブセットがないように見えても、セーブセットが削除される危険性はありません。
- セーブセットの数が少ない、または書き込み合計が少ないボリュームでは、[Scan Needed]フラグをそのままにして、scanner: scanner -i devicenameを実行して、レコードがなくなったボリュームで見つかったファイルを再導入する必要があります。各ボリュームのスキャナーが完了したら、セーブセット数をもう一度確認し、[ Scan Needed]フラグを削除します。欠落していると予想されるセーブセットが スキャナー によって置き換えられたと確信できたら、ボリュームを再マウントします。
nsrdr
nsrdrによって実行されるフル ディザスター リカバリーでは、メディア データベースだけでなく、リソース データベースやジョブ データベースなどの他のサーバー要素もリカバリーされます。次の手順に進む前に、お使いのバージョンの 『Server Disaster Recoveryおよび可用性のベスト プラクティス ガイド 』を参照してください。このコマンドは、完了するためには、ストレージ ノードがオンラインで接続可能であることを想定しています。
メモ: メディア データベースのリカバリーはディスク ボリュームのデータ ロスを招く可能性があるため、質問や懸念事項がある場合は必ずサポートにお問い合わせください。破損や以前のポイント イン タイムへのリカバリーによりメディア データベース レコードがない可能性がある実行可能なセーブセットを使用してファイル システムを保護するために[スキャンが必要]フラグを使用しない場合。
Affected Products
NetWorkerProducts
Data Backup & Protection Software, NetWorker FamilyArticle Properties
Article Number: 000223518
Article Type: Solution
Last Modified: 08 Apr 2024
Version: 1
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