Mainframe Enablers SnapVX: Inconsistent Snapshot Activated When Requesting 'ACTIVATE CONSISTENT YES'

Summary: A consistent copy is attempted, but a timeout occurs due to existing SRDF/A R2 invalid trackswWhen specifying 'ACTIVATE (CONSISTENT(YES))' using Mainframe Enablers SnapVX. An inconsistent copy was created and activated. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A consistent copy is attempted, but a timeout occurs due to existing SRDF/A R2 invalid tracks when specifying ACTIVATE (CONSISTENT(YES)) using Mainframe Enablers SnapVX. The return code (RC) from the ACTIVATE is 8 (MAXRC setting was 4), but an inconsistent copy is still created and activated. 

This issue only occurs in Mainframe Enablers 10.0.0.
EMCSRDFA failed for SRDF/A group 000000nn GK nnnn - inconsistent SRDF/A found 
ESNP119W CONSISTENT COPY ATTEMPTED, BUT TIMEOUT OCCURRED OR UNSUPPORTED DEVICE, COPY NOT CONSISTENT     
ESNPO47E EMC SNAP API - ERROR SUSPENDING SNOW GROUP                                         
ESNPF51I PROCESSING FOR STATEMENT #nn COMPLETED, HIGHEST RETURN CODE ENCOUNTERED IS 8       
ESNP041E MAXRC OF 4 EXCEEDED, PROCESSING TERMINATED                                         
ESNP440I PROCESSING COMPLETED, HIGHEST RETURN CODE ENCOUNTERED IS 8                                     
RQST RC SOURCE                                       TARGET    
2 00 CREATE SNAPSHOT SGC062(snap_shot_name)     
4 08 ACTIVATE - CONSISTENT(YES)

Cause

This is due to a software issue.

When the SRDF/A group fails to suspend, it performs an ACTIVATE of the created snapshots and did not terminate the inconsistent snapshots.

Resolution

Permanent Fix
  • For Mainframe Enablers 10.0.0, PTF SNA0039 is developed to correct the issue. It is available to download from Dell Online Support.

Affected Products

Mainframe Enablers
Article Properties
Article Number: 000223737
Article Type: Solution
Last Modified: 17 Jul 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.