Dell VxRail: Impossibile generare il report Advisory tramite aggiornamento Internet
Summary: Durante l'utilizzo degli aggiornamenti Internet per un sistema VxRail, non viene generato il report di avvertenza.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Durante l'utilizzo degli aggiornamenti Internet per un sistema VxRail, non viene generato il report di avvertenza.
Dal lcm-cvs.log si può vedere che non è stato possibile scaricare il file baseline.json dal server ACG a VxRail Manager /data/store2/cvs/.
Dal registro do-eservices, la richiesta di download sembra essere corretta con 200 restituiti all'inizio.
Non c era alcun nome file nell'intestazione della risposta dopo l'invio della richiesta e questo ha causato il mancato download del file. Il nome file previsto nell'intestazione deve essere VXRAIL_COMPOSITE_7.0.483-28492387_InstallerMetadata_for_7.0.x.zip
Quando si utilizza il metodo manuale per generare il report di consulenza a livello locale, l'operazione ha esito positivo. https://www.dell.com/support/kbdoc/en-us/000214668
Dal lcm-cvs.log si può vedere che non è stato possibile scaricare il file baseline.json dal server ACG a VxRail Manager /data/store2/cvs/.
2024-04-16T01:03:43.815Z <08e780f72702464dfdeabb8d48b7c799> lcm [ERROR] <177> AdvisoryCheckServiceImpl.java run() (169): Failed to generate report com.dellemc.vxrail.cvs.exception.LcmCvsException: Failed to generate advisory report due to no baseline info for 7.0.483-28492387
Dal registro do-eservices, la richiesta di download sembra essere corretta con 200 restituiti all'inizio.
"2024-04-23 23:34:36,152" microservice.do-eservices "2024-04-23T23:34:35.297879805Z stderr F 2024-04-23T23:34:35.297Z <00000000000000000000000000000000> do-eservices [INFO] <140078431866952> httpclient.py get() (139): HTTP Client GET, URL = https://dl.dell.com/downloads/5CX44_VxRail-7.0.483-Composite-Upgrade-Multi-part-Packages-for-7.0.x-part-1-of-10.zip?source=ACG" "2024-04-23 23:34:37,152" microservice.do-eservices "2024-04-23T23:34:36.346725792Z stderr F 2024-04-23T23:34:36.346Z <1c65ddbd7c57478525aedac0b1d52f51> do-eservices [INFO] <140078345899336> request.py log_request() (43): [REQUEST START] Request API: /eservices/download/17138505168762407 GET" "2024-04-23 23:34:37,152" microservice.do-eservices "2024-04-23T23:34:36.346858515Z stderr F 2024-04-23T23:34:36.346Z <1c65ddbd7c57478525aedac0b1d52f51> do-eservices [INFO] <140078345899336> downloadfile.py get() (91): get task 17138505168762407" "2024-04-23 23:34:37,152" microservice.do-eservices "2024-04-23T23:34:36.346942224Z stderr F 2024-04-23T23:34:36.346Z <1c65ddbd7c57478525aedac0b1d52f51> do-eservices [INFO] <140078345899336> taskmanager.py get_task_status( ) (121): got the task in task pool 17138505168762407" "2024-04-23 23:34:37,152" microservice.do-eservices "2024-04-23T23:34:36.347341687Z stderr F 2024-04-23T23:34:36.347Z <1c65ddbd7c57478525aedac0b1d52f51> do-eservices [INFO] <140078345899336> request.py log_response() (119) : [REQUEST END] The request finished successfully. Response status: 200 OK"
Non c era alcun nome file nell'intestazione della risposta dopo l'invio della richiesta e questo ha causato il mancato download del file. Il nome file previsto nell'intestazione deve essere VXRAIL_COMPOSITE_7.0.483-28492387_InstallerMetadata_for_7.0.x.zip
"2024-04-23 23:34:41,152" microservice.do-eservices "2024-04-23T23:34:40.880271966Z stderr F 2024-04-23T23:34:40.880Z <00000000000000000000000000000000> do-eservices [INFO] <140078431866952> download.py download() (297): No file name info in header, use the filename in url=5CX44_VxRail-7.0.483-Composite-Upgrade-Multi-part-Packages-for-7.0.x-part-1-of-10.zip"
Quando si utilizza il metodo manuale per generare il report di consulenza a livello locale, l'operazione ha esito positivo. https://www.dell.com/support/kbdoc/en-us/000214668
Cause
Il server ACG restituisce sempre il codice 200 anche quando non viene fornita alcuna credenziale di supporto. Solo quando viene fornita la credenziale di supporto corretta ACG, rispondere con i dati corretti e un file zip valido.
Resolution
Se si verifica questo problema, contattare il centro di assistenza clienti Dell o il responsabile dell'assistenza per assistenza e citare l'ID di questa soluzione. La procedura per risolvere il problema comporta l'eliminazione dei file e l'accesso a VxRail Manager.
Additional Information
VXEE-13657,VXEE-13676
Article Properties
Article Number: 000224521
Article Type: Solution
Last Modified: 30 Apr 2024
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.