PowerEdge: Broadcom NIC May Drop VLAN-tagged Proprietary Protocol Packets

Summary: Broadcom Network Interface Controller (NIC) cards do not receive proprietary protocol packets such as Remote Maintenance Protocol (RMP).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  1. Application based on some Virtual local area network (VLAN)-tagged proprietary protocol cannot receive the packets.
  2. VLAN-tagged proprietary protocol packets, none of the VLAN-tagged proprietary protocol packets could be captured behind the Broadcom NIC.
  3. The application functions as expected when tested with another brand of NIC or disabling the VLAN tag.
  4. VLAN-tagged proprietary protocol packets are dropped at the Broadcom NIC firmware level, so the NIC dropped packet counter in the Operating System (OS) may not reflect the issue.

Cause

VLAN Length and Type Field definitions are causing this issue.

Resolution

FIX:
Update the firmware of the Broadcom NetXtreme-E Network Device to version 22.92.07.50 or newer.
The fixes listed in the firmware are:

- Correct handling of minimum size VLAN tagged frames with length field
- Random link down events with BCM5741x and VMware
- VMware RDMA not working with some BCM5741x adapters

Workaround:
Disabling VLAN can serve as a workaround for the issue.

Affected Products

C Series, Modular Infrastructure, Rack Servers, Tower Servers, XR Servers, Broadcom NetXtreme Family of Adapters
Article Properties
Article Number: 000225440
Article Type: Solution
Last Modified: 20 May 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.