NetWorker Web UI (NWUI) service does not start after a server reboot

Summary: NetWorker Web UI (NWUI) service does not start after a server reboot even if the service is enabled to automatically start after a reboot.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker Web UI (NWUI) does not start after a server reboot.

Checking the service status returned the message.

# systemctl status nwui
Unit nwui.service could not be found.

The nwui.service file is installed in the default location with the correct permissions.

The nwui.service is enabled to start automatically after a reboot.

Cause

The `nwui.service` fails to initialize because the required `/opt` file system where the NWUI is installed was not mounted at the time of the service unit startup. The `/opt` file system was mounted some time after the initialization attempt, causing the service to fail to start.

Resolution

To ensure that the `nwui.service` starts correctly after a reboot, the service unit file /opt/nwui/scripts/nwui.service must be updated to include dependencies on the required file system. The dependency should be added to the "After" directive under the [unit] section as show below:

# description: NetWorker Management Web UI Server systemd unit file.

[Unit]
Description=NetWorker Management Web UI Server
After=syslog.target network.target opt.mount 

[Service]
...
...

Because nwui.service was modified, run.

# systemctl daemon-reload

Start the service with.

# systemctl start nwui.service

Next time the server is rebooted, the nwui service will start automatically.

 

Article Properties
Article Number: 000227961
Article Type: Solution
Last Modified: 02 Sep 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.