PowerProtect: Resolving Parsing Errors in addon.cfg Configuration File for Oracle Scheduled Backup

Summary: For customers using Dell EMC PowerProtect Data Manager (PPDM) with Oracle database backup, there have been reported issues with scheduled backups. However, ad-hoc manual backups are working without any problems. The root cause has been identified as an empty section in the addon.cfg file ([]), which is a result of the getInstallOracleSidUser() function not handling the output of a specific commandco correctly. This issue is resolved in the upcoming 19.18 release and the next 19.17 patch release. Customers who do not wish to upgrade can request a hotfix for the 19.16 release. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

* Oracle backup scheduled has issues * Adhoc manual backup can work * Python unable to handle INI format configuration file with empty section, like "[]" * Empty section added in addon.cfg file * Noise information added in the map causing empty section * Noise information comes from Imperva Cyber command line * Imperva Cyber discovery of Oracle database interferes with the backup process.

We can see below error message in log:

[2024-07-28 17:00:17,742 GMT| 2024-07-29 01:00:17,743555 +08| APPBACKUPASSETS_89AE63F6DB2D6224| PID-77095| TID-140512660902656| ERROR| TraceContext-TRACE_ID:89ae63f6db2d6224;EXEC_ID:a631207817a80e3d] /opt/dpsapps/agentsvc/tmp/_MEIng5l7D/AddOnManager/AddOnManager.pyc-getAllAddOnsMap()-Line 140- Exception Source contains parsing errors: '/opt/dpsapps/agentsvc/AddOns/D2B24128_9482_44D2_8723_6D211DB49BFB/addon.cfg'               [line 26]: '[]\n' in getAllAddOnsMap.Traceback (most recent call last):  File "AddOnManager/AddOnManager.py", line 126, in getAllAddOnsMap  File "AddOnManager/AddOnManager.py", line 96, in __add2modules  File "AddOnManager/AddOnManager.py", line 87, in instantiateMainClass  File "nsr/AppAgentService/AddOns/D2B24128_9482_44D2_8723_6D211DB49BFB/AddOnMain.py", line 42, in get_instance  File "nsr/AppAgentService/AddOns/D2B24128_9482_44D2_8723_6D211DB49BFB/AddOnMain.py", line 63, in __init__  File "nsr/AppAgentService/AddOns/D2B24128_9482_44D2_8723_6D211DB49BFB/AddOnBase.py", line 1319, in parseConfigFile  File "configparser.py", line 713, in read  File "configparser.py", line 1132, in _readconfigparser.ParsingError: Source contains parsing errors: '/opt/dpsapps/agentsvc/AddOns/D2B24128_9482_44D2_8723_6D211DB49BFB/addon.cfg'               [line 26]: '[]\n'

And we can see there is [] in the addon.cfg automatically.

Cause

The Python is unable to handle the INI format configuration file with empty section, like "[]". If the the configuration is like the followed example it will fail to parse:

[+APX1]
agent_user = oragrid

[ASMCR5R]
agent_user = oracloud

[]
 

So that we can know is the issue comes from the empty section "[]" in the addon.cfg file.

The noise information comes from the Imperva Cyber which used by the customer. Once the Imperva Cyber runs with the Application System Discovery at the same time, the empty section "[]"  will be added into the addon.cfg file. The Imperva Cyber command line looks like:

sh -c /opt/imperva/ragent/bin/db-discovery.sh -d Oracle -f /opt/imperva/ragent/bin/ -r "tnslsnr" -i _pmon_ -e "false" -s "oracle+ASM[A-Za-z0-9]{0,}|asm_d[000-999]|ora_d[000-999]" -a "false" -p 9999 -o /opt/imperva/ragent/var/db_discovery_oracle.txt -ipc 2>>/opt/imperva/ragent/var/stderr_db_discovery.txt
/bin/bash /opt/imperva/ragent/bin/db-discovery.sh -d Oracle -f /opt/imperva/ragent/bin/ -r tnslsnr -i _pmon_ -s oracle+ASM[A-Za-z0-9]{0,}|asm_d[000-999]|ora_d[000-999] -a "false" -p 9999 -o /opt/imperva/ragent/var/db_discovery_oracle.txt -ipc
 

Basically, the Imperva Cyber uses the same way to discovery the Oracle database, but it puts the keyword {}pmon_{_} in the command line, and our function does not handle the output contains Imperva Cyber commands the well.

Resolution

For the issue with the scheduled Oracle backup, you can perform manual backups as a workaround. This issue occurs due to the Python's inability to handle the INI format configuration file with empty sections, like "[]". This issue can be traced back to the addon.cfg file, which contains an empty section. A fix will be available in the 19.18 release and the next 19.17 patch release. If you are using the 19.16 release and do not plan to upgrade, contact Dell Support for further assistance and to request a hotfix. 

Affected Products

PowerProtect Software
Article Properties
Article Number: 000228923
Article Type: Solution
Last Modified: 13 Feb 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.