PowerProtect: SQL 2022 Backups Fail with Cannot Login to SQL Server Error

Summary: SQL 2022 backups fail due to 'Cannot login to SQL Server' error.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SQL 2022 backups fail with an error message indicating that the provider cannot be found.

  • The error message "Provider cannot be found. It may not be properly installed" is displayed.
  • The error code 800a0e7a is encountered.
  • The error description "Unknown error 0x800A0E7A" is displayed.
  • The source of the error is listed as ADODB.Connection.
  • The connection attempt to SQL Server fails.

Cause

The root cause of the issue is the inability of the PPDM to connect to SQL Server using the OLE DB driver version 19.x.x.x.

    The error message also mentions a COM error with code 800a0e7a, indicating a problem with the ADODB.Connection.
    2025-03-18T14:41:51.779Z  Attempting to connect to SQL Server 'SQLVM\SQL2022' using  OLEDB provider:'MSOLEDBSQL'.
    2025-03-18T14:41:51.779Z D:/views/ci/workspace/_appagent_appagent_release_19.18/nsr/db_apps/bsmsql/nsrsqlado.cpp(1595): Entering adoOpenConnectionEx().
    2025-03-18T14:41:51.967Z D:/views/ci/workspace/_appagent_appagent_release_19.18/nsr/db_apps/bsmsql/ns

    Resolution

    Follow these steps to resolve the issue:

    • Install OLE DB driver 18.7.4 or 
    • Install the SQL native driver.
    Article Properties
    Article Number: 000300476
    Article Type: Solution
    Last Modified: 02 May 2025
    Version:  1
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