Firmware updates unintentionally applied to Azure Stack HCI (AX) nodes using OpenManage Enterprise

Summary: Azure Stack Hyper Converged Infrastructure (HCI) (AX) nodes associated to a firmware compliance baseline within OpenManage Enterprise are displayed in the compliance report. While these devices cannot be selected, they are in the firmware compliance job if the 'Select All' checkbox is used. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Azure Stack HCI (AX) nodes are in the firmware compliance baselines that do not exclude the HCI Appliances device group.

Viewing the firmware compliance report, the AX nodes are listed but the device selector is unavailable.

Firmware Compliance report showing an AX node device selector greyed out

However, if the 'Select All' checkbox is used the AX node is in the resulting firmware compliance job.

Firmware Compliance report showing AX-node device selector greyed out after 'Select All' button used

The Azure Stack HCI (AX) node is rebooted if the firmware compliance job includes components that require a restart.

Cause

Missing capability check is resulting in the firmware compliance job being created for AX nodes when leveraging the 'Select All' checkbox.

Resolution

Dell Technologies recommends leveraging OpenManage Integration for Windows Admin Center (OMIWAC) to maintain firmware and drivers for Azure Stack HCI clusters.

A capability check will be in the next release of OpenManage Enterprise, version 4.5.

Until then, the following workarounds should be considered when creating firmware compliance baselines where Azure Stack HCI (AX) nodes are present:

  1. Exclude either the parent HCI Appliances or child AX device group when associating devices to a newly created firmware compliance baseline.
  2. If the firmware compliance baseline includes Azure Stack HCI (AX) nodes, do not use the 'Select All' check box. Rather, select devices individually as to not inadvertently create a firmware compliance job on an Azure Stack HCI (AX) node.

Affected Products

AX-4510C, AX-4520C, AX-640, ax-650, AX-6515, AX-740XD, AX-750, AX-7525, AX-760, Dell EMC OpenManage Enterprise
Article Properties
Article Number: 000311449
Article Type: Solution
Last Modified: 23 Apr 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.