Firmware updates unintentionally applied to Azure Stack HCI (AX) nodes using OpenManage Enterprise
Summary: Azure Stack Hyper Converged Infrastructure (HCI) (AX) nodes associated to a firmware compliance baseline within OpenManage Enterprise are displayed in the compliance report. While these devices cannot be selected, they are in the firmware compliance job if the 'Select All' checkbox is used. ...
Symptoms
Azure Stack HCI (AX) nodes are in the firmware compliance baselines that do not exclude the HCI Appliances device group.
Viewing the firmware compliance report, the AX nodes are listed but the device selector is unavailable.

However, if the 'Select All' checkbox is used the AX node is in the resulting firmware compliance job.

The Azure Stack HCI (AX) node is rebooted if the firmware compliance job includes components that require a restart.
Cause
Missing capability check is resulting in the firmware compliance job being created for AX nodes when leveraging the 'Select All' checkbox.
Resolution
Dell Technologies recommends leveraging OpenManage Integration for Windows Admin Center (OMIWAC) to maintain firmware and drivers for Azure Stack HCI clusters.
A capability check will be in the next release of OpenManage Enterprise, version 4.5.
Until then, the following workarounds should be considered when creating firmware compliance baselines where Azure Stack HCI (AX) nodes are present:
- Exclude either the parent HCI Appliances or child AX device group when associating devices to a newly created firmware compliance baseline.
- If the firmware compliance baseline includes Azure Stack HCI (AX) nodes, do not use the 'Select All' check box. Rather, select devices individually as to not inadvertently create a firmware compliance job on an Azure Stack HCI (AX) node.