Impossible de désinstaller PowerPath en cas d’erreur d’hôte Sun Solaris = l’appareil est occupé
Resumen: Impossible de désinstaller PowerPath en cas d’erreur d’hôte Sun Solaris = l’appareil est occupé
Este artículo se aplica a:
Este artículo no se aplica a:
Este artículo no está vinculado a ningún producto específico.
En este artículo no se identifican todas las versiones de los productos.
Síntomas
pkgrm EMCpower
Impossible de désinstaller PowerPath en cas d’erreur d’hôte Sun Solaris = l’appareil est occupé
pkgrm ne parvient pas à installer PowerPath sur Sun Solaris
Erreur pseudos PowerPath occupés ou installés. Arrêtez toutes les E/S et assurez-vous qu’aucun volume n’est* installé, puis réessayez de supprimer le package.
Impossible de désinstaller PowerPath en cas d’erreur d’hôte Sun Solaris = l’appareil est occupé
pkgrm ne parvient pas à installer PowerPath sur Sun Solaris
Erreur pseudos PowerPath occupés ou installés. Arrêtez toutes les E/S et assurez-vous qu’aucun volume n’est* installé, puis réessayez de supprimer le package.
Causa
----------------------------------------------------------------
* Emcpower Removal :
* Erreur : Les pseudos PowerPath sont toujours en cours d’utilisation, occupés ou installés.
* Arrêtez toutes les E/S et assurez-vous qu’aucun volume n’est
* installé, puis réessayez de supprimer le package.
----------------------------------------------------------------
pkgrm : ERREUR : le script de présuppression ne s’est pas terminé avec succès
Échec de la suppression de <EMCpower>.
* Emcpower Removal :
* Erreur : Les pseudos PowerPath sont toujours en cours d’utilisation, occupés ou installés.
* Arrêtez toutes les E/S et assurez-vous qu’aucun volume n’est
* installé, puis réessayez de supprimer le package.
----------------------------------------------------------------
pkgrm : ERREUR : le script de présuppression ne s’est pas terminé avec succès
Échec de la suppression de <EMCpower>.
Resolución
1.
Vérifiez que les pseudo-périphériques sont toujours installés. Si c’est le cas, désinstallez-les et essayez de désinstaller PowerPath.
Si le problème persiste, -
2.
Vérifiez « fuser -c <pseudo device> » et «fuser -ck <pseudo-device> » et essayez de désinstaller PowerPath.
Si le problème persiste, -
3.
Si le point 2 ne fonctionne pas, redémarrez le système en mode utilisateur unique sans cluster et essayez de désinstaller PowerPath.
Si le problème persiste, -
4.
Si vous obtenez toujours la même « erreur de périphérique occupé », veuillez ouvrir le fichier /etc/system et modifiez la ligne sur « set emcp:bPcEnableInit=0 », puis redémarrez l’hôte en mode utilisateur unique. La valeur « 0 » assure que les modules emcp PowerPath ne seront pas chargés lors du redémarrage (modinfo | grep -i emcp).
Une fois l’hôte redémarré, essayez de désinstaller PowerPath.
Vérifiez que les pseudo-périphériques sont toujours installés. Si c’est le cas, désinstallez-les et essayez de désinstaller PowerPath.
Si le problème persiste, -
2.
Vérifiez « fuser -c <pseudo device> » et «fuser -ck <pseudo-device> » et essayez de désinstaller PowerPath.
Si le problème persiste, -
3.
Si le point 2 ne fonctionne pas, redémarrez le système en mode utilisateur unique sans cluster et essayez de désinstaller PowerPath.
Si le problème persiste, -
4.
Si vous obtenez toujours la même « erreur de périphérique occupé », veuillez ouvrir le fichier /etc/system et modifiez la ligne sur « set emcp:bPcEnableInit=0 », puis redémarrez l’hôte en mode utilisateur unique. La valeur « 0 » assure que les modules emcp PowerPath ne seront pas chargés lors du redémarrage (modinfo | grep -i emcp).
Une fois l’hôte redémarré, essayez de désinstaller PowerPath.
Información adicional
Avant de modifier le fichier /etc/system, vous devez disposer d’une copie du fichier d’origine.
Productos afectados
PowerPath for SolarisProductos
PowerPath for SolarisPropiedades del artículo
Número de artículo: 000064215
Tipo de artículo: Solution
Última modificación: 14 ago 2025
Versión: 5
Encuentra las respuestas que necesitas con la ayuda de otros usuarios de Dell
Servicios de asistencia
Comprueba si tu dispositivo está cubierto por los servicios de asistencia.