ECS: DD Cloud unit disconnected due to http 403 errors - Access Denied

Resumen: Cloud unit disconnected due to http 403 errors - Access Denied issue reporting on Data Domain

Este artículo se aplica a: Este artículo no se aplica a: Este artículo no está vinculado a ningún producto específico. En este artículo no se identifican todas las versiones de los productos.

Síntomas

Nettskyenheten blir frakoblet på grunn av http 403-feil med problem med ingen tilgang.

Følgende feil vil rapportere om DD.
03/21 07:22:01.838 (tid 0x6991b0): ERROR: CSM cl_curl_write_cb:1680 - Request failed with httpcode:403
03/21 07:22:01.838 (tid 0x6991b0): ERROR: CSM cl_request_convert_httpcode_to_err:1554 - HTTP operation returned code:403, request error:Access Denied [5075], uri:https://emcecs.xxxxxxx.xx.xx:9021/?endpoint, date:Tue, 21 Mar 2023 03:22:01 GMT, bytes_sent:0, bytes:rcvd:0
03/21 07:22:01.838 (tid 0x6991b0): ERROR: csm_provider_version_check:496 - Error (Access Denied) getting the provider version for cloud profile: EMC-ECS
03/21 07:22:01 ERROR: csm_provider_version_check:496 - Error (Access Denied) getting the provider version for cloud profile: EMC-ECS
04/03 18:46:49.710 (tid 0x699060): ERROR: csm_validate_profile_internal:445 - list_bucket failed for profile cloud-ecs101_profile_profile with err 5075: Access Denied
04/03 18:46:49 ERROR: csm_validate_profile_internal:445 - list_bucket failed for profile cloud-ecs101_profile_profile with err 5075: Access Denied

På ECS , kpi.sh for den berørte kurven viser 403 feil.
Extracting RequestLog data:        DONE

                                 All Requests                                           500 Errors
Node             GETs      PUTs      POSTs     DELETEs   HEADs    Total     GETs    PUTs    POSTs   DELETEs  HEADs   Total
10.xx.xx.001     0         0         0         0         0        0         0       0       0       0        0       0
10.xx.xx.002     0         0         0         0         0        0         0       0       0       0        0       0
10.xx.xx.003     0         0         0         0         0        0         0       0       0       0        0       0
10.xx.xx.004     1         0         0         0         0        1         0       0       0       0        0       0
10.xx.xx.005     0         0         0         0         0        0         0       0       0       0        0       0
10.xx.xx.006     0         0         0         0         0        0         0       0       0       0        0       0
10.xx.xx.007     0         1         0         0         0        1         0       0       0       0        0       0
10.xx.xx.008     0         0         0         0         0        0         0       0       0       0        0       0

Req Totals:      1         1         0         0         0        2         0       0       0       0        0       0
Req Error %:                                                                0.00    0.00    0.00    0.00     0.00    0.00

------------------------------------------------------------------------------------------------------------------------
Error Summary - All Error Codes
------------------------------------------------------------------------------------------------------------------------
Error Code        GET        PUT        POST       HEAD       DELETE     Total

403               1          1          0          0          0          2

Error Totals      1          1          0          0          0          2
------------------------------------------------------------------------------------------------------------------------

Etter at du har sporet 403-feilene, vises følgende varsel om tidsforskyvning i logger.
169.254.1.7 dataheadsvc.log.20230413-213831.gz 2023-04-13T15:32:10,334 [qtp1744025389-1494616-0a112bbb:184289e9ad9:fe3c0:4-s3-10.xx.xx.002] ERROR  V2Signer.java (line 168) client/server time skewed. RequestId 0a112bbb:184289e9ad9:fe3c0:4

Causa

Klokkeslettet er ikke synkronisert med NTP på verken Data Domain eller ECS.

Resolución

1. Kjør den nyeste versjonen av xDoctor for å sikre at det ikke er rapportert noen tidssynkronisering eller NTP-problemer. 

2. Kontroller systemtiden og maskinvareklokken på alle noder. 
admin@ecsnode1:~> viprexec "hwclock; date"

Output from host : 192.168.219.2
2023-04-14 07:40:03.749250+0000
Fri Apr 14 07:40:04 UTC 2023

Output from host : 192.168.219.3
2023-04-14 07:40:03.748930+0000
Fri Apr 14 07:40:04 UTC 2023

Output from host : 192.168.219.7
2023-04-14 07:40:03.747903+0000
Fri Apr 14 07:40:04 UTC 2023

Output from host : 192.168.219.1
2023-04-14 07:40:03.749030+0000
Fri Apr 14 07:40:04 UTC 2023

Output from host : 192.168.219.4
2023-04-14 07:40:03.749111+0000
Fri Apr 14 07:40:04 UTC 2023

Output from host : 192.168.219.8
2023-04-14 07:40:03.748931+0000
Fri Apr 14 07:40:04 UTC 2023

Output from host : 192.168.219.5
2023-04-14 07:40:03.733340+0000
Fri Apr 14 07:40:04 UTC 2023

Output from host : 192.168.219.6
2023-04-14 07:40:03.729096+0000
Fri Apr 14 07:40:04 UTC 2023

3. Hvis du finner et problem med tidssynkronisering eller manglende maskinvareklokke på ECS-noder, kan du samarbeide med Dells kundestøtte for å løse problemet.

4. Hvis klokkeslettet er synkronisert på alle ECS-noder, kan problemet være på Data Domain.

5. Koble til Data Domain-støtte for å kontrollere og korrigere tids- eller NTP-problemer på Data Domain. 

6. Kontroller status for nettskyenheten.

Productos afectados

ECS, Elastic Cloud Storage
Propiedades del artículo
Número de artículo: 000212712
Tipo de artículo: Solution
Última modificación: 08 jun 2023
Versión:  2
Encuentra las respuestas que necesitas con la ayuda de otros usuarios de Dell
Servicios de asistencia
Comprueba si tu dispositivo está cubierto por los servicios de asistencia.