「Dell EMC Unity:構成されたプロキシを使用したテクニカル アドバイザリーの取得に失敗する(ユーザー修正可能)」

Riepilogo: テクニカル アドバイザリーの受信エラー

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Unisphereからテクニカル アドバイザリーを取得しようとすると、次のエラー メッセージが生成されます。

There was an error when retrieving catalog from Dell EMC through configured proxy (Error Code:0x6400bda)’

EMCSystemLogFile.logのメッセージは、次のとおりです。
2021-01-28T17:09:09.974Z" "xxx_spb@APM00123456789" "Neo_CEM" "17037" "local/admin" "WARN" "14:380012" :: "Failed to get technical advisory with configured proxy http://proxy.FQDN.com:8080." :: Category=User Component=EmcSupportServices TimeZone=UTC


プロキシ サーバーとの接続をチェックするcurlコマンドが失敗しています。

# curl -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:」 -v

Hostname was NOT found in DNS cache
Could not resolve host: colu.emc.com
Closing connection 0
curl: (6) Could not resolve host: colu.emc.com


curlコマンドへのプロキシ サーバーへの追加が成功しました。

# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1...   (proxy server IP)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive


<--切れ目-->
(メモのすべての出力を参照)

Causa

この場合、お客様はDNSサーバーへの直接アクセスを許可しておらず、取得にはプロキシ サーバーのみを使用しています。  この問題の原因は、Unityとプロキシ サーバー間のデータ転送が完了する前に、colu.emc.comとプロキシ サーバー間の接続が閉じられてしまうことです。  これは、curlの接続処理方法に起因するようです。

Risoluzione

解決策
この問題は、Dell EMC Unity OEの今後のリリースで解決の予定です。  アップデートについては、ナレッジベース記事をご覧ください。

回避策
テクニカル アドバイザリーの取得にプロキシ サーバーを使用しないでください。または、この問題が修正されたコードがリリースされるまでは、Unisphereの一時的なバイパスを設定してください。

Informazioni aggiuntive

curlコマンドに「プロキシ サーバーのURL」を追加すると、次のようなメッセージが表示されます。

# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1...   (proxy server IP)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive
>
< HTTP/1.1 200 Connection established
<
* Proxy replied OK to CONNECT request
* successfully set certificate verify locations:
* CAfile: none
CApath: /etc/ssl/certs/
* SSLv3, TLS handshake, Client hello (1):
*SSLv3, TLS handshake, Server hello (2):
* SSLv3, TLS handshake, Certificate (11):
* SSLv3, TLS handshake, Server key exchange (12):
* SSLv3, TLS handshake, Server finished (14):
*SSLv3, TLS handshake, Client key exchange (16):
*SSLv3, TLS change cipher, Client hello (1):
*SSLv3, TLS handshake, Finished (20):
*SSLv3, TLS change cipher, Client hello (1):
*SSLv3, TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384
* Server certificate:
* subject: C=US; ST=Texas; L=Round Rock; O=Dell; CN=colu.emc.com
* start date: 2020-08-25 03:21:00 GMT
* expire date: 2022-08-25 03:21:00 GMT
* subjectAltName: colu.emc.com matched
* issuer: C=US; O=Entrust, Inc.; OU=See www.entrust.net/legal-terms; OU=(c) 2012 Entrust, Inc. - for authorized use only; CN=Entrust Certification Authority - L1K
* SSL certificate verify ok.

Prodotti interessati

Dell EMC Unity Family
Proprietà dell'articolo
Numero articolo: 000182700
Tipo di articolo: Solution
Ultima modifica: 19 ago 2021
Versione:  3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.